Results 1 to 10 of 12

Thread: Split Dns setup

Hybrid View

  1. #1
    Join Date
    Sep 2012
    Posts
    24
    Rep Power
    3

    Default Split Dns setup

    I have read the various posts and docs about split dns, but it still seems to have issues:
    Here are the responses to the commands that involve thiese issues. When I run the install.sh script it reports a dns mx problem.

    Code:
    [root@zimbrahost axiomcrs]# host `hostname`
    zimbrahost.axiomcomputerservices.com has address 63.251.179.13
    zimbrahost.axiomcomputerservices.com has address 8.15.7.117
    Host zimbrahost.axiomcomputerservices.com not found: 3(NXDOMAIN)
    Code:
    [root@zimbrahost axiomcrs]# dig axiomcomputerservices.com mx
    
    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.3 <<>> axiomcomputerservices.com mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9516
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;axiomcomputerservices.com.	IN	MX
    
    ;; ANSWER SECTION:
    axiomcomputerservices.com. 5274	IN	MX	0 axiomcomputerservices.com.
    
    ;; ADDITIONAL SECTION:
    axiomcomputerservices.com. 5274	IN	A	74.104.135.114
    
    ;; Query time: 2 msec
    ;; SERVER: 10.3.0.3#53(10.3.0.3)
    ;; WHEN: Tue Sep 25 13:53:48 2012
    ;; MSG SIZE  rcvd: 75
    Code:
    [root@zimbrahost axiomcrs]# dig axiomcomputerservices.com any
    
    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.3 <<>> axiomcomputerservices.com any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13281
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 0, ADDITIONAL: 3
    
    ;; QUESTION SECTION:
    ;axiomcomputerservices.com.	IN	ANY
    
    ;; ANSWER SECTION:
    axiomcomputerservices.com. 5231	IN	A	74.104.135.114
    axiomcomputerservices.com. 8336	IN	NS	ns2.bluehost.com.
    axiomcomputerservices.com. 8336	IN	NS	ns1.bluehost.com.
    axiomcomputerservices.com. 8336	IN	SOA	ns1.bluehost.com. root.box603.bluehost.com. 2012091400 86400 7200 3600000 300
    axiomcomputerservices.com. 5231	IN	MX	0 axiomcomputerservices.com.
    axiomcomputerservices.com. 14400 IN	TXT	"v=spf1 a mx ptr include:bluehost.com ?all"
    
    ;; ADDITIONAL SECTION:
    ns2.bluehost.com.	2150	IN	A	69.89.16.4
    ns1.bluehost.com.	2140	IN	A	74.220.195.31
    axiomcomputerservices.com. 5231	IN	A	74.104.135.114
    
    ;; Query time: 98 msec
    ;; SERVER: 10.3.0.3#53(10.3.0.3)
    ;; WHEN: Tue Sep 25 13:54:31 2012
    ;; MSG SIZE  rcvd: 270
    [
    Code:
    root@zimbrahost axiomcrs]# cat /etc/hosts
    127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
    10.3.0.99 zimbrahost.axiomcomputerservices.com
    [root@zimbrahost axiomcrs]# cat /etc/resolv.conf
    nameserver 10.3.0.3
    nameserver 71.243.0.12
    nameserver 10.3.0.99
    [root@zimbrahost axiomcrs]#
    Last edited by phoenix; 09-25-2012 at 11:11 AM. Reason: Code tags!

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You're hosts file is incorrect, your resolv.conf file is incorrect and you have invalid DNS A & MX records - the only article you need to read is the one in the wiki - that article tells you all you need to know about the format of your MX records (compare yours to the example - hint: check the FQDN), the A record (specifically the IP address to which it points), the resolv.conf (how many and which DNS servers should be in there) and the hosts file (specifically the IP address and the FQDN of your ZCS server). When you've checked those and corrected the you should run all the commands in the 'Verify....' section of that article and post the output here - to make the output more readable please enclose each bit of output in code tags to make it easier to read (see your post above after my edit).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Sep 2012
    Posts
    24
    Rep Power
    3

    Default

    After restarting the named daemon I get:

    Code:
    root@zimbrahost named]# /etc/init.d/named restart
    Stopping named:                                            [  OK  ]
    Starting named: 
    Error in named configuration:
    db.zimbrahost.axiomcomputerservices.com:1: no TTL specified; using SOA MINTTL instead
    db.zimbrahost.axiomcomputerservices.com:8: NS record '10.3.0.99' appears to be an address
    db.zimbrahost.axiomcomputerservices.com:10: ignoring out-of-zone data (axiomcomputerservices.com)
    dns_rdata_fromtext: db.zimbrahost.axiomcomputerservices.com:10: near 'zimbrahost.axiomcomputerservices.com.': not a valid number
    zone zimbrahost.axiomcomputerservices.com/IN: loading from master file db.zimbrahost.axiomcomputerservices.com failed: not a valid number
    zone zimbrahost.axiomcomputerservices.com/IN: not loaded due to errors.
    _default/zimbrahost.axiomcomputerservices.com/IN: not a valid number
                                                               [FAILED]
    [root@zimbrahost named]#
    I am following the bind part of the wiki. Here is named.conf:

    Code:
    [root@zimbrahost named]# cat /etc/named.conf
    //
    // named.conf
    //
    //
    
    options {
    	directory 	"/var/named";
    	dump-file 	"/var/named/data/cache_dump.db";
            statistics-file "/var/named/data/named_stats.txt";
    	forwarders { 10.3.0.3 ; };
    };
    
    zone "zimbrahost.axiomcomputerservices.com" {
    	type master;
    	file "db.zimbrahost.axiomcomputerservices.com";
    };
    [root@zimbrahost named]#

    The db.server zone file is:

    Code:
    [root@zimbrahost named]# cat /var/named/db.zimbrahost.axiomcomputerservices.com 
    @	IN	SOA	zimbrahost.axiomcomputerservices.com.	hostmaster.zimbrahost.axiomcomputerservices.com. (
    			10118	;
    			43200	;
    			3600	;
    			3600000	;
    			2592000 ) ;
    
    	IN	NS	10.3.0.99
    
    axiomcomputerservices.com.	IN	MX	zimbrahost.axiomcomputerservices.com.
    zimbrahost.axiomcomputerservices.com.	IN	A	10.3.0.99
    [root@zimbrahost named]#

    The /etc/hosts file is:

    Code:
    [root@zimbrahost named]# cat /etc/hosts
    127.0.0.1   zimbrahost zimbrahost.axiomcomputerservices.com
    10.3.0.99 zimbrahost.axiomcomputerservices.com
    [root@zimbrahost named]#
    resolv.conf is:

    Code:
    [root@zimbrahost named]# cat /etc/resolv.conf
    search axiomcomputerservices.com
    nameserver 127.0.0.1
    nameserver 10.3.0.3
    nameserver 71.243.0.12
    nameserver 10.3.0.99
    [root@zimbrahost named]#

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Why have you not fixed your hosts file and your resolv.conf files?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Sep 2012
    Posts
    24
    Rep Power
    3

    Default

    The instructions for the bind section does not actually say to edit the hosts file. That part of the wiki applies to the dnsmasq configuring. Here is my hosts:

    Code:
    [root@zimbrahost named]# cat /etc/hosts
    127.0.0.1   localhost.localdomain localhost
    10.3.0.99 zimbrahost.axiomcomputerservices.com
    [root@zimbrahost named]#
    My resolv.conf file looks right to me.

  6. #6
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    In your zone file the "NS" record should contain a FQDN (ie zimbrahost.axiomcomputerservices.com) instead of the IP address and your "MX" record needs a priority number (ie 10) in front of the server name. Those are the two issues that jump out at me based on the error messages you are getting when you try to start named.

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by axiomcrs View Post
    The instructions for the bind section does not actually say to edit the hosts file.
    No but the ZCS Installation instructions do as does the 'Verify...' section of the wiki article.

    Quote Originally Posted by axiomcrs View Post
    That part of the wiki applies to the dnsmasq configuring.
    You're mistaken, the 'Verify...' section is a completely separate section in the article and it's description of the hosts & resolv file applies to your server whichever DNS server is in use.

    Quote Originally Posted by axiomcrs View Post
    Here is my hosts:

    Code:
    [root@zimbrahost named]# cat /etc/hosts
    127.0.0.1   localhost.localdomain localhost
    10.3.0.99 zimbrahost.axiomcomputerservices.com
    [root@zimbrahost named]#
    My resolv.conf file looks right to me.
    Your resolv file is not correct and both files require modifying as described in the article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Split DNS setup problems.
    By xxthegonzxx in forum Installation
    Replies: 1
    Last Post: 11-25-2011, 06:54 AM
  2. ZCA Split-DNS setup with Windows Server DNS
    By yonatan in forum Virtualization
    Replies: 3
    Last Post: 10-16-2010, 03:29 AM
  3. Split-DNS setup possible with the ZCA?
    By yonatan in forum Virtualization
    Replies: 8
    Last Post: 08-24-2010, 11:05 PM
  4. problems with split domain/dns setup
    By xkill911 in forum Administrators
    Replies: 3
    Last Post: 08-12-2009, 08:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •