Results 1 to 3 of 3

Thread: Error attempting to create a new tag

Hybrid View

  1. #1
    Join Date
    Oct 2005
    Posts
    181
    Rep Power
    10

    Default Error attempting to create a new tag

    Here's an error message I get trying to create a new tag in the web client.

    message - thisHtmlElement has no properties
    fileName - https://our.host.name/zimbra/js/Ajax...v=050920160141
    lineNumber - 1821
    stack - ([object Object],1)@https://our.host.name/zimbra/js/Ajax_all.js.jgz?v=050920160141:1821
    (1)@https://our.host.name/zimbra/js/Ajax_all.js.jgz?v=050920160141:1751
    DwtTreeItem([object Object],1,"Test tag 1",[object Array])@https://our.host.name/zimbra/js/Ajax_all.js.jgz?v=050920160141:1715
    ([object Object],[object Object],1)@https://our.host.name/zimbra/js/ZimbraMail_all.js.jgz?v=050920160141:572
    ([object Object])@https://our.host.name/zimbra/js/ZimbraMail_all.js.jgz?v=050920160141:589
    call([object Object],[object Object])@:0
    ([object Object])@https://our.host.name/zimbra/js/ZimbraMail_all.js.jgz?v=050920160141:600
    call([object Object],[object Object])@:0
    ([object Object])@https://our.host.name/zimbra/js/Ajax_all.js.jgz?v=050920160141:472
    call([object Object],[object Object])@:0
    ([object Object])@https://our.host.name/zimbra/js/Ajax_all.js.jgz?v=050920160141:476
    (1,[object Object])@https://our.host.name/zimbra/js/Ajax_all.js.jgz?v=050920160141:460
    (1,[object Object])@https://our.host.name/zimbra/js/ZimbraMail_all.js.jgz?v=050920160141:163
    ([object Object])@https://our.host.name/zimbra/js/ZimbraMail_all.js.jgz?v=050920160141:271
    ([object Object],undefined)@https://our.host.name/zimbra/js/ZimbraMail_all.js.jgz?v=050920160141:4158
    ([object Object])@https://our.host.name/zimbra/js/ZimbraMail_all.js.jgz?v=050920160141:4142
    ([object Object])@https://our.host.name/zimbra/js/ZimbraMail_all.js.jgz?v=050920160141:4128
    ([object Object])@https://our.host.name/zimbra/js/ZimbraMail_all.js.jgz?v=050920160141:4087
    ("Test tag 1",4)@https://our.host.name/zimbra/js/ZimbraMail_all.js.jgz?v=050920160141:270
    ([object Object])@https://our.host.name/zimbra/js/ZimbraMail_all.js.jgz?v=050920160141:1305
    call([object Object],[object Object])@:0
    ((function (params) {var parent = params.parent || this._appCtxt.getTagList().root;try {parent.create(params.name, params.color);} catch (ex) {if (ex.code == ZmCsfeException.MAIL_INVALID_NAME) {var msg = AjxStringUtil.resolve(ZmMsg.errorInvalidName, params.name);this._msgDialog.setMessage(msg, DwtMessageDialog.CRITICAL_STYLE);this._msgDialog.p opup();} else {this._handleException(ex, ZmTagTreeController.prototype._doCreate, params, false);}}}),[object Object],0)@https://our.host.name/zimbra/js/ZimbraMail_all.js.jgz?v=050920160141:1101
    apply([object Object],[object Array])@:0
    (2259)@https://our.host.name/zimbra/js/Ajax_all.js.jgz?v=050920160141:451
    @https://our.host.name/zimbra/js/Ajax_all.js.jgz?v=050920160141:448

    name - TypeError

    The tag gets created but the error dialogue box appears at each new tag creation attempt. Cant say when it started to do this as Ive just started using this server in a live test environment. (names changed to protect innocent hardware ;-)

    Any ideas?

    Thanks

    Kevin

  2. #2
    Join Date
    Sep 2005
    Location
    Sunnyvale, CA
    Posts
    269
    Rep Power
    10

    Default

    If you dont mind, try the following so we can get a better idea of where the bug is:

    - append "?gzip=false&mode=mjsf" (w/o quotes) to the end of the url and try to repro this bug again.

    Adding this string to your url will turn off gzip and file aggregation so we can pinpoint the JS error.

    Once you get the JS error, post the line number w/ the filename. Thanks.

  3. #3
    Join Date
    Oct 2005
    Posts
    181
    Rep Power
    10

    Default Odd behaviour - but..

    ...once I had deleted the tags (with the same error) logged out and for other reasons restarted Zimbra server, the tags now get created without error. Perhaps once initially created the something changed but I wouldnt have thought that from the type of error? Anyway as I now cant replicate the error I cant pass more info on but I'll bear the url in mind for any future errors

    Thanks

    Kevin

Similar Threads

  1. Fedora 5: Could not create the Java virtual machine
    By mi2enno in forum Installation
    Replies: 6
    Last Post: 06-01-2007, 03:16 AM
  2. Opensource backup Question.
    By nfear24 in forum Administrators
    Replies: 3
    Last Post: 03-31-2007, 11:47 PM
  3. Create a group by a tag
    By nicoleplace in forum Users
    Replies: 3
    Last Post: 03-07-2007, 01:57 PM
  4. Tag Weirdness
    By chalkboy in forum Administrators
    Replies: 1
    Last Post: 01-03-2007, 10:40 AM
  5. Create tag bug in create new filter
    By PotatoBob in forum Developers
    Replies: 3
    Last Post: 10-31-2005, 08:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •