Results 1 to 5 of 5

Thread: Compiling source

Hybrid View

  1. #1
    Join Date
    Dec 2006
    Posts
    11
    Rep Power
    8

    Default Compiling source

    Any love or luck for freeBSD servers?
    I grabbed the source from SVN but there were no make files.
    Please help me out.

  2. #2
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default Search first!

    Some folks have had success. Read this forum thread for details...
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Dec 2006
    Posts
    11
    Rep Power
    8

    Default postfix woes?

    Im havign problems with the postfix portion of things. First it was 1000's of gmake errors then i did some messign around and ive gotten through a few more problems. I'm not sure that where I am at now doesnt have somethign to do with what I have been trying. as things stand I am getting errors from postfix-install when it tries to do the non interactive install

    postfix-install: Error: "" should be "no" or an absolute path name.
    /libexec/ld-elf.so.1: Shared object "libsasl2.so.2" not found, required by "postconf" also comes up a number of times right before that error evne though i have ensured that the files is present with correct permissions and is in one (or at this point more) of the paths specified in the Makefile.

    Anyone come across anythign similar?
    -J

  4. #4
    Join Date
    Jan 2007
    Posts
    121
    Rep Power
    8

    Exclamation

    Quote Originally Posted by FloydWilliams View Post
    Im havign problems with the postfix portion of things. First it was 1000's of gmake errors then i did some messign around and ive gotten through a few more problems. I'm not sure that where I am at now doesnt have somethign to do with what I have been trying. as things stand I am getting errors from postfix-install when it tries to do the non interactive install

    postfix-install: Error: "" should be "no" or an absolute path name.
    /libexec/ld-elf.so.1: Shared object "libsasl2.so.2" not found, required by "postconf" also comes up a number of times right before that error evne though i have ensured that the files is present with correct permissions and is in one (or at this point more) of the paths specified in the Makefile.

    Anyone come across anythign similar?
    -J
    We are also coming across the thousands of gmake erros from postfix. Have not solved yet and will keep posted.

  5. #5
    Join Date
    Dec 2006
    Posts
    11
    Rep Power
    8

    Default

    I could have sworn I had nother post on this thread already with my solution.
    I needed to copy the tar.gz into the 2.2.9 directory and then perfomr a full clean build. I was buildign in a jail and made a copy of the jail at a number of stages so i coudl easily back out changes I made. Also there is no src directory under mysql so the tarball accidently got copied in as src the first time i did it so i made the directory and put the tarball into it in the future attempts. I had bad luck trying to resume a build even after putting things in order. Maybe I was just unlucky but it was easy to retry with my saved jails. I saved one of a clean make world one with all the simbra stuff before the path then all the thirdparty files in place and the patch installed ready to build.

    Good luck and feel free to get in touch if you need help.

Similar Threads

  1. Installs but won't start on Linux FC6
    By iain in forum General Questions
    Replies: 6
    Last Post: 03-29-2007, 11:19 AM
  2. Compiling Zimbra Source
    By raghu in forum Developers
    Replies: 1
    Last Post: 04-12-2006, 09:25 AM
  3. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM
  4. Zimbra on Debian?
    By omry_y in forum Installation
    Replies: 25
    Last Post: 11-04-2005, 11:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •