Results 1 to 3 of 3

Thread: Zimbra with PHP.INI

  1. #1
    Join Date
    Dec 2006
    Posts
    14
    Rep Power
    9

    Default Zimbra with PHP.INI

    Hello, after installing Zimbra we've updated the PHP.INI changing the sendmail_path to the zimbra (opt/...).

    The "problem" is that after restarting apache, with the phpinfo function the sendmail_path variable still shows "/usr/sbin/sendmail -t -i".

    We've edited the PHP.INI and appears the new sendmail_path, but seems like if php didn't "refresh" the settings.

    We've tried to stop apache, start it again with same result.

    It's possible to send email from Zimbra, all protocols, and also SMTP via PHP, but the mail() function of PHP doesn't work "sending no email".

    My question is: should we change the sendmail_path anywhere else than php.ini? Does this problem happen because we haven't rebooted the server?

    We're using CentOS with 64bit support.

    Thank you for your help!

  2. #2
    Join Date
    Dec 2006
    Posts
    14
    Rep Power
    9

    Default Autoanswer :)

    Well... maybe it's an uncommon "problem", but as we've solved it, I think it would be nice to share the solution, just in case someone had this problem also:

    The problem was with some CentOS restrictions (SELinux).

    Changing it and rebooting the server, the PHP.INI has been "updated" after the changes we made, and everything works fine

    Regards.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by aalcaine View Post
    The problem was with some CentOS restrictions (SELinux).
    SELinux should be disabled on any server that has Zimbra on it, it's a requirement mentioned in the documentation.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 26
    Last Post: 04-19-2011, 10:24 AM
  2. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  3. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  4. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 07:18 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 05:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •