Hoping someone can provide advice here...

I have a server running RHEL 4 x86_64 with ZCS 7.2.1; I want to move to a new machine running RHEL 6.3 x86_64 and upgrade to ZCS 8.0.0

I tried to rsync the full 7.2.1 /opt/zimbra across, I ran the RHEL 4 installer for 7.2.1 which doesn't work so I tried running the installation 7.2.1 for RHEL 6. That worked but the software wouldn't start.

I tried upgrading that 7.2.1 to 8.0.0 hoping the new release would install and resolve things only to receive this:
Fri Oct 19 12:12:46 2012: Dropping IM tables...
Fri Oct 19 12:12:47 2012: Verified schema version 65.
Fri Oct 19 12:12:47 2012: Updating DB schema version from 65 to 90.
Running /opt/zimbra/libexec/scripts/migrate20120410-BlobLocator.pl
PS1: ""
Fri Oct 19 12:12:50 2012: Verified schema version 90.
Fri Oct 19 12:31:33 2012: Verified schema version 90.
Fri Oct 19 12:31:33 2012: Updating DB schema version from 90 to 91.
PS1: ""
Stopping mysql...PS1: ""
done.
PS1: ""
Updating from 8.0.0_BETA1
Adding dynamic group configuration
Can't call method "get_value" on an undefined value at /opt/zimbra/libexec/zmupgrade.pm line 4047, line 7.


I have not been able to find a good resource for how to upgrade both the operating system and Zimbra... I am really bummed that support for RHEL4 is gone. The nature of our business requires mail 7x24 so I cannot have my mail services down for extended durations, I have to keep my outage windows as small as possible which is why I am trying to move to a new server. Doing an OS upgrade on the current server is not an option because the upgrade itself is time consuming and if it doesn't work, recovery is too time consuming as well.

Any suggestions would be helpful!
Robert