Results 1 to 4 of 4

Thread: Relay per Domain not working after upgrade to 8.0.0 OSE

Threaded View

  1. #1
    Join Date
    Nov 2011
    Posts
    11
    Rep Power
    4

    Exclamation Relay per Domain not working after upgrade to 8.0.0 OSE

    Hi,
    here's basic info and problem:

    Zimbra: Release 8.0.0.GA.5434.UBUNTU12.64 UBUNTU12_64 FOSS edition.

    Upgrade history:
    7.1.3_GA_3346.UBUNTU10_64
    7.2.0_GA_2669.UBUNTU10_64
    UBUNTU10_64 -> UBUNTU12.64
    8.0.0.GA.5434.UBUNTU12.64

    Corporational network architecture. Zimbra is used as local (LAN) workgroup system and mail with localdomain (nor registered or visible in Internet) and mail traffic (SMNP/POP/IMAP) is not allowed outside corporate network.
    Beside that there are 10 mail shared accounts (like department accounts) in external domain hosted in remote server in WAN, but still not in Internet. Mail traffic from this server is allowed in/out corporate network.
    This external domain is reflected in Zimbra and mails from remote server are fetched and delivered in Zimbra to corresponding local accounts. This way using external accounts is easier for users - it is the same as local account.
    Local accounts in external domain are shared and users with rights to use it have created persona to send emails to the outside world. This accounts have main transport defined in settings as smtp:externalserver.com:25 (externalserver.com IP:y.y.y.y). In Zimbra 8 they are granted sendAs right.
    Only problem was relying mails from local copies of external accounts through remote server. It was solved per Relay per Domain - Zimbra :: Wiki

    Problem
    After upgrade to 8.0.0 relaying per domain stopped working. Of course changes to Postfix configuration were reapplied after Zimbra upgrade.
    Investigation showed that after changes introduced/related to zimbraAllowFromAddress/sendOnBehalfOf/sendAs

    BUG67091 - Support creating persona for addresses for which user has been granted sendAs/sendOnBehalfOf rights
    BUG66387 - zimbraAllowFromAddress pref should exclude internal accounts

    all mails at postfix level are seen as sent by local user (even mails sent from external domain and mails sent with external account

    Before upgrade
    Code:
    Nov 19 12:32:14 hermes opendkim[11339]: 1ED6FC22C7: no signing table match for 'extaccount@externalserver.com'
    Nov 19 12:32:14 hermes postfix/qmgr[16643]: 1ED6FC22C7: from=< extaccount@externalserver.com >, size=1316, nrcpt=1 (queue active)
    ...
    Nov 19 12:32:22 hermes postfix/smtp[19025]: 8A70EC2BD1: to=< john@mail.com >, relay=externalserver.com[y.y.y.y]:25, delay=0.18, delays=0/0/0.08/0.1, dsn=2.0.0, status=sent (250 Queued! 1353324742 qp 30605 < 917622890.48.1353324733935.JavaMail.root@externalserver.com >)
    After upgrade
    Code:
    Nov 19 11:48:04 hermes opendkim[2267]: 2BBAEC2D64: no signing table match for 'extaccount@externalserver.com'
    Nov 19 11:48:04 hermes postfix/qmgr[4453]: 2BBAEC2D64: from=< localuser@internalserver.com >, size=1571, nrcpt=1 (queue active)
    ...
    Nov 19 11:48:12 hermes postfix/smtp[8092]: 2BBAEC2D64: to=< john@mail.com >, relay=127.0.0.1[127.0.0.1]:10026, delay=8.5, delays=0.05/0/0/8.4, 
    dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 99581C2D60)
    ...
    Nov 19 11:48:42 hermes postfix/smtp[7609]: connect to mail.com[z.z.z.z]:25: Connection timed out
    Nov 19 11:48:42 hermes postfix/smtp[7609]: 99581C2D60: to=< john@mail.com >, relay=none, delay=30, delays=0/0/30/0, dsn=4.4.1, 
    status=deferred (connect to mail.com[z.z.z.z]:25: Connection timed out)
    Question
    Is there a workaround to the problem? Any suggestions? Is this a bug that should be reported? Any help appreciated.
    Last edited by b0rek; 11-27-2012 at 02:04 AM. Reason: not all visible in logs

Similar Threads

  1. Relay per domain
    By xray0045 in forum Administrators
    Replies: 1
    Last Post: 11-30-2012, 02:01 AM
  2. [SOLVED] specify relay for a certain domain
    By maxxer in forum Administrators
    Replies: 2
    Last Post: 08-31-2010, 01:56 AM
  3. Use Zimbra as relay for one domain
    By zagg in forum Administrators
    Replies: 3
    Last Post: 11-26-2009, 09:30 AM
  4. Relay per Domain is not working
    By Savage82 in forum Administrators
    Replies: 0
    Last Post: 09-24-2009, 04:21 AM
  5. How to add relay domain to postfix
    By borispr in forum Administrators
    Replies: 2
    Last Post: 07-31-2008, 07:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •