I installed 4.0.2 just fine in a multi machine configuration. Then our license expired so I downloaded a new one to use while we are purchasing our real license.

I tried to repeat the same installation with 4.0.5 and I get this error when starting up the MTA services.

saslauthd[24346] :set_auth_mech : failed to initialize mechanism zimbra

I am running a split config
machineA: everything but MTA
machineB: MTA

(no changes to the machines from the prior installation. Yes SELinux is disabled)

Machine A everything seems to be running fine. I can log in as administrator and as a user.

I made the following changes before I installed my MTA machine.

Code:
Set auth fallback

zmprov md capetestinternal.com zimbraAuthFallbackToLocal TRUE

Set mail access to SSL

 zmtlsctl https

I also changed the root and default LDAP passwords
Then I went to machineB and proceeded to install the MTA. It completed and it did not complain about any LDAP communication during installation. I provided the new passwords I entered. However when I stop and restart the MTA system I get this error.

Code:
[zimbra@mail ~]$ bin/zmcontrol start
Host mail.capeinternal.com
        Starting antispam...Done.
        Starting antivirus...Done.
        Starting snmp...Done.
        Starting mta...FAILED
saslauthd[24346] :set_auth_mech   : failed to initialize mechanism zimbra
zmsaslauthdctl failed to start

I also tried starting it manually and it did not work.
1) Could someone please do the following:
explain what saslauthd is and what it is doing

2) What else I can look for to either figure it out or assist others in helping me out.

I looked through the forum but all proposed remedies either did not fit or did not work.

thanks

Doug