Results 1 to 3 of 3

Thread: OSX 10.4.8 and Network edition-startup fails

  1. #1
    Join Date
    Dec 2006
    Rep Power

    Default OSX 10.4.8 and Network edition-startup fails

    I'm bamboozled by the problem with this installation - it installed fine and the services appear to have been running, but I needed to restart the machine and the Zimbra services aren't starting. Now, when I manually try to start it I'm getting what appears to be a Perl error:

    mini:~ administrator$ sudo su - zimbra
    mini:~ zimbra$ zmcontrol start
    Bad arg length for Socket::pack_sockaddr_in, length is 0, should be 4 at /System/Library/Perl/5.8.6/darwin-thread-multi-2level/ line 373.
    mini:~ zimbra$

    The part that is really confusing is that I was able to connect to the admin console before the reboot and so it appears to have worked fine. I would suspect the IP address change, except that the error really doesn't look like that as the source. There's nothing in the logs that I can find... nothing in the log directory is changing except the .pid files.

    Where should I be looking? What could lead me to finding the root of this issue? The machine has a fresh OSX Server install (24 hours old) with 100% patches as of last night. Suggestions?

  2. #2
    Join Date
    Nov 2005
    Rep Power


    >I would suspect the IP address change

    what ip address change? what's in /etc/hosts and /etc/resolv.conf?

  3. #3
    Join Date
    Dec 2006
    Rep Power

    Default Solved the issue

    It looks like I made a mistake in the HOSTS file ( entered) and so I switched it to the IP on the ethernet card. That got the LDAP running, but until I set up a fake zone file with DNS entries that looked like the final environment will, the rest of the services wouldn't start. It's dangerous to have service starts dependent on DNS when the DNS could be (a) wrong, (b) in transition/migration, (c) down at the moment, or (d) poisoned and it can prevent your server from starting up correctly. Bad possibility of heisenbugs, since the DNS could recover and you'd never know what went wrong originally.

    It also makes it hard to deal with behind-a-firewall life, where the server knows a different (internal) world than the public does. Is there any advice out there as to how to run Zimbra (best practices) behind a firewall? Or any suggestions that I can compile?



Similar Threads

  1. Replies: 1
    Last Post: 12-19-2006, 01:58 PM
  2. OS Requirements for Network Edition
    By mrichard in forum Installation
    Replies: 6
    Last Post: 11-22-2006, 01:52 PM
  3. Network edition on openSuse 10.1
    By mjfleck2000 in forum Installation
    Replies: 4
    Last Post: 10-29-2006, 01:20 PM
  4. OSX Server Network Edition
    By jjprusk in forum Installation
    Replies: 3
    Last Post: 05-16-2006, 09:56 AM
  5. Replies: 7
    Last Post: 04-21-2006, 09:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts