Hi,

it has been 2 weeks since I've upgraded my ZCS from 7.1.4 on Ubuntu 8.04 to 7.2.1 on Ubuntu 10.04, and now I am facing some strange problems. Although it seems ZCS is working fine all the time, it happened 3 or 4 times in last days that I've got "imapproxy" and/or "stats" among services DOWN (as seen via Admin WEB GUI), and when I looked it up via SSH, it says "zmnginxctl is not runing", for example:
Code:
        antispam                Running
        antivirus               Running
        imapproxy               Stopped
                zmnginxctl is not running
        ldap                    Running
        logger                  Running
        mailbox                 Running
        memcached               Running
        mta                     Running
        snmp                    Running
        spell                   Running
        stats                   Running
        zmconfigd               Running
Sometimes simply "zmnginxctl start" did the trick, but sometimes I need to issue "zmcontrol restart" to get it up and running.

Now, the weird part:
I've took a walk through SERVER SETTINGS and I noticed, that my ZCS has checked these options:
- This server is a reverse proxy lookup target: YES
- Services --> Reverse proxy: YES
- IMAP and POP --> Enable clear text login: Checked and grayed out

I really do not remember ever before running "Reverse proxy"!?
Any idea where did it came from? Did I maybe press one YES too much during upgrade?

I have firewall also on this machine, and those 7*** proxy ports are NOT opened.
Should I open them, or rather get rid of proxy?

...and if it is safe to remove it by simply un-checking it under SERVICES (admin web gui), and select that "this server is NOT reverse proxy lookup target"?