Results 1 to 8 of 8

Thread: hosts file error on Zimbra 8.0.2 with Ubuntu 12.04 server

Hybrid View

  1. #1
    Join Date
    Jan 2013
    Posts
    6
    Rep Power
    2

    Unhappy hosts file error on Zimbra 8.0.2 with Ubuntu 12.04 server

    Zimbra 8.0.2 install on VMware with Ubuntu12.04.

    here is the file info.

    hostname:
    VMmail

    hosts:
    127.0.0.1 localhost
    127.0.1.1 VMmail
    192.168.0.1 mail01.uninet.com mail01

    when I run install.sh ... It will give me error asking me to fix /etc/hosts.

    Do you agree with the terms of the software license agreement? [N] y


    ERROR: Installation can not proceeed. Please fix your /etc/hosts file
    to contain:



    Where is the ip address of the host,
    is the FULLY QUALIFIED host name, and
    is the (optional) hostname-only portion

    root@VMmail:/var/tmp/zcs-8.0.2_GA_5569.UBUNTU12_64.20121210115059#

    Any idea what happen !?

    Cheers,

    Edwin
    Last edited by edwin@uninet; 01-15-2013 at 10:47 AM.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by edwin@uninet View Post
    Any idea what happen !?
    Your hosts file is incorrect as the error states, go to the Split DNS article (I assume you do have a Split DNS?) in the wiki and check the details there or read the many threads in the forums on this topic.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jan 2013
    Posts
    6
    Rep Power
    2

    Default

    I already do the Split DNS(one of the option is "Configuring dnsmasq on the Zimbra Server"). And the dig result is correct. The error message remains.


    ; <<>> DiG 9.8.1-P1 <<>> uninet.com mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60281
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;uninet.com. IN MX

    ;; ANSWER SECTION:
    uninet.com. 0 IN MX 5 mail01.uninet.com.

    ;; ADDITIONAL SECTION:
    mail01.uninet.com. 0 IN A 192.168.0.1

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Wed Jan 16 17:08:01 2013
    ;; MSG SIZE rcvd: 87

    root@VMmail:/var/tmp/zcs-8.0.2_GA_5569.UBUNTU12_64.20121210115059#

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by edwin@uninet View Post
    I already do the Split DNS(one of the option is "Configuring dnsmasq on the Zimbra Server"). And the dig result is correct.
    How about posting the output of all the commands in the 'Verify...' section of that article, just for confirmation.

    Quote Originally Posted by edwin@uninet View Post
    The error message remains.
    The error message remains because your hosts file is incorrect, the Split DNS article tells you exactly what the required format of all the lines in that file.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Jan 2013
    Posts
    6
    Rep Power
    2

    Default

    [QUOTE=phoenix;254647]How about posting the output of all the commands in the 'Verify...' section of that article, just for confirmation.

    Here is the result:

    root@VMmail:/etc# dig uninet.com mx

    ; <<>> DiG 9.8.1-P1 <<>> uninet.com mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58386
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;uninet.com. IN MX

    ;; ANSWER SECTION:
    uninet.com. 0 IN MX 5 mail01.uninet.com.

    ;; ADDITIONAL SECTION:
    mail01.uninet.com. 0 IN A 192.168.0.1

    ;; Query time: 1 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Wed Jan 16 18:17:14 2013
    ;; MSG SIZE rcvd: 87

    root@VMmail:/etc#

    root@VMmail:/etc# dig uninet.com any

    ; <<>> DiG 9.8.1-P1 <<>> artesian.com.hk any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28187
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;uninet.com. IN ANY

    ;; ANSWER SECTION:
    uninet.com. 0 IN MX 5 mail01.uninet.com.

    ;; ADDITIONAL SECTION:
    mail01.uninet.com. 0 IN A 192.168.0.1

    ;; Query time: 0 MSc
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Wed Jan 16 18:19:38 2013
    ;; MSG SIZE rcvd: 87

    root@VMmail:/etc#

    root@VMmail:/etc/network# more interfaces
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet static
    address 192.168.0.1
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.254
    dns-nameservers 8.8.8.8
    dns-search uninet.com
    root@VMmail:/etc/network#


    root@VMmail:/etc# host mail01
    mail01.uninet.com has address 192.168.0.1
    root@VMmail:/etc#


    root@VMmail:/etc/network# cd ..
    root@VMmail:/etc# more resolv.conf
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1
    search uninet.com
    root@VMmail:/etc#


    root@VMmail:/etc# more hosts
    127.0.0.1 localhost.localdomain localhost
    127.0.1.1 VMmail
    192.168.0.1 mail01.uninet.com mail01

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    root@VMmail:/etc#


    Well ... every thing seems okay for me.

  6. #6
    Join Date
    Apr 2012
    Posts
    101
    Rep Power
    3

    Default

    If your machine name is mail01.uninet.com, why does your command prompt say root@VMmail: ?

    do :
    host $(hostname)

    sorry, that was a bit terse.
    Zimbra does not refer to the hosts file. Unless your machine name is directly resolvable you won't get anywhere. Your machine name is VMmail, not mail01.uninet.com.
    Last edited by Brad_C; 01-16-2013 at 07:38 AM.

  7. #7
    Join Date
    Jan 2013
    Posts
    6
    Rep Power
    2

    Default

    Quote Originally Posted by phoenix View Post
    Your hosts file is incorrect as the error states, go to the Split DNS article (I assume you do have a Split DNS?) in the wiki and check the details there or read the many threads in the forums on this topic.
    I already done the "Split DNS" with dnsmasq. but the problem remains.

Similar Threads

  1. hosts file problem, installing on ubuntu 8.04
    By onjinc in forum Installation
    Replies: 4
    Last Post: 05-20-2010, 12:02 AM
  2. ERROR: Please fix your /etc/hosts file
    By tomekck in forum Installation
    Replies: 1
    Last Post: 03-21-2010, 06:13 AM
  3. Replies: 3
    Last Post: 02-18-2010, 07:35 AM
  4. ERROR: Please fix your /etc/hosts file
    By fsloke in forum Installation
    Replies: 1
    Last Post: 07-29-2008, 12:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •