Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: saslauthd: Permission denied (external SMTP AUTH broken)

  1. #21
    Join Date
    Jan 2007
    Posts
    19
    Rep Power
    8

    Default

    Code:
    [root@mail ~]# id zimbra
    uid=511(zimbra) gid=511(zimbra) groups=511(zimbra),4(adm),5(tty),89(postfix)
    [root@mail ~]# id postfix
    uid=89(postfix) gid=89(postfix) groups=89(postfix),12(mail)

  2. #22
    Join Date
    Jan 2007
    Posts
    19
    Rep Power
    8

    Default Resolved

    It was umask.

    root had
    Code:
    umask 027
    in the ~/.bashrc. Removed it, did a clean-slate reinstall of Zimbra, and it works.

    Yay for simple solutions.

  3. #23
    Join Date
    Aug 2006
    Posts
    22
    Rep Power
    9

    Default

    I had the same problem and I run:
    chmod a+rwx /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/state

    And it looks like it's fixed.

  4. #24
    Join Date
    Apr 2007
    Posts
    32
    Rep Power
    8

    Default

    I've just been caught by this too - 4.5.6 using RHEL5_64. Is this a problem with the packaging or have I done something wrong?

  5. #25
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Did that fix it?

  6. #26
    Join Date
    Apr 2007
    Posts
    32
    Rep Power
    8

    Default

    It did, yes. I was just surprised that the permissions aren't set so that it works during the setup, however.

  7. #27
    Join Date
    Jul 2008
    Posts
    78
    Rep Power
    7

    Default

    I just had a similar problem in 7.1.0_GA_3140.UBUNTU10_64 UBUNTU10_64 NETWORK edition.

    Code:
    Starting saslauthd...saslauthd[13014] :main            : could not open pid lock file: /opt/zimbra/cyrus-sasl-2.1.23.3z/state/saslauthd.pid.lock
    saslauthd[13014] :main            : open: Permission denied
    saslauthd[13014] :main            : Check to make sure the directory exists and is
    saslauthd[13014] :main            : writeable by the user this process runs as.
    failed.
    zmsaslauthdctl failed to start
    I just mv saslauthd.pid.lock to saslauthd.pid.lock.orig and restarted zimbra and it seemed to work.

Similar Threads

  1. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  2. Backup issues
    By telescop in forum Administrators
    Replies: 3
    Last Post: 03-01-2007, 05:09 PM
  3. Ldap issues
    By mississippiman in forum Installation
    Replies: 11
    Last Post: 01-09-2007, 07:00 PM
  4. Enable SMTP Auth to external users
    By VictorMedina in forum Administrators
    Replies: 1
    Last Post: 05-24-2006, 10:06 AM
  5. Move server to different OS
    By EriSan500 in forum Administrators
    Replies: 7
    Last Post: 03-05-2006, 12:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •