Results 1 to 10 of 12

Thread: Mysql does not start on RHEL 64

Hybrid View

  1. #1
    Join Date
    Jan 2007
    Posts
    35
    Rep Power
    8

    Default Mysql does not start on RHEL 64

    Mysqld fails to start on RHEL 64 (Linux 2.6.9-42.0.3.ELsmp SMP Mon Sep 25 17:24:31 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux) w/ zcs-NETWORK-4.5.0_GA_612.RHEL4_64

    From zmsetup.log

    * Creating required directories
    * Generating mysql config /opt/zimbra/conf/my.cnf
    * Creating database in /opt/zimbra/db/data
    * Starting mysql server
    * Failed to connect to mysql...retrying
    * Failed to connect to mysql...retrying
    * Failed to connect to mysql...giving up!
    Done

    Initializing logger sql database...
    *** Running as zimbra user: /opt/zimbra/libexec/zmloggerinit

    * Creating required directories
    * Creating database in /opt/zimbra/logger/db/data
    * Starting logger_mysql server
    * Loading schema /opt/zimbra/db/loggerdb.sql
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/logger/db/mysql.sock' (2)
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/logger/db/mysql.sock' (2)
    * Setting random password for mysql root user in zimbra local config
    * Setting random password for mysql zimbra user in zimbra local config
    * Changing mysql root user password
    ^G/opt/zimbra/logger/mysql/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/opt/zimbra/logger/db/mysql.sock' (2)'
    Check that mysqld is running and that the socket: '/opt/zimbra/logger/db/mysql.sock' exists!

    Any help would be greatly appreciated.

  2. #2
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default

    Was this an upgrade from 4.0.x or is this a new install?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Jan 2007
    Posts
    35
    Rep Power
    8

    Default

    Quote Originally Posted by anand View Post
    Was this an upgrade from 4.0.x or is this a new install?
    This was a complete fresh install on a freshly installed RHEL machine.

    Thanks.

  4. #4
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default

    is selinux turned on?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    Join Date
    Jan 2007
    Posts
    35
    Rep Power
    8

    Default

    Quote Originally Posted by anand View Post
    is selinux turned on?
    Yes it is.

    SELinux status: enabled
    SELinuxfs mount: /selinux
    Current mode: permissive
    Mode from config file: permissive
    Policy version: 18
    Policy from config file:targeted

    Policy booleans:
    allow_syslog_to_console inactive
    allow_ypbind inactive
    dhcpd_disable_trans inactive
    httpd_builtin_scripting active
    httpd_disable_trans inactive
    httpd_enable_cgi active
    httpd_enable_homedirs active
    httpd_ssi_exec active
    httpd_tty_comm inactive
    httpd_unified active
    mysqld_disable_trans inactive
    named_disable_trans inactive
    named_write_master_zonesinactive
    nscd_disable_trans inactive
    ntpd_disable_trans inactive
    pegasus_disable_trans inactive
    portmap_disable_trans inactive
    postgresql_disable_transinactive
    snmpd_disable_trans inactive
    squid_disable_trans inactive
    syslogd_disable_trans inactive
    use_nfs_home_dirs inactive
    use_samba_home_dirs inactive
    use_syslogng inactive
    winbind_disable_trans inactive
    ypbind_disable_trans inactive
    Last edited by cryptogram; 01-18-2007 at 12:33 PM.

  6. #6
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default

    pls try with selinux off.

    Is there anything in the logs directory from the logger mysql (we run two instance of mysql - one for mail and one for syslog data and in your case the logging one is the one that can not be initialized).

    After that if you still have the same problem, (and since this is a new system, and you can afford to trash it) try running bash -x /opt/zimbra/libexec/zmloggerinit and see what the hell it is doing.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  4. No listener on port 7071
    By earthling in forum Installation
    Replies: 3
    Last Post: 11-14-2005, 08:16 AM
  5. Can't start MySQL to init db - Gentoo
    By fak3r in forum Installation
    Replies: 3
    Last Post: 10-10-2005, 07:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •