I have Zimbra installed on Ubuntu 12.04 LTS x64. Inbound mail is configured and working properly. I'm trying to set up outbound mail to use the Amazon SES as a relay with STARTTLS or SSL, but am having difficulty. I followed the instructions from the wiki (Outgoing SMTP Authentication - Zimbra :: Wiki), but the messages in the monitoring tab are staying in "deferred." In /var/log/mail.log, I'm getting:

Code:
Aug 29 07:56:31 mail postfix/smtp[27444]: 6C4BE102772: to=<***@***.com>, relay=none, delay=28025, delays=27875/0.07/150/0, dsn=4.4.1, status=deferred (connect to email-smtp.us-east-1.amazonaws.com[107.21.244.69]:25: Connection timed out)
Aug 29 08:34:01 mail postfix/qmgr[11106]: F0E43102783: from=<***@***.com>, size=849, nrcpt=1 (queue active)
Aug 29 08:34:01 mail postfix/smtp[13062]: F0E43102783: to=<***@***.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=29993, delays=29993/0.05/0.01/0, dsn=4.7.4, status=deferred (TLS is required, but was not offered by host 127.0.0.1[127.0.0.1])
It seems that the connection the the SES server is timing out when connecting, then maybe it's reverting to a local smtp server(?). I'm not sure if this is related to port blocking on my end, so I wanted to try changing to one of the alternate accepted ports for SES. However, I can't seem to find where the config file is that the command "zmprov ms server.domain.com zimbraMtaRelayHost mailrelay.example.com" is altering. Also, I'd love to hear any other suggestions if there is another problem I'm missing.

Thanks,
Brett