Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 34

Thread: INVALID_PDU error on 4.5 GA

  1. #21
    Join Date
    May 2006
    Location
    Vanderbijlpark
    Posts
    11
    Rep Power
    9

    Default

    I have the same problem and have followed every suggestion posted but the problem still persist. Is there any other way I could get around this.

    I can't even open the zimbraAdmin page, as I get a blank page when I get there.

    I haven't changed anything, and my last upgrade was about three months ago and everything was working fine until today.

    I'm running the 4.5.3_GA OOS release under CentOs



    Please help!
    Makalo Motsamai

  2. #22
    Join Date
    Mar 2006
    Posts
    52
    Rep Power
    9

    Default

    We had one issue with INVALID_PDU.

    We changed the hostname of the Zimbra server. Changing it back worked.

    You have to do it with zmprov.

  3. #23
    Join Date
    May 2006
    Location
    Vanderbijlpark
    Posts
    11
    Rep Power
    9

    Default

    10.Q Abak for your reply.

    However I haven't changed the hostname attribute on the server. Are you suggesting I change it?
    Makalo Motsamai

  4. #24
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Are you on 4.5GA or 4.5.xGA? If you're just on 4.5, you may wish to upgrade to the latest patch, which is 4.5.5

    Also, take a look in /opt/zimbra/log/mailbox.log
    for anything in there.

    jh

  5. #25
    Join Date
    May 2006
    Location
    Vanderbijlpark
    Posts
    11
    Rep Power
    9

    Default

    The version i'm running is 4.5.3_GA.

    The mailbox.log gives:

    2007-06-12 08:27:08,184 INFO [http-80-Processor94] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-12 08:27:17,731 INFO [http-80-Processor94] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-12 08:27:37,542 INFO [http-80-Processor78] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-12 08:27:45,059 INFO [http-80-Processor100] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-12 08:27:46,122 INFO [http-80-Processor77] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-12 08:27:46,534 INFO [http-80-Processor91] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-12 08:27:47,321 INFO [http-80-Processor84] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    Makalo Motsamai

  6. #26
    Join Date
    May 2006
    Location
    Vanderbijlpark
    Posts
    11
    Rep Power
    9

    Default

    Quote Originally Posted by jholder View Post
    Are you on 4.5GA or 4.5.xGA? If you're just on 4.5, you may wish to upgrade to the latest patch, which is 4.5.5

    Also, take a look in /opt/zimbra/log/mailbox.log
    for anything in there.

    jh

    I've upgraded as advised but the problem still stands.

    Makalo Motsamai

  7. #27
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Can you post your whole mailbox.log and perhaps the catalina.out located in /opt/zimbra/tomcat/logs/ ?

    Thanks
    jh

  8. #28
    Join Date
    May 2006
    Location
    Vanderbijlpark
    Posts
    11
    Rep Power
    9

    Default

    Catalina.out is empty and mailbox.log gives:

    2007-06-13 01:30:03,382 INFO [http-7071-Processor50] [] [AdminServlet] - Servlet AdminServlet is currently unavailable
    2007-06-13 03:00:03,611 INFO [http-7071-Processor48] [] [AdminServlet] - Servlet AdminServlet is currently unavailable
    2007-06-13 07:56:27,754 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 07:56:53,691 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 07:57:03,149 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 07:57:05,859 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:21:02,792 INFO [http-80-Processor100] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:21:31,283 INFO [http-80-Processor100] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:23:35,398 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:24:21,255 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:24:45,657 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:25:12,914 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:25:35,695 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:25:36,201 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:25:36,660 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:25:43,121 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:25:44,225 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:25:44,759 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:25:45,366 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:25:45,855 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:27:00,584 INFO [http-80-Processor100] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:27:15,280 INFO [http-80-Processor100] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:27:24,282 INFO [http-80-Processor100] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:27:26,835 INFO [http-80-Processor100] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:27:39,177 INFO [http-80-Processor100] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:27:48,617 INFO [http-80-Processor100] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:28:07,718 INFO [http-80-Processor71] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:28:13,590 INFO [http-80-Processor73] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:28:36,023 INFO [http-80-Processor100] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:28:49,779 INFO [http-80-Processor84] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    2007-06-13 08:28:50,888 INFO [http-80-Processor100] [] [SoapServlet] - Servlet SoapServlet is currently unavailable
    Makalo Motsamai

  9. #29
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Have you tried restarting tomcat? There's got to be something before those statements.

    Try
    su - root
    cat /dev/null > /opt/zimbra/log/mailbox.log
    su - zimbra
    tomcat restart

    Then post our mailbox.log
    Also, can you verify that there's nothing running on port 80?
    Can you login to the adminui? Looks like it's just port 80.

  10. #30
    Join Date
    May 2006
    Location
    Vanderbijlpark
    Posts
    11
    Rep Power
    9

    Default

    The Admin ui opens but does not show the logon screen(servlet). After following your above suggestion mailbox.log gives:

    2007-06-15 07:55:12,243 INFO [main] [] ClamScanner - attachment scan is disabled
    2007-06-15 07:55:12,243 INFO [main] [] extensions - Initialized extension clamscanner: com.zimbra.clam.ClamScanner@com.zimb...tensio n.ZimbraExtensionClassLoader@b3cac9
    2007-06-15 07:55:12,247 INFO [main] [] ClamScanner - attachment scan is disabled
    2007-06-15 07:55:12,248 INFO [main] [] extensions - Initialized extension clamscanner: com.zimbra.clam.ClamScanner@com.zimb...tensio n.ZimbraExtensionClassLoader@ee6ad6
    2007-06-15 07:55:12,248 INFO [IndexWritersSweeper] [] MailboxIndex - IndexWritersSweeper thread exiting
    2007-06-15 07:55:12,248 INFO [main] [] MailboxIndex - Flushing all open index writers
    2007-06-15 07:55:12,248 INFO [IndexWritersSweeper] [] MailboxIndex - IndexWritersSweeper thread starting
    2007-06-15 07:55:12,257 INFO [main] [] RedoLogManager - Starting pre-startup crash recovery
    2007-06-15 07:55:44,190 INFO [main] [] RedoPlayer - Redoing 2 uncommitted transactions
    2007-06-15 07:55:44,190 INFO [main] [] RedoPlayer - Deferring crash recovery to after startup: txn 1179837673.229373 [IndexItem] ver=1.12, tstamp=1181264573333, mailbox=747, id=1698, type=5
    2007-06-15 07:55:59,869 FATAL [main] [] soap - Unable to start servlet
    java.lang.OutOfMemoryError: Java heap space
    2007-06-15 07:55:59,870 INFO [main] [] [/service] - Marking servlet AdminServlet as unavailable
    2007-06-15 07:55:59,870 ERROR [main] [] [/service] - Servlet /service threw load() exception
    javax.servlet.UnavailableException: Java heap space
    at com.zimbra.soap.SoapServlet.init(SoapServlet.java: 118)
    at javax.servlet.GenericServlet.init(GenericServlet.j ava:211)
    at org.apache.catalina.core.StandardWrapper.loadServl et(StandardWrapper.java:1105)
    at org.apache.catalina.core.StandardWrapper.load(Stan dardWrapper.java:932)
    at org.apache.catalina.core.StandardContext.loadOnSta rtup(StandardContext.java:3915)
    at org.apache.catalina.core.StandardContext.start(Sta ndardContext.java:4176)
    at org.apache.catalina.core.ContainerBase.addChildInt ernal(ContainerBase.java:759)
    at org.apache.catalina.core.ContainerBase.addChild(Co ntainerBase.java:739)
    at org.apache.catalina.core.StandardHost.addChild(Sta ndardHost.java:524)
    at org.apache.catalina.startup.HostConfig.deployDirec tory(HostConfig.java:910)
    at org.apache.catalina.startup.HostConfig.deployDirec tories(HostConfig.java:873)
    at org.apache.catalina.startup.HostConfig.deployApps( HostConfig.java:474)
    at org.apache.catalina.startup.HostConfig.start(HostC onfig.java:1118)
    at org.apache.catalina.startup.HostConfig.lifecycleEv ent(HostConfig.java:310)
    at org.apache.catalina.util.LifecycleSupport.fireLife cycleEvent(LifecycleSupport.java:119)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1020)
    at org.apache.catalina.core.StandardHost.start(Standa rdHost.java:718)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1012)
    at org.apache.catalina.core.StandardEngine.start(Stan dardEngine.java:442)
    at org.apache.catalina.core.StandardService.start(Sta ndardService.java:450)
    at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
    at org.apache.catalina.startup.Catalina.start(Catalin a.java:551)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:275)
    at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:406)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at com.zimbra.cs.launcher.TomcatLauncher.start(Tomcat Launcher.java:52)
    at com.zimbra.cs.launcher.TomcatLauncher.main(TomcatL auncher.java:74)
    2007-06-15 07:55:59,886 INFO [main] [] ContentServlet - Servlet ContentServlet starting up
    2007-06-15 07:55:59,890 INFO [main] [] PublicICalServlet - Servlet PublicICalServlet starting up
    2007-06-15 07:55:59,894 INFO [main] [] account - Servlet PreAuthServlet starting up
    2007-06-15 07:55:59,984 INFO [main] [] mailbox - Servlet UserServlet starting up
    2007-06-15 07:56:00,001 INFO [main] [] FileUploadServlet - Servlet FileUploadServlet starting up
    2007-06-15 07:56:00,006 INFO [main] [] StatsImageServlet - Servlet StatsImageServlet starting up
    2007-06-15 07:59:54,231 INFO [http-80-Processor100] [] [SoapServlet] - Servlet SoapServlet is currently unavailable

    and catalina.out gives:

    Full thread dump Java HotSpot(TM) Client VM (1.5.0_08-b03 mixed mode):

    "http-7071-Processor50" daemon prio=1 tid=0x080de640 nid=0x139d in Object.wait() [0x8814d000..0x8814e130]
    at java.lang.Object.wait(Native Method)
    - waiting on <0x99d8ace8> (a org.apache.tomcat.util.threads.ThreadPool$ControlR unnable)
    at java.lang.Object.wait(Object.java:474)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:656)
    - locked <0x99d8ace8> (a org.apache.tomcat.util.threads.ThreadPool$ControlR unnable)
    at java.lang.Thread.run(Thread.java:595)

    "http-7071-Processor49" daemon prio=1 tid=0x080dd740 nid=0x139c runnable [0x881ce000..0x881ceeb0]
    at java.net.PlainSocketImpl.socketAccept(Native Method)
    at java.net.PlainSocketImpl.accept(PlainSocketImpl.ja va:384)
    - locked <0x997f7e58> (a java.net.SocksSocketImpl)
    at java.net.ServerSocket.implAccept(ServerSocket.java :450)
    at com.sun.net.ssl.internal.ssl.SSLServerSocketImpl.a ccept(SSLServerSocketImpl.java:259)
    at org.apache.tomcat.util.net.jsse.JSSESocketFactory. acceptSocket(JSSESocketFactory.java:110)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.acceptS ocket(PoolTcpEndpoint.java:407)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:70)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:684)
    at java.lang.Thread.run(Thread.java:595)

    "http-7071-Processor48" daemon prio=1 tid=0x080dc840 nid=0x139b in Object.wait() [0x8824f000..0x8824fe30]
    at java.lang.Object.wait(Native Method)
    - waiting on <0x99d8a828> (a org.apache.tomcat.util.threads.ThreadPool$ControlR unnable)
    at java.lang.Object.wait(Object.java:474)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:656)
    - locked <0x99d8a828> (a org.apache.tomcat.util.threads.ThreadPool$ControlR unnable)
    at java.lang.Thread.run(Thread.java:595)
    Last edited by Makalo; 06-15-2007 at 12:33 AM. Reason: additional info
    Makalo Motsamai

Similar Threads

  1. Replies: 12
    Last Post: 09-11-2007, 05:35 PM
  2. Outlook Connector send behaviour in 4.5
    By inigoml in forum Zimbra Connector for Outlook
    Replies: 5
    Last Post: 07-05-2007, 03:02 PM
  3. Replies: 6
    Last Post: 05-29-2007, 11:01 AM
  4. ZCS 4.5 eval ?? + 64/32 ?
    By dlochart in forum Installation
    Replies: 7
    Last Post: 02-06-2007, 09:08 AM
  5. Replies: 1
    Last Post: 12-19-2006, 02:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •