Results 1 to 10 of 21

Thread: Problem setting up split DNS Zimbra 8.0.5 Ubuntu 12.04

Hybrid View

  1. #1
    Join Date
    Sep 2013
    Posts
    9
    Rep Power
    2

    Default Problem setting up split DNS Zimbra 8.0.5 Ubuntu 12.04

    I know this topic has been pounded to death on the forums and I apologise for dragging it back up again but I am having a real problem setting up split DNS for my new Zimbra install. Iím sure that it is probably something simple that Iím missing but Iíve been staring at it for too long and cannot see what Iím doing wrong.

    First some background. This is a new install of Zimbra 8.0.5 on Ubuntu 12.04 running on a KVM VM under Ubuntu 12.04. This setup is located behind an Untangle box running in router mode. My local IP is 192.168.0.191.

    My named.conf.local file looks like:

    Code:
    //
    // Do any local configuration here
    //
    
    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    // include "/etc/bind/zones.rfc1918";
    
    include "/etc/bind/rndc.key";
    
    zone "tkdb.ca" {
            type master;
            file "/etc/bind/db.tkdb.ca";
    };
    My db.tkdb.ca file looks like:

    Code:
    $TTL    3600
    @       IN      SOA     ns.tkdb.ca.     hostmaster.tkdb.ca. (
                         2013092501         ; Serial
                               3600         ; Refresh
                               3600         ; Retry
                             604800         ; Expire
                             604800 )       ; Negative Cache TTL
    ;
            IN      NS      192.168.0.191
    
    tkdb.ca.        IN      MX      10 mail.tkdb.ca
    mail.tkdb.ca    IN      A       192.168.0.191
    My /etc/hosts file looks like:

    Code:
    127.0.0.1       localhost mail.tkdb.ca
    192.168.0.191   mail.tkdb.ca    mail
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    dig tkdb.ca mx returns:

    Code:
    ; <<>> DiG 9.8.1-P1 <<>> tkdb.ca mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 4608
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;tkdb.ca.                       IN      MX
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.0.191#53(192.168.0.191)
    ;; WHEN: Wed Sep 25 08:56:06 2013
    ;; MSG SIZE  rcvd: 25
    dig tkdb.ca any returns:

    Code:
    ; <<>> DiG 9.8.1-P1 <<>> tkdb.ca any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 48393
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;tkdb.ca.                       IN      ANY
    
    ;; Query time: 1 msec
    ;; SERVER: 192.168.0.191#53(192.168.0.191)
    ;; WHEN: Wed Sep 25 08:56:16 2013
    ;; MSG SIZE  rcvd: 25
    host $(hostname) returns
    Code:
    Host mail not found: 3(NXDOMAIN)
    DNS is working on the box and I have a connection to the world as nslookup google.ca returns:
    Code:
    Server:         192.168.0.191
    Address:        192.168.0.191#53
    
    Non-authoritative answer:
    Name:   google.ca
    Address: 173.194.33.31
    Name:   google.ca
    Address: 173.194.33.23
    Name:   google.ca
    Address: 173.194.33.24
    Can anybody see where I went wrong?

    Thanks,
    Last edited by NorthWill; 09-25-2013 at 10:55 AM.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You really should enclose each command and it's output in code tags (highlight the relevant text and hit the CODE button - it's the # symbol) as it's difficult to read in the format you've posted.

    The simple answer to your question (although you haven't given any indication of what error you're encountering) is that your hosts file is incorrect, go to the Split DNS article and compare you file to the example given there.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Sep 2013
    Posts
    9
    Rep Power
    2

    Default

    Thanks for the response (and the pointer re: the code tags. I was looking for something like that but I missed that there was an advanced edit menu).

    I've changed my host file to:

    Code:
    127.0.0.1       localhost.localdomain localhost
    192.168.0.191   mail.tkdb.ca    mail
    but I'm still getting the status: SERVFAIL error on the dig commands and host $(hostname) still returns:

    Code:
    Host mail not found: 3(NXDOMAIN)
    The basic problem is that tkdb.ca is not resolvable. I cannot ping tkdb.ca internally or externally. I can log on to the admin console and my test account using the IP address internally but not using the name mail.tkdb.ca. I can send mail from Zimbra but I cannot send mail to Zimbra.

    Thanks,

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    What is in your resolve.conf and is your DNS server authoritative for your domain?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Sep 2013
    Posts
    9
    Rep Power
    2

    Default

    My resolv.conf is:

    Code:
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 192.168.0.191
    search tkdb.ca
    These settings are controlled from the dns-option entries in my /etc/network/interfaces file but I don't think that matters.

    It doesn't appear that my DNS server is authoritative though. I'll work on that and try again. Thanks for the tip.

  6. #6
    Join Date
    Sep 2013
    Posts
    9
    Rep Power
    2

    Default

    Finally figured it out. The split DNS article at Split DNS - Zimbra :: Wiki is not quite correct in all cases.

    In my case I have a firewall (Untangle) that uses dnsmasq -s to pass through dns queries to the dns nameserver on 192.168.0.191. It seems that that makes the firewall transparent to dns queries so I need to set up my dns nameserver on 192.168.0.191 with the A and MX records pointing to my public address rather than to the internal address. Once I did that the world was a happy place.

    The article at Making Zimbra & BIND Work Together :: Zimbra :: Blog is what I eventually followed although because I am on Ubuntu 12 I only installed the Bind9 package rather than the bind-devel, bind-utils, and caching-nameserver packages. From Part 2, I followed the instructions fairly closely with slight modifications to reflect the different file and folder structure of Ubuntu.

    Thanks,

Similar Threads

  1. Replies: 2
    Last Post: 08-25-2011, 04:41 AM
  2. zimbra split domain problem
    By sandiphw in forum Administrators
    Replies: 0
    Last Post: 06-02-2010, 08:11 AM
  3. Replies: 5
    Last Post: 08-28-2009, 10:35 AM
  4. [SOLVED] Problem w/ split DNS on Ubuntu 6.06
    By LittleLebowski in forum Installation
    Replies: 4
    Last Post: 05-06-2008, 09:18 AM
  5. Split DNS setup help? Ubuntu and zimbra 4.5RC2.
    By nfear24 in forum Installation
    Replies: 2
    Last Post: 01-11-2007, 07:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •