(I was about asking question, but while writing and looking around, I found answer by myself ... so I'm posting anyway, as it may help newbies too )

Hello,

I've install CentOS 6 (Basic server). ( ... create a user other than root, configure a static ip address and update the system)
I've install dependencies :
Code:
sudo yum install nc libidn gmp openssh
I've modified DNS configuration on my domain provider ( OVH ).
I made mistake : I first create a host with a name "mail" before changing it to the name of my zimbra server.

So the final DNS configuration is the following :
Code:
.mydomain.fr 	NS 	ns105.ovh.net
.mydomain.fr	NS 	dns105.ovh.net
.mydomain.fr	MX 10 	myserver.mydomain.fr
.mydomain.fr	A 	EXTERNAL.IP.OF.MYROUTER
www.mydomain.fr 	A 	EXTERNAL.IP.OF.MYROUTER
myserver.mydomain.fr 	A 	EXTERNAL.IP.OF.MYROUTER
I've configure my router to do NAT on port 25 to the local ip address of my zimbra server

I've install DNSMasq on the zimbra server for DNS SPLIT
/etc/dnsmasq.conf file :
Code:
server=8.8.8.8
server=208.67.222.222
domain=mydomain.fr
mx-host=mydomain.fr,myserver.mydomain.fr,5
listen-address=127.0.0.1
/etc/hosts file :
Code:
127.0.0.1 localhost.localdomain localhost
192.168.1.8    myserver.mydomain.fr myserver
/etc/resolv.conf file :
I know it shoud be :
Code:
search mydomain.fr
nameserver 127.0.0.1
But the file is configured by DHCP whith these value :
Code:
; generated by /sbin/dhclient-script
nameserver 208.67.222.222
nameserver 208.67.220.220
I put the install file 'zcs-NETWORK-8.0.5_GA_5839.RHEL6_64.20130910124005.tgz' and my XML licence in the home directory of the server.
I have untar and launch './install.sh' to start the installation.

I had error but was able to fix it ( I forget the hosts file ... )
Finally, I configure the admin password, put the licence path and file name.

Then I run some test :
Code:
su
su - zimbra
zmcontrol status
that gave me

Code:
[zimbra@myserver ~]$ zmcontrol status
Host myserver.mydomain.fr
	antispam                Running
	antivirus               Running
	convertd                Running
	ldap                    Running
	logger                  Running
	mailbox                 Running
	memcached               Running
	mta                     Stopped
		postfix is not running
	opendkim                Running
	proxy                   Running
	snmp                    Running
	spell                   Running
	stats                   Running
	zmconfigd               Running
Even after doing
Code:
zmcontrol start
I did some more testing :
Code:
[myuser@myserver ~]$ dig mydomain.fr mx

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.6 <<>> mydomain.fr mx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59387
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mydomain.fr.		IN	MX

;; ANSWER SECTION:
mydomain.fr.	1571	IN	MX	1 mail.mydomain.fr.

;; Query time: 32 msec
;; SERVER: 208.67.222.222#53(208.67.222.222)
;; WHEN: Fri Nov 29 16:27:30 2013
;; MSG SIZE  rcvd: 56
Two things that are wrong :
This DNS server is still using my old hostname "mail" instead of "myserver" ... I think I have to wait for world wide DNS replication.
The local machine is not using my local DNSMasq ... may be because of the resolv.conf file. That have to be fix through the DHCP server.

------

Today, I've changed the network configuration to static IP on the server.
I've also tested the dig command. External DNS now give the correct host name.
But the internal DNS is not answering.
I check the /etc/resolv.conf. the file contain the necessary information.
I check the status of dnsmasq :
Code:
[myuser@myserver ~]$ sudo /etc/init.d/dnsmasq status
[sudo] password for myuser: 
dnsmasq is stopped
Ok, dnsmask is not starting at boot ... I have to fix that

If I do
Code:
[myuser@myserver ~]$ su
Mot de passe : 
[root@myserver myuser]# su - zimbra
[zimbra@myserver ~]$ zmcontrol start
I get :

Code:
Starting mta...Failed.
Starting saslauthd...already running.
postfix failed to start
In the zimbra.log file i get this error:

Code:
myserver postfix/master[4711]: fatal: bind 0.0.0.0 port 25: Address already in use
Code:
[myuser@myserver ~]$ sudo lsof -i TCP:25
[sudo] password for myuser: 
COMMAND  PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
master  1943 root   12u  IPv4  14783      0t0  TCP localhost.localdomain:smtp (LISTEN)
master  1943 root   13u  IPv6  14785      0t0  TCP localhost.localdomain:smtp (LISTEN)
What that master process ?

This is the system postfix. Weird, is it install with the basic server centOS installation ?

Code:
[myuser@myserver ~]$ sudo /etc/init.d/postfix status
[sudo] password for myuser: 
master (pid  1943) is running...
So I stop it.
Code:
[myuser@myserver ~]$ sudo /etc/init.d/postfix stop
Stopping postfix :                                         [  OK  ]
Code:
[zimbra@myserver ~]$ zmcontrol start
Host myserver.mydomain.fr
	Starting zmconfigd...Done.
	Starting logger...Done.
	Starting convertd...Done.
	Starting mailbox...Done.
	Starting memcached...Done.
	Starting proxy...Done.
	Starting antispam...Done.
	Starting antivirus...Done.
	Starting opendkim...Done.
	Starting snmp...Done.
	Starting spell...Done.
	Starting mta...Done.
	Starting stats...Done.
Now it looks like it should work better.
I have to check if mails are going in and out in the real world.

------

It' all good !
And next time, for the production server, l'll install minimal version of CentOS not basic !!