Results 1 to 4 of 4

Thread: Zimbra on SLES 9 ?

Hybrid View

  1. #1
    Join Date
    Nov 2005
    Posts
    12
    Rep Power
    10

    Question Zimbra on SLES 9 ?

    I did zimbra install from the source package in the SLES 9 (SuSE Enterprise Server 9) according to the instruction on the site at http://www.zimbra.com/blog/archives/2005/08/index.html.

    Initially my computer has the very basic SLES9 system software installed, such as gcc, fetchmail, and other kernel software. I didn't install any of the LDAP, Apache2, PHP, MySQL, Java2, postfix, anti-virus, and anti-spam software in there at all 'cause I know the zimbra software package comes with that. However, I downloaded java 1.5.05 SDK and Apache ANT 1.6.5. Here are the steps that I went through:

    1) installed java 1.5.05 SDK and created a symbolic link to /usr/lib/java that points to the SDK installation;
    2) installed apache ant;
    3) set path for java and ant;
    4) In /etc/hosts, make sure that it has the following lines:
    127.0.0.1 localhost
    10.10.0.6 webmail.mydomain.com webmail
    5) create a user myzimbra under the group users;
    6) login as myzimbra, make a directory zcssrc under the home directory of myzimbra and download zcs-3.0.M1_21-src.tgz from www.zimbra.com;
    7) login as a root and run the following commands:
    # mkdir /opt/zimbra
    # chown myzimbra.users /opt/zimbra
    8) login as myzimbra and do the following:
    $ cd ~/zcssrc
    $ tar zxvf zcs-3.0.M1_21-src.tgz
    $ cd ZimbraBuild
    $ make dev-install
    9) login in as root:
    - Add these directories to my /etc/ld.so.conf file:
    /opt/zimbra/lib
    /opt/zimbra/sleepycat/lib
    /opt/zimbra/openldap/lib
    /opt/zimbra/cyrus-sasl/lib
    - Run ldconfig
    - Add the following lines into /etc/sudoers file:
    myzimbra ALL=NOPASSWD:/opt/zimbra/openldap/libexec/slapd
    myzimbra ALL=NOPASSWD:/opt/zimbra/postfix/sbin/postfix
    myzimbra ALL=NOPASSWD:/opt/zimbra/postfix/sbin/postalias
    - initialize postfix:
    # groupadd postdrop
    # groupadd postfix
    # useradd -d /opt/zimbra/postfix -g postfix postfix
    # edit /opt/zimbra/postfix/conf/main.cf file to include,
    ## Internet host and domain names
    myhostname = webmail.mydomain.com
    mydomain = mydomain.com
    ## Sending mail
    myorigin = $mydomain
    ## Receiving mail
    inet_interfaces = all

    # /opt/zimbra/postfix/sbin/postfix set-permissions
    # chmod 775 /opt/zimbra/postfix/conf
    - create symbolic links to:
    * ln -s "/usr/lib/libssl.so.0.9.7" libssl.so.4
    * ln -s "/usr/lib/libcrypto.so.0.9.7" libcrypto.so.4
    10) login in as myzimbra,
    (a) to initialize mysql: $ /opt/zimbra/libexec/zmmyinit
    (b) to initialize ldap:
    $ cd /opt/zimbra
    $ mkdir openldap-data
    $ /opt/zimbra/libexec/zmldapinit
    (c) to initialize postfix: $ /opt/zimbra/libexec/zmmtainit localhost

    All went well up to this point ! ;o)

    See the display by executing 'ps -ef'
    myzimbra 5820 1 0 Nov11 pts/1 00:00:00 /bin/sh /opt/zimbra/mysql/bin/mysqld_safe --defaults-file=/opt/zimbra/conf/my.cnf
    myzimbra 5852 5820 0 Nov11 pts/1 00:00:03 /opt/zimbra/mysql/bin/mysqld --defaults-file=/opt/zimbra/conf/my.cnf --basedir=/op
    myzimbra 5853 5852 0 Nov11 pts/1 00:00:00 /opt/zimbra/mysql/bin/mysqld --defaults-file=/opt/zimbra/conf/my.cnf --basedir=/op
    myzimbra 5854 5853 0 Nov11 pts/1 00:00:00 /opt/zimbra/mysql/bin/mysqld --defaults-file=/opt/zimbra/conf/my.cnf --basedir=/op
    myzimbra 5855 5853 0 Nov11 pts/1 00:00:00 /opt/zimbra/mysql/bin/mysqld --defaults-file=/opt/zimbra/conf/my.cnf --basedir=/op
    myzimbra 5856 5853 0 Nov11 pts/1 00:00:00 /opt/zimbra/mysql/bin/mysqld --defaults-file=/opt/zimbra/conf/my.cnf --basedir=/op
    myzimbra 5857 5853 0 Nov11 pts/1 00:00:00 /opt/zimbra/mysql/bin/mysqld --defaults-file=/opt/zimbra/conf/my.cnf --basedir=/op
    myzimbra 5871 5853 0 Nov11 pts/1 00:00:00 /opt/zimbra/mysql/bin/mysqld --defaults-file=/opt/zimbra/conf/my.cnf --basedir=/op
    myzimbra 5872 5853 0 Nov11 pts/1 00:00:07 /opt/zimbra/mysql/bin/mysqld --defaults-file=/opt/zimbra/conf/my.cnf --basedir=/op
    myzimbra 5873 5853 0 Nov11 pts/1 00:00:00 /opt/zimbra/mysql/bin/mysqld --defaults-file=/opt/zimbra/conf/my.cnf --basedir=/op
    myzimbra 5874 5853 0 Nov11 pts/1 00:00:00 /opt/zimbra/mysql/bin/mysqld --defaults-file=/opt/zimbra/conf/my.cnf --basedir=/op
    myzimbra 5875 5853 0 Nov11 pts/1 00:00:00 /opt/zimbra/mysql/bin/mysqld --defaults-file=/opt/zimbra/conf/my.cnf --basedir=/op
    myzimbra 6076 4643 0 Nov11 pts/3 00:00:00 /bin/bash
    myzimbra 6197 1 0 Nov11 ? 00:00:00 /opt/zimbra/openldap/libexec/slapd -4 -u myzimbra -h ldap://:389/ -f /opt/zimbra/c


    when I ran the next line,
    (d) /opt/zimbra/bin/zmmtaconfig mta
    it started to generate errors:

    ERROR: account.NO_SUCH_SERVER (no such server: webmail.mydomain.com)
    ERROR: account.NO_SUCH_SERVER (no such server: webmail.mydomain.com)
    ERROR: account.NO_SUCH_SERVER (no such server: webmail.mydomain.com)

    I have tried to login as root and change the myhostname and mydomain to localhost in the /opt/zimbra/postfix/conf/main.cf file, and then run the commands again:
    - $ /opt/zimbra/libexec/zmmtainit localhost
    - $ /opt/zimbra/bin/zmmtaconfig mta

    It still generates the same error ! ;o(

    Any ideas ?
    Last edited by nick20; 11-12-2005 at 12:43 AM.

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Seems LDAP is running on 389, I think it should be on 7389 and port mapped with iptables in this rev. BTW: the next release will be out very soon and should provide a way to build all the dependancies from source which may make your life easier.

  3. #3
    Join Date
    Dec 2005
    Posts
    6
    Rep Power
    9

    Default

    Hey guys is anyone here using ZIMBRA on SLES ?
    Ive SLES here and Im thinking that it will be a good choice for our installation what do u think about ?

    regards,

  4. #4
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default SuSE build released last week


Similar Threads

  1. Replies: 9
    Last Post: 03-01-2008, 08:21 PM
  2. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  3. Logger
    By jholder in forum Installation
    Replies: 24
    Last Post: 03-31-2006, 11:50 AM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 05:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •