Results 1 to 2 of 2

Thread: Problems with upgrade from 8.0.1 version - asks to install zimbra-mta

  1. #1
    Join Date
    Dec 2010
    Location
    Riga
    Posts
    15
    Rep Power
    4

    Default [SOLVED] Problems with upgrade from 8.0.1 version - asks to install zimbra-mta

    Hi!

    Yesterday I did upgrade from 8.0.1 to 8.0.6 Zimbra Ubuntu 12.04 64-bit version, but I had few problems. After upgrade, messages were nor delivered, nor received. With reject message from Postfix.

    After problems, I have restored to snapshot, and LIVE server is up and running 8.0.1. But I havecreated a clone for test upgrades.

    So, the first thing: when I start ./install.sh, it asks for upgrade, and then - asks again to install zimbra-mta.
    MTA _IS_ installed already, and this would be required to upgrade it, not install as fresh service, am I right?

    Code:
    Checking for prerequisites...
         FOUND: NPTL
         FOUND: netcat-openbsd-1.89-4ubuntu1
         FOUND: sudo-1.8.3p1-1ubuntu3.4
         FOUND: libidn11-1.23-2
         FOUND: libpcre3-8.12-4
         FOUND: libgmp3c2-2:4.3.2+dfsg-2ubuntu1
         FOUND: libexpat1-2.0.1-7.2ubuntu1.1
         FOUND: libstdc++6-4.6.3-1ubuntu5
         FOUND: libperl5.14-5.14.2-6ubuntu2.3
    
    Checking for suggested prerequisites...
         FOUND: pax
         FOUND: perl-5.14.2
         FOUND: sysstat
         FOUND: sqlite3
    Prerequisite check complete.
    Checking current number of databases...
    
    Do you want to verify message store database integrity? [Y] n
    
    Checking for installable packages
    
    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell
    Found zimbra-memcached
    Found zimbra-proxy
    
    
    The Zimbra Collaboration Server appears already to be installed.
    It can be upgraded with no effect on existing accounts,
    or the current installation can be completely removed prior
    to installation for a clean install.
    
    Do you wish to upgrade? [Y] y
    
    Select the packages to install
        Upgrading zimbra-core
        Upgrading zimbra-ldap
        Upgrading zimbra-logger
    
    Install zimbra-mta [N]
    In fact - I had few problems with 8.0.1 before, where I was forced to restore few folders from backup, but do not remembre, probably postfix also.
    It would be the best - to install fresh 8.0.1 on new server, and move message and user store to new server, but I did not found good tutorial for 8th version. Does anyone has materials for that?
    Last edited by arnisraido; 01-12-2014 at 11:12 AM. Reason: Set solved by myself
    Release 8.0.1.GA.5438.UBUNTU12.64 UBUNTU12_64 FOSS edition.

  2. #2
    Join Date
    Dec 2010
    Location
    Riga
    Posts
    15
    Rep Power
    4

    Default

    Even
    Code:
    dpkg -s zimbra-mta
    did not found installed package (this is the same command install.sh ir running to determine installed packages).

    I decided to fix installation, based on forum [SOLVED] Upgrade Problem: zimbra-core...NOT FOUND : Release package zimbra-core is no

    0. MAKE FULL BACKUP. MAKE SNAPSHOT OR anything to be sure, if something goes wrong!!!

    1. stop all services
    Code:
    su - zimbra
    zmcontrol stop
    2. rename old zimbra
    Code:
    mv /opt/zimbra /opt/zimbra_bak
    3. install the same Zimbra version (in my case - 8.0.1) with "-s" switch (will install only software packages)
    and choose NOT TO UPGRADE, but install fresh version. It will show, that all mails/users will be deleted!
    Code:
    ./install.sh -s
    4. check, if all services are stopped
    Code:
    su - zimbra
    zmcontrol stop
    5. rename new version (or delete if You wish)
    Code:
    mv /opt/zimbra /opt/zimbra_new
    6. Now, run latest installation script, 8.0.6 in my case, with normal "./install.sh"
    Installation script now correctly recognizes, that zimbra-mta is installed.
    Now choose to upgrade!

    Everything went well. It took time to recognize, that all services are running in WEB ADMIN GUI, but in command line everything worked as expected.
    Release 8.0.1.GA.5438.UBUNTU12.64 UBUNTU12_64 FOSS edition.

Similar Threads

  1. Replies: 0
    Last Post: 11-17-2012, 04:32 AM
  2. Addressbook Problems after Upgrade to Version 8
    By Beat in forum Administrators
    Replies: 8
    Last Post: 09-25-2012, 05:19 AM
  3. Did I install the wrong version of Zimbra?
    By sshaffer in forum General Questions
    Replies: 0
    Last Post: 08-14-2011, 08:56 PM
  4. Replies: 8
    Last Post: 05-23-2011, 07:51 AM
  5. My zimbra not asks confirm accept share diary
    By depin in forum Administrators
    Replies: 0
    Last Post: 08-21-2009, 10:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •