Results 1 to 3 of 3

Thread: Problems after partition move

  1. #1
    Join Date
    Apr 2012
    Location
    Bracknell
    Posts
    44
    Rep Power
    3

    Default Problems after partition move

    Hi Folks

    Hope someone can help. I've just installed a new Zimbra NE server and, while migrating mailboxes to it from one of our old Sendmail servers, I suddenly realised that the partition for /root was only 70 Gbs and almost full. I had hoped the install would have gone into the large disk area under /home that I'd created for it but obviously I did something I shouldn't have done during the install and this is how we ended up.

    I did the following to move the partition:

    I shut down the services for Zimbra
    I rsynced everything from /opt/zimbra to /home/zimbra
    I did a ln -s /home/zimbra /opt/zimbra
    Restarted all services

    I checked the link to make sure that it's looking at /home/zimbra when changing to /opt/zimbra and it appears to be OK.

    When restarting the server, it came up with an Apache error on the httpd.pid file which I deleted and it's not come back with the error.

    However, now when stopping the services I get:

    antispam Running
    antivirus Running
    convertd Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    opendkim Stopped
    opendkim is not running.
    snmp Running
    spell Stopped
    zmapachectl is not running
    stats Running
    zmconfigd Running

    When I try to stop and restart I get this:

    Starting ldap...Done.
    Starting zmconfigd...Done.
    Starting logger...Done.
    Starting convertd...Done.
    Starting mailbox...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting opendkim...Done.
    Starting snmp...Done.
    Starting spell...Failed.
    Starting apache...(98)Address already in use: AH00072: make_sock: could not bind to address [::]:7780
    (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:7780
    no listening sockets available, shutting down
    AH00015: Unable to open logs
    failed.


    Starting mta...Done.
    Starting stats...Done.

    Can anyone help with this? This is a production server which the customer is expecting to be online tomorrow and, although I've moved the mailboxes across and sync'ed them, and the server appears to be OK and allowing connections, this does worry me a great deal. Have I done something I shouldn't have done in the move?

    Looking forward to hearing from you.
    Chris

  2. #2
    Join Date
    Apr 2012
    Location
    Bracknell
    Posts
    44
    Rep Power
    3

    Default

    A quick update:

    If I run netstate -lnp | grep ':80'

    I get

    tcp 0 0 127.0.0.1:80 0.0.0.0:* LISTEN 43185/java

    Not sure whether this muddies the water or not?

    Also, if I run
    [root]# ls -alh /opt/zimbra

    I get
    lrwxrwxrwx 1 root root 12 Mar 8 18:18 /opt/zimbra -> /home/zimbra

    Ermmm - I thought I would see the directory listing of /home/zimbra... I didn't....

    Cheers
    Chris
    Last edited by kenwardc; 03-09-2014 at 07:40 AM.

  3. #3
    Join Date
    May 2014
    Posts
    2
    Rep Power
    1

    Default

    Greetings:

    first thing you need to do is httpd.pid you can rename file with a different name not to lose it

    see that port 7780 with the command

    netstat - tcp - udp - listening - program

    see that port 7780 is occupied by httpd

    then you can kill the process with the command:

    killall httpd

    and come back to restart your services zimbra

    I hope to help you solve your problem

Similar Threads

  1. Can I add one more or other store partition
    By blason in forum Administrators
    Replies: 1
    Last Post: 01-04-2012, 09:56 AM
  2. how to move the zdb file to another path (new partition, hard drive..)
    By Michael REMY in forum Zimbra Connector for Outlook
    Replies: 4
    Last Post: 01-29-2010, 09:58 AM
  3. Move to new server problems
    By mluxton in forum Administrators
    Replies: 6
    Last Post: 04-27-2008, 01:06 AM
  4. Partition recommendations
    By ryandball in forum Installation
    Replies: 3
    Last Post: 12-28-2007, 08:34 PM
  5. Partition advice
    By jeg1972 in forum Installation
    Replies: 3
    Last Post: 01-19-2006, 12:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •