Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 36

Thread: Cannot connect to Zimbra after installation

  1. #21
    Join Date
    Sep 2005
    Location
    Amsterdam
    Posts
    44
    Rep Power
    10

    Default

    Well gentlemen,

    This is weird... I've removed the entire installation using ./install.sh -u, and then reinstalled it.

    When I did, everything was ok. Now everything actually works straight out!

    Thanks for the help!

  2. #22
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Awesome! Let us know how you like it.

  3. #23
    Join Date
    Sep 2005
    Posts
    7
    Rep Power
    10

    Default

    I am alos getting the :

    DBI connect('database=zimbra;mysql_read_default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152
    Here is a copy of install log:

    Preparing packages for installation...
    zimbra-core-2005.0.0_39.FC3-1_ARMSTRONG
    Preparing packages for installation...
    zimbra-ldap-2005.0.0_39.FC3-1_ARMSTRONG
    Preparing packages for installation...
    zimbra-mta-2005.0.0_39.FC3-1_ARMSTRONG
    Preparing packages for installation...
    zimbra-snmp-2005.0.0_39.FC3-1_ARMSTRONG
    Preparing packages for installation...
    zimbra-store-2005.0.0_39.FC3-1_ARMSTRONG
    COMMAND: zmmyinit
    * Creating required directories
    * Generating mysql config /opt/zimbra/conf/my.cnf
    * Creating database in /opt/zimbra/db/data
    * Starting mysql server
    * Loading schema /opt/zimbra/db/db.sql
    * Loading version from /opt/zimbra/db/versions-init.sql
    * Setting random password for mysql root user in zimbra local config
    * Setting random password for mysql zimbra user in zimbra local config
    * Changing mysql root user password
    * Changing mysql zimbra user password
    * Changed zimbra mysql user password
    COMMAND: zmlocalconfig -e zimbra_server_hostname=mail1.vipercomm.net
    COMMAND: zmlocalconfig -e ldap_host=mail1.vipercomm.net
    COMMAND: zmlocalconfig -e ldap_port=389
    COMMAND: zmldapinit
    /opt/zimbra/openldap/sbin/slappasswd: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
    /opt/zimbra/openldap/sbin/slappasswd: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
    /opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
    Started slapd: pid
    /opt/zimbra/openldap/bin/ldapmodify: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
    /opt/zimbra/openldap/bin/ldapmodify: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
    COMMAND: zmprov cs mail1.vipercomm.net
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail1.vipercomm.net:389)
    COMMAND: zmprov cd vipercomm.net
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail1.vipercomm.net:389)
    COMMAND: zmprov mcf zimbraDefaultDomainName vipercomm.net
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail1.vipercomm.net:389)
    COMMAND: zmprov ca admin@vipercomm.net 8939405 zimbraIsAdminAccount TRUE
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail1.vipercomm.net:389)
    COMMAND: id=`zmprov gs mail1.vipercomm.net | grep zimbraId | awk '{print $2}'`; for i in `zmprov gc default | grep zimbraMailHostPool | sed 's/zimbraMailHostPool: //'`; do host="$host zimbraMailHostPool $i"; done; zmprov mc default $host zimbraMailHostPool $id
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail1.vipercomm.net:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail1.vipercomm.net:389)
    zmprov [cmd] [args ...]

    CreateAccount(ca) {name@domain} {password} [attr1 value1 [attr2 value2...]]
    DeleteAccount(da) {name@domain|id}
    GetAccount(ga) {name@domain|id}
    GetAllAccounts(gaa) [-v] [{domain}]
    GetAllAdminAccounts(gaaa) [-v]
    ModifyAccount(ma) {name@domain|id} [attr1 value1 [attr2 value2...]]
    SetPassword(sp) {name@domain|id} {password}
    AddAccountAlias(aaa) {name@domain|id} {alias@domain}
    RemoveAccountAlias(raa) {name@domain|id} {alias@domain}
    SetAccountCos(sac) {name@domain|id} {cos-name|cos-id}
    SearchAccounts(sa) [-v] {ldap-query} [limit {limit}] [offset {offset}] [sortBy {attr}] [attrs {a1,a2...}] [sortAscending 0|1*] [applyCos [0|1*] [domain {domain}]
    SearchGal(sg) {domain} {name}
    RenameAccount(ra) {name@domain|id} {newName@domain}

    CreateDomain(cd) {domain} [attr1 value1 [attr2 value2...]]
    DeleteDomain(dd) {domain|id}
    GetDomain(gd) {domain|id}
    GetAllDomains(gad) [-v]
    ModifyDomain(md) {domain|id} [attr1 value1 [attr2 value2...]]

    CreateCos(cc) {name} [attr1 value1 [attr2 value2...]]
    DeleteCos(dc) {name|id}
    GetCos(gc) {name|id}
    GetAllCos(gac) [-v]
    ModifyCos(mc) {name|id} [attr1 value1 [attr2 value2...]]
    RenameCos(rc) {name|id} {newName}

    CreateServer(cs) {name} [attr1 value1 [attr2 value2...]]
    DeleteServer(ds) {name|id}
    GetServer(gs) {name|id}
    GetAllServers(gas) [-v]
    ModifyServer(ms) {name|id} [attr1 value1 [attr2 value2...]]

    GetAllConfig(gacf)
    GetConfig(gcf) {name}
    ModifyConfig(mcf) attr1 value1 [attr2 value2...]

    CreateDistributionList(cdl) {list@domain}
    GetAllDistributionLists(gadl) [-v]
    GetDistributionList(gdl) {list@domain|id}
    DeleteDistributionList(ddl) {list@domain|id}
    AddDistributionListMember(adlm) {list@domain|id} {member@domain}
    RemoveDistributionListMember(rdlm) {list@domain|id} {member@domain}

    exit (quit)
    help (?)

    COMMAND: zmmtainit mail1.vipercomm.net
    COMMAND: zmlocalconfig -e av_notify_user=rmroadee@vipercomm.net
    COMMAND: zmlocalconfig -e av_notify_domain=vipercomm.net
    COMMAND: zmlocalconfig -e snmp_notify=0
    COMMAND: zmlocalconfig -e smtp_notify=1
    COMMAND: zmlocalconfig -e snmp_trap_host=localhost.localdomain
    COMMAND: zmlocalconfig -e smtp_source=rmroadee@vipercomm.net
    COMMAND: zmlocalconfig -e smtp_destination=none
    COMMAND: zmsnmpinit
    creating /opt/zimbra/conf/swatchrc
    COMMAND: zmprov ms mail1.vipercomm.net zimbraServiceInstalled ldap zimbraServiceInstalled mailbox zimbraServiceInstalled mta zimbraServiceInstalled antivirus zimbraServiceInstalled antispam zimbraServiceInstalled snmp
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail1.vipercomm.net:389)
    Any ideas. I have read most of the threads and did the sybolic link and still have errors. Openssl is installed

    Any help would be great.

  4. #24
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default are you sure your openssl install is ok?

    Do:

    # file /lib/libssl.so.4

    I suspect you have a broken symbolic link to the real SSL shared library.

  5. #25
    Join Date
    Sep 2005
    Posts
    7
    Rep Power
    10

    Default

    Quote Originally Posted by anand
    Do:

    # file /lib/libssl.so.4

    I suspect you have a broken symbolic link to the real SSL shared library.
    /lib/libssl.so.4: symbolic link to `libssl.so.0.9.7f'

    I am pretty sure ooenssl is installed correctly. Did a rpm -qi openssl and got this

    Name : openssl Relocations: (not relocatable)
    Version : 0.9.7f Vendor: Red Hat, Inc.
    Release : 7 Build Date: Thu 19 May 2005 02:35:45 AM PDT
    Install Date: Thu 15 Sep 2005 04:38:52 PM PDT Build Host: tweety.build.redhat.com
    Group : System Environment/Libraries Source RPM: openssl-0.9.7f-7.src.rpm
    Size : 3388928 License: BSDish
    Signature : DSA/SHA1, Fri 20 May 2005 12:31:34 PM PDT, Key ID b44269d04f2a6fd2
    Packager : Red Hat, Inc.
    URL : http://www.openssl.org/
    Summary : The OpenSSL toolkit.
    Description :
    The OpenSSL toolkit provides support for secure communications between
    machines. OpenSSL includes a certificate management tool and shared
    libraries which provide various cryptographic algorithms and
    protocols.

  6. #26
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    What is the out put of:

    Code:
    ldd /opt/zimbra/openldap/libexec/slapd

  7. #27
    Join Date
    Sep 2005
    Posts
    7
    Rep Power
    10

    Default

    Quote Originally Posted by KevinH
    What is the out put of:

    Code:
    ldd /opt/zimbra/openldap/libexec/slapd
    Code:
    linux-gate.so.1 =>  (0x00d24000)
            libdb-4.2.so => /opt/zimbra/lib/libdb-4.2.so (0x00170000)
            libsasl2.so.2 => /opt/zimbra/cyrus-sasl/lib/libsasl2.so.2 (0x008c5000)
            libssl.so.4 => /lib/libssl.so.4 (0x00941000)
            libcrypto.so.4 => not found
            libresolv.so.2 => /lib/libresolv.so.2 (0x00101000)
            libpthread.so.0 => /lib/libpthread.so.0 (0x00d56000)
            libc.so.6 => /lib/libc.so.6 (0x00a98000)
            libdl.so.2 => /lib/libdl.so.2 (0x00bea000)
            libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x0097b000)
            libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x0076d000)
            libcom_err.so.2 => /lib/libcom_err.so.2 (0x0075e000)
            libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x007e6000)
            libcrypto.so.5 => /lib/libcrypto.so.5 (0x0021b000)
            libz.so.1 => /usr/lib/libz.so.1 (0x00bf0000)
            /lib/ld-linux.so.2 (0x00a7a000)
            libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x007e1000)

  8. #28
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Looke like your missing the link for:

    libcrypto.so.4 => not found

    If your on FC4



    cd /lib
    ln -s libcrypto.so.0.9.7f libcrypto.so.4

  9. #29
    Join Date
    Sep 2005
    Posts
    7
    Rep Power
    10

    Default

    Quote Originally Posted by KevinH
    Looke like your missing the link for:

    libcrypto.so.4 => not found

    If your on FC4



    cd /lib
    ln -s libcrypto.so.0.9.7f libcrypto.so.4
    I will give that a shot here.. Upgrading memory.

    After making that change, I uninstalled, reinstalled and it work. I made a mistake and reinstalling.. Now I need to work on setting it up so it is not on port 80 and can fuction with my web service and new custom dns.

    Will be having some users test it out this weekend.
    Last edited by rmroadee; 09-17-2005 at 01:14 AM. Reason: Adding

  10. #30
    Join Date
    Sep 2005
    Location
    Michigan
    Posts
    10
    Rep Power
    10

    Default Mailbox service doesn't start

    I have read through all of the current installation problem threads regarding Fedora and haven't seen this problem mentioned. The test system currently doesn't have a lot of memory, so I wonder if that may be the problem. I am unable to connect to the Admin console and I have performed all of the various checks I have seen posted (symlink to the SSL modules, reducing the values for thread concurrency and max connections in the my.conf file as well as checking the hosts file and LDAP status).

    Any guidance would be greatly appreciated.

    Frank
    Last edited by abtech; 09-18-2005 at 12:19 PM.

Similar Threads

  1. Reliable Zimbra installation on Debian Etch?
    By holunde in forum Installation
    Replies: 7
    Last Post: 06-21-2007, 12:01 AM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  3. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 11:45 AM
  4. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 09:19 AM
  5. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 07:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •