Page 1 of 2 12 LastLast
Results 1 to 10 of 36

Thread: Cannot connect to Zimbra after installation

Hybrid View

  1. #1
    Join Date
    Sep 2005
    Posts
    6
    Rep Power
    10

    Default Cannot connect to Zimbra after installation

    Cannot connect to 7071, cannot even see it in NETSTAT:
    Code:
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
    tcp        0      0 fugly.lawyer.local:7777     *:*                         LISTEN      22755/perl          
    tcp        0      0 *:7075                      *:*                         LISTEN      6309/master         
    tcp        0      0 fugly.lawyer.local:10025    *:*                         LISTEN      6309/master         
    tcp        0      0 fugly.lawyer.local:mysql    *:*                         LISTEN      19861/mysqld        
    tcp        0      0 192.168.100.1:domain        *:*                         LISTEN      2268/named          
    tcp        0      0 *:ssh                       *:*                         LISTEN      2280/sshd           
    tcp        0      0 192.168.100.1:squid         *:*                         LISTEN      2363/(squid)        
    tcp        0      0 fugly.lawyer.local:rndc     *:*                         LISTEN      2268/named          
    tcp        0      0 *:7389                      *:*                         LISTEN      2595/slapd          
    tcp        0      0 ::1:rndc                    *:*                         LISTEN      2268/named          
    udp        0      0 *:32768                     *:*                                     2268/named          
    udp        0      0 *:32770                     *:*                                     2363/(squid)        
    udp        0      0 192.168.100.1:domain        *:*                                     2268/named          
    udp        0      0 *:bootps                    *:*                                     2302/dhcpd          
    udp        0      0 *:bootpc                    *:*                                     2241/dhclient       
    udp        0      0 *:bootpc                    *:*                                     1789/dhclient       
    udp        0      0 *:32769                     *:*                                     2268/named
    I have tried to connect to all the exposed ports with the browser, no love.

    Any help is appreciated, I don't even know where to begin

    Thanks,

    Bob

  2. #2
    Join Date
    Sep 2005
    Posts
    6
    Rep Power
    10

    Default

    I suppose some more information might be in order...

    Centos 4.1 (RHEL4)
    set up as required, some additional software installed, no firewall in place (internal test system so this is OK for now)

    No error messages in zimbra.log
    No error messages in /var/log/messages

    Bob

  3. #3
    Join Date
    Sep 2005
    Posts
    6
    Rep Power
    10

    Default

    More info, found what looks like the problem:

    jakarta-tomcat-5.5.7/logs/catalina.out:MESSAGE: Access denied for user 'zimbra'@'fugly.lawyer.local' (using password: YES)
    jakarta-tomcat-5.5.7/logs/catalina.out:java.sql.SQLException: Access denied for user 'zimbra'@'fugly.lawyer.local' (using password: YES)

    Where can I change these settings?

    Thanks,

    Bob

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Make sure your /etc/hosts file has an entry like:

    127.0.0.1 localhost.localdomain localhost

    We've seen this problem when you have your hostname listed first in the list.

    -kevin

  5. #5
    Join Date
    Sep 2005
    Location
    Amsterdam
    Posts
    44
    Rep Power
    10

    Default

    I have the same issue, my netstat shows:

    Code:
    [root@localhost etc]# netstat -anp
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    tcp        0      0 127.0.0.1:7777              0.0.0.0:*                   LISTEN      2631/perl
    tcp        0      0 0.0.0.0:32769               0.0.0.0:*                   LISTEN      1579/rpc.statd
    tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      1561/portmap
    tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN      1888/cupsd
    tcp        0      0 127.0.0.1:5335              0.0.0.0:*                   LISTEN      1873/mDNSResponder
    tcp        0      0 :::22                       :::*                        LISTEN      1936/sshd
    tcp        0      0 ::1:45249                   ::1:32786                   TIME_WAIT   -
    tcp        0      0 ::1:58737                   ::1:32788                   TIME_WAIT   -
    tcp       52    148 ::ffff:192.168.8.235:22     ::ffff:192.168.8.244:3815   ESTABLISHED 3833/sshd: mark [pr
    udp        0      0 0.0.0.0:32768               0.0.0.0:*                               1579/rpc.statd
    udp      432      0 192.168.8.235:32769         192.168.8.51:53             ESTABLISHED 4127/java
    udp        0      0 0.0.0.0:907                 0.0.0.0:*                               1579/rpc.statd
    udp        0      0 0.0.0.0:68                  0.0.0.0:*                               1509/dhclient
    udp        0      0 0.0.0.0:5353                0.0.0.0:*                               1873/mDNSResponder
    udp        0      0 0.0.0.0:111                 0.0.0.0:*                               1561/portmap
    udp        0      0 0.0.0.0:631                 0.0.0.0:*                               1888/cupsd
    udp        0      0 192.168.8.235:123           0.0.0.0:*                               1949/ntpd
    udp        0      0 127.0.0.1:123               0.0.0.0:*                               1949/ntpd
    udp        0      0 0.0.0.0:123                 0.0.0.0:*                               1949/ntpd
    udp        0      0 :::123                      :::*                                    1949/ntpd
    This is on a fresh Fedora Core 4 installation. Nothing added, and sendmail off in the configs.

    When I try to restart zimbra I get:
    Code:
    [root@localhost etc]# /etc/init.d/zimbra restart
    Calling ShutDownRequest (gws.mine.nu)
    
    Calling startup (gws.mine.nu)
    
    [root@localhost etc]#
    What can we do?

    Thanks,
    Mark

  6. #6
    Join Date
    Sep 2005
    Location
    Amsterdam
    Posts
    44
    Rep Power
    10

    Default

    I just got a little more info when trying to restart zimbra from the commandline:

    Code:
    [root@localhost log]# /etc/init.d/zimbra restart
    Calling ShutDownRequest (gws.mine.nu)
    
    Calling startup (gws.mine.nu)
    
    perl /opt/zimbra/zimbramon/zmmon &
    
    RESPONSE: (Zimbra::Mon::serviceInfo)
            host
                    ip                  217.149.34.117
                    name                gws.mine.nu
    [root@localhost log]# DBI connect('database=zimbra;mysql_read_default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152
    Does that help?

  7. #7
    Join Date
    Sep 2005
    Location
    Germany
    Posts
    42
    Rep Power
    10

    Default MySQL does not start

    I installed ZCS on a new FC4. Only the stuff listening on port 7777 runs. MySQL and other ZCS does not:

    Code:
    [root@zimbra etc]# netstat -l -n --programs
    Aktive Internetverbindungen (Nur Server)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
    tcp        0      0 127.0.0.1:7777              0.0.0.0:*                   LISTEN      3480/perl           
    tcp        0      0 0.0.0.0:32769               0.0.0.0:*                   LISTEN      1616/rpc.statd      
    tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      1597/portmap        
    tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN      1986/cupsd          
    tcp        0      0 127.0.0.1:5335              0.0.0.0:*                   LISTEN      1968/mDNSResponder  
    tcp        0      0 :::22                       :::*                        LISTEN      2034/sshd           
    udp        0      0 0.0.0.0:32768               0.0.0.0:*                               1616/rpc.statd      
    udp        0      0 0.0.0.0:944                 0.0.0.0:*                               1616/rpc.statd      
    udp        0      0 0.0.0.0:5353                0.0.0.0:*                               1968/mDNSResponder  
    udp        0      0 0.0.0.0:111                 0.0.0.0:*                               1597/portmap        
    udp        0      0 0.0.0.0:631                 0.0.0.0:*                               1986/cupsd          
    udp        0      0 192.168.2.71:123            0.0.0.0:*                               2048/ntpd           
    udp        0      0 127.0.0.1:123               0.0.0.0:*                               2048/ntpd           
    udp        0      0 0.0.0.0:123                 0.0.0.0:*                               2048/ntpd           
    udp        0      0 :::123                      :::*                                    2048/ntpd
    /etc/init.d/zimbra restart takes an eternity to finish and yields

    Code:
    Calling ShutDownRequest (zimbra.gtds.lan)
    
    Calling startup (zimbra.gtds.lan)
    
    perl /opt/zimbra/zimbramon/zmmon &
    
    RESPONSE: (Zimbra::Mon::serviceInfo)
            host
                    ip                  192.168.2.71
                    name                zimbra.gtds.lan
    [root@zimbra ~]# DBI connect('database=zimbra;mysql_read_default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152
    with the DBI error mesaage repeating until I kill the process.

    As far as I can tell MySQL never get started. There is nothing MySQL related inside /etc/init.d/. I remember thar MySQL was started by nstall.sh and under /opt/zimbra/db/data/ is a zimbra directory.

    Can you help? TIA.

    Regards,

    Gert

  8. #8
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Looke like your missing the link for:

    libcrypto.so.4 => not found

    If your on FC4



    cd /lib
    ln -s libcrypto.so.0.9.7f libcrypto.so.4

  9. #9
    Join Date
    Sep 2005
    Posts
    7
    Rep Power
    10

    Default

    Quote Originally Posted by KevinH
    Looke like your missing the link for:

    libcrypto.so.4 => not found

    If your on FC4



    cd /lib
    ln -s libcrypto.so.0.9.7f libcrypto.so.4
    I will give that a shot here.. Upgrading memory.

    After making that change, I uninstalled, reinstalled and it work. I made a mistake and reinstalling.. Now I need to work on setting it up so it is not on port 80 and can fuction with my web service and new custom dns.

    Will be having some users test it out this weekend.
    Last edited by rmroadee; 09-17-2005 at 02:14 AM. Reason: Adding

  10. #10
    Join Date
    Sep 2005
    Location
    Michigan
    Posts
    10
    Rep Power
    10

    Default Mailbox service doesn't start

    I have read through all of the current installation problem threads regarding Fedora and haven't seen this problem mentioned. The test system currently doesn't have a lot of memory, so I wonder if that may be the problem. I am unable to connect to the Admin console and I have performed all of the various checks I have seen posted (symlink to the SSL modules, reducing the values for thread concurrency and max connections in the my.conf file as well as checking the hosts file and LDAP status).

    Any guidance would be greatly appreciated.

    Frank
    Last edited by abtech; 09-18-2005 at 01:19 PM.

Similar Threads

  1. Reliable Zimbra installation on Debian Etch?
    By holunde in forum Installation
    Replies: 7
    Last Post: 06-21-2007, 01:01 AM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 12:34 PM
  3. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  4. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 10:19 AM
  5. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 08:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •