Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 47

Thread: No_Such_Server

  1. #11
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by vpoorboy
    I have the same problem with Zimbra Binaries for FC4. It showed the same error though "etc/hosts" is "127.0.0.1 localhost.localdomain localhost"
    Your /etc/hosts should have 2 lines. The 2nd line needs your real IP address and both FQDN and short host name.

  2. #12
    Join Date
    Nov 2005
    Posts
    19
    Rep Power
    10

    Default

    Anyone have any suggestions on troubleshooting this No_Such_Server error I am recieving on install of M2 on a fresh install of FC3?

    My domain name of the zimbra box resolves to the correct IP address on the Zimbra box using nslookup domain.domainname.com.

    I was able and am still able to load M1 on a clean install of FC3 and it works without any issues..

    My host file is correct and looks like this:

    127.0.0.7 localhost.localdomain locahost
    xx.xx.xx.xx zmail.domainname.com


    anyone know anyting else that I can try in order to troubleshoot this No_Such_Server error that I receive..

  3. #13
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by chamo
    127.0.0.7 localhost.localdomain locahost
    xx.xx.xx.xx zmail.domainname.com
    You last line should look like:

    xx.x.x.x zmail.domainname.com zmail


    You were missing the local part. Are there any errors in your /tmp/install.log?

  4. #14
    Join Date
    Nov 2005
    Posts
    19
    Rep Power
    10

    Default

    I left the short name off my post..
    /etc/hosts does look like:

    xx.xx.xx.xx zmail.domain.com zmail

    install log shows the following error:
    cat: /opt/zimbra/zimbramon/zimbra.cf . in: No such file or directory
    ERROR: service.Failure (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)

    not sure if this error is becuase of a reinstall after doing several ./install.sh then ./install.sh -u

  5. #15
    Join Date
    Oct 2005
    Posts
    67
    Rep Power
    10

    Default

    Yes, I also have the same problems. Adding the second line in /etc/hosts has no effect. Reinstalling Zimbra I faced "No such server" again. I run "zmcontrol start" and here is the error:
    Code:
    Host mail.test.homedns.org
            Starting ldap...Done.
    ERROR: account.NO_SUCH_SERVER (no such server: mail.test.homedns.org)
    And the content of "/etc/hosts":

    Code:
    127.0.0.1       localhost.localdomain   localhost
    192.168.1.33   mail.test.homedns.org mail
    Note that 192.168.1.33 is the local IP that the modem assigns to my NIC. The modem has an Outside IP: a.b.c.d .But it's not static, so I use dynDNS to map it to test.homedns.org.
    I've tried replacing 192.168.1.33 with a.b.c.d, but there's still the problem.

    I think in my system, Zimbra doesnot rely much on "/etc/hosts". With a dns system installed maybe the problem will be solved.
    Last edited by vpoorboy; 11-21-2005 at 11:03 PM.

  6. #16
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default ldap, not /etc/hosts

    the no such server error, I believe, means the servername isn't configured in ldap - run zmprov gas, and see if the server is listed.

  7. #17
    Join Date
    Nov 2005
    Posts
    19
    Rep Power
    10

    Default

    When I run zmprov gas, i get the following:

    ERROR: service:FAILURE (system failure: unabel to list all servers) (cause: javax.naming.NameNotFoundException [LDAP: error code 32 - No Such Object])

    This is on a clean install done last night on a clean install of FC3 with yum uodate run, and all the needed installs before running ./install.sh.

    any ideas?

  8. #18
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default That is strange

    I'm not sure what's causing that - were there ldap errors in the install.log in /tmp? Is slapd running? (I assume that it is).

    Does
    /opt/zimbra/openldap/sbin/slapcat -f conf/slapd.conf | grep dn | grep servers
    return a line with your server name in it?

    What does zmhostname return?

  9. #19
    Join Date
    Nov 2005
    Posts
    19
    Rep Power
    10

    Default

    slapd is running..

    running:
    /opt/zimbra/openldap/sbin/slapcat -f conf/slapd.conf | grep dn | grep servers
    returns 'slapcat: bad configuration file!'

    running zmhostname returns my correct FQDN.


    here is my install log:
    Preparing packages for installation...
    zimbra-core-3.0.0_M2_740.FC3-20051114171941
    cat: /opt/zimbra/zimbramon/zimbra.cf.in: No such file or directory
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    mkdir: cannot create directory `/opt/zimbra/.ssh': File exists
    Preparing packages for installation...
    zimbra-ldap-3.0.0_M2_740.FC3-20051114171941
    cat: /opt/zimbra/zimbramon/zimbraldap.cf: No such file or directory
    Preparing packages for installation...
    zimbra-logger-3.0.0_M2_740.FC3-20051114171941
    cat: /opt/zimbra/zimbramon/zimbralogger.cf: No such file or directory
    Preparing packages for installation...
    zimbra-mta-3.0.0_M2_740.FC3-20051114171941
    cat: /opt/zimbra/zimbramon/zimbramta.cf: No such file or directory
    Preparing packages for installation...
    zimbra-snmp-3.0.0_M2_740.FC3-20051114171941
    cat: /opt/zimbra/zimbramon/zimbrasnmp.cf: No such file or directory
    Preparing packages for installation...
    zimbra-store-3.0.0_M2_740.FC3-20051114171941
    cat: /opt/zimbra/zimbramon/zimbramail.cf: No such file or directory
    Preparing packages for installation...
    zimbra-apache-3.0.0_M2_740.FC3-20051114171941
    Preparing packages for installation...
    zimbra-spell-3.0.0_M2_740.FC3-20051114171941

  10. #20
    Join Date
    Oct 2005
    Posts
    67
    Rep Power
    10

    Default

    yes, all errors Chamo had with his FC3 box are the same with mine (FC4 box). What's the problem ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •