Results 1 to 8 of 8

Thread: Zimbra 4.5.1 -> 4.5.2 zimbra-spell failure

  1. #1
    Join Date
    Nov 2006
    Location
    Canada
    Posts
    69
    Rep Power
    9

    Default Zimbra 4.5.1 -> 4.5.2 zimbra-spell failure

    When I attempt to upgrade Zimbra 4.5.1 to 4.5.2 I am getting an error when the install script tries to install zimbra-spell-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm. The full install log looks like this:

    Code:
    [root@tiny zcs]# ./install.sh
    hostname: Unknown host
    ./util/utilfunc.sh: line 42: [: =: unary operator expected
    hostname: Unknown host
    
    Operations logged to /tmp/install.log.17269
    Checking for existing installation...
        zimbra-ldap...FOUND zimbra-ldap-4.5.2_GA_699
        zimbra-logger...FOUND zimbra-logger-4.5.2_GA_699
        zimbra-mta...FOUND zimbra-mta-4.5.2_GA_699
        zimbra-snmp...FOUND zimbra-snmp-4.5.2_GA_699
        zimbra-store...FOUND zimbra-store-4.5.2_GA_699
        zimbra-apache...FOUND zimbra-apache-4.5.2_GA_699
        zimbra-spell...NOT FOUND
        zimbra-core...FOUND zimbra-core-4.5.2_GA_699
    
    Saving existing configuration file to /opt/zimbra/.saveconfig
    
    
    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.
    
    License Terms for the Zimbra Collaboration Suite:
            http://www.zimbra.com/license/collaboration_suite_collective_license_1.0.html
    
    
    Press Return to continue
    
    Checking for prerequisites...
        NPTL...FOUND
        sudo...FOUND sudo-1.6.7p5-30.1.3
        libidn...FOUND libidn-0.5.6-1
        curl...FOUND curl-7.12.1-8
        fetchmail...FOUND fetchmail-6.2.5-6
        gmp...FOUND gmp-4.1.4-3
        compat-libstdc++-296...FOUND compat-libstdc++-296-2.96-132.7.2
        compat-libstdc++-33...FOUND compat-libstdc++-33-3.2.3-47.3
        /usr/lib/libstdc++.so.5...FOUND
    Checking for required space...
    Checking current number of databases...
    
    Checking for installable packages
    
    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell
    
    
    The Zimbra Collaboration Suite appears already to be installed.
    It can be upgraded with no effect on existing accounts,
    or the current installation can be completely removed prior
    to installation for a clean install.
    
    Do you wish to upgrade? [Y] y
    
    Select the packages to install
        Upgrading zimbra-core
        Upgrading zimbra-ldap
        Upgrading zimbra-logger
        Upgrading zimbra-mta
        Upgrading zimbra-snmp
        Upgrading zimbra-store
        Upgrading zimbra-apache
    
    Install zimbra-spell [N] y
    
    Installing:
        zimbra-core
        zimbra-ldap
        zimbra-logger
        zimbra-mta
        zimbra-snmp
        zimbra-store
        zimbra-apache
        zimbra-spell
    You appear to be installing packages on a platform different
    than the platform for which they were built
    
    This platform is CentOS4
    Packages found: zimbra-core-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm
    This may or may not work
    
    
    Install anyway? [N] y
    
    The system will be modified.  Continue? [N] y
    
    Shutting down zimbra mail
    
    Backing up ldap
    
    
    Removing existing packages
    
       zimbra-ldap...done
       zimbra-logger...done
       zimbra-mta...done
       zimbra-snmp...done
       zimbra-store...done
       zimbra-apache...done
       zimbra-core...done
    
    Removing deployed webapp directories
    Installing packages
    
        zimbra-core......zimbra-core-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-ldap......zimbra-ldap-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-logger......zimbra-logger-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-mta......zimbra-mta-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-snmp......zimbra-snmp-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-store......zimbra-store-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-apache......zimbra-apache-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-spell......zimbra-spell-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...FAILED
    ###ERROR###
    
    zimbra-spell-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm installation failed
    
    Installation cancelled
    I've already tried removing the spelling component all together and then letting it reinstall that RPM from scratch but that hasn't solved the problem. Any ideas?

  2. #2
    Join Date
    Nov 2006
    Location
    Canada
    Posts
    69
    Rep Power
    9

    Default

    I got it fixed. There was a problem with my /etc/hosts file.

  3. #3
    Join Date
    Nov 2006
    Location
    Canada
    Posts
    69
    Rep Power
    9

    Default

    New error now:

    Code:
    Installing packages
    
        zimbra-core......zimbra-core-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-ldap......zimbra-ldap-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-logger......zimbra-logger-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-mta......zimbra-mta-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-snmp......zimbra-snmp-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-store......zimbra-store-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-apache......zimbra-apache-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
        zimbra-spell......zimbra-spell-4.5.2_GA_699.RHEL4-20070216161813.i386.rpm...done
    
    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
       HOSTNAME=localhost.localdomain
       LDAPHOST=
       LDAPPORT=
       SNMPTRAPHOST=
       SMTPSOURCE=
       SMTPDEST=
       SNMPNOTIFY=0
       SMTPNOTIFY=0
       LDAPROOTPW=zimbra
       LDAPZIMBRAPW=zimbra
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    Operations logged to /tmp/zmsetup.log.7498
    Setting defaults...Setting defaults from existing config...Warning: null valued key 'mysql_logger_root_password'
    Done
    Upgrading from 4.5.1_GA_660 to 4.5.2_GA_699
    Fri Feb 23 13:59:10 2007: Stopping zimbra services
    Fri Feb 23 13:59:16 2007: Stop failed - exiting
    UPGRADE FAILED - exiting
    I checked the log file and found nothing more then what you see here "UPGRADE FAILED - ERROR"

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Looks like your save config got deleted. Do you have backup?
    It would have been in /opt/zimbra/.saveconfig/config.save

  5. #5
    Join Date
    Nov 2006
    Location
    Canada
    Posts
    69
    Rep Power
    9

    Default

    Unfortunatly I wasn't smart enough to back it up before the upgrade. I've since removed Zimbra, reinstalled 4.5.1 and am going to copy my midnight backup over top of the fresh install and then try the upgrade again.

  6. #6
    Join Date
    Nov 2006
    Location
    Canada
    Posts
    69
    Rep Power
    9

    Default

    I got it all going.

  7. #7
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Good Job Fizi.

    Remember, if you EVER have difficulty, we're here to help. . .it just may take a few minutes.

    -john

  8. #8
    Join Date
    Nov 2006
    Location
    Canada
    Posts
    69
    Rep Power
    9

    Default

    Thanks! Great to know the support is there and free to boot

    I fixed the problem by installing Zimbra 4.5.1 and then copying my entire backup of the /opt/zimbra dir back over top of it. I ran fixperms as per the Wiki Article for restoring backups and then I re-ran the upgrade to Zimbra 4.5.2 and it fixed any of the fiddly problems left over from the backup restore.

Similar Threads

  1. Removing hostname from hosts file fixed prob.
    By lemur in forum Installation
    Replies: 10
    Last Post: 06-13-2007, 07:29 PM
  2. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  4. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 05:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •