Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Failed upgrade from 4.0.5 to 4.5.2

  1. #1
    Join Date
    Dec 2005
    Location
    Eugene, OR
    Posts
    78
    Rep Power
    10

    Default Failed upgrade from 4.0.5 to 4.5.2

    Upgrade failed.

    This is the error message.

    ERROR 1005 (HY000) at line 2: Can't create table './mboxgroup11/#sql-1107_9d.frm' (errno: 150)
    Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=[password here] --database=zimbra --batch --skip-co lumn-names'. at /opt/zimbra/libexec/scripts/Migrate.pm line 220, line 21.
    Sat Feb 24 13:21:26 2007: Script failed with code 1 - exiting
    UPGRADE FAILED - exiting


    Is this the same problem other poeple are having?

    Is there a fix?
    Last edited by jholder; 02-24-2007 at 02:38 PM.

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    I edited your post because it contained your mysql password. . .and I assumed you didn't want that floating around

    That is a different error.
    You have a backup, right?

    If so, can you restore, then erase everything in /tmp and try again?

    -john

  3. #3
    Join Date
    Dec 2005
    Location
    Eugene, OR
    Posts
    78
    Rep Power
    10

    Default

    I do have a full backup using zmbackup. Should I do a down grade then restore?

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Yup.
    I'm looking into what could cause your problem now.

    -john

  5. #5
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Can you post the following files:

    /opt/zimbra/log/mysqld.log or /opt/zimbra/db/data/.err.
    And your install.log would be helpful as well.

    -john

  6. #6
    Join Date
    Dec 2005
    Location
    Eugene, OR
    Posts
    78
    Rep Power
    10

    Default

    Here is the .com.err

    070224 13:18:22 mysqld started
    070224 13:18:23 InnoDB: Started; log sequence number 0 420624428
    070224 13:18:23 [Note] /opt/zimbra/mysql/libexec/mysqld: ready for connections.
    Version: '5.0.33-log' socket: '/opt/zimbra/db/mysql.sock' port: 7306 Source distribution

    Here is the mysqld.log- This appears to be before the upgrade.

    070208 19:12:44 mysqld ended

    070208 19:13:11 mysqld started
    070208 19:13:14 InnoDB: Started; log sequence number 0 377207864
    /opt/zimbra/mysql/libexec/mysqld: ready for connections.
    Version: '4.1.20-log' socket: '/opt/zimbra/db/mysql.sock' port: 7306 Source distribution
    070216 13:52:07 [Note] /opt/zimbra/mysql/libexec/mysqld: Normal shutdown

    070216 13:52:07 InnoDB: Starting shutdown...
    070216 13:52:09 InnoDB: Shutdown completed; log sequence number 0 399173266
    070216 13:52:09 [Note] /opt/zimbra/mysql/libexec/mysqld: Shutdown complete

    070216 13:52:09 mysqld ended

    070216 13:54:45 mysqld started
    070216 13:54:47 InnoDB: Started; log sequence number 0 399173266
    /opt/zimbra/mysql/libexec/mysqld: ready for connections.
    Version: '4.1.20-log' socket: '/opt/zimbra/db/mysql.sock' port: 7306 Source distribution
    070216 16:41:32 [Note] /opt/zimbra/mysql/libexec/mysqld: Normal shutdown

    070216 16:41:32 InnoDB: Starting shutdown...
    070216 16:41:35 InnoDB: Shutdown completed; log sequence number 0 399651359
    070216 16:41:35 [Note] /opt/zimbra/mysql/libexec/mysqld: Shutdown complete

    070216 16:41:35 mysqld ended

    070216 16:44:10 mysqld started
    070216 16:44:11 InnoDB: Started; log sequence number 0 399651359
    /opt/zimbra/mysql/libexec/mysqld: ready for connections.
    Version: '4.1.20-log' socket: '/opt/zimbra/db/mysql.sock' port: 7306 Source distribution
    070224 13:15:39 [Note] /opt/zimbra/mysql/libexec/mysqld: Normal shutdown

    070224 13:15:40 InnoDB: Starting shutdown...
    070224 13:15:43 InnoDB: Shutdown completed; log sequence number 0 420624428
    070224 13:15:43 [Note] /opt/zimbra/mysql/libexec/mysqld: Shutdown complete

    070224 13:15:43 mysqld ended

  7. #7
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Nothing odd. . .What about the other ones?

  8. #8
    Join Date
    Dec 2005
    Location
    Eugene, OR
    Posts
    78
    Rep Power
    10

    Default

    See the attached install.log

  9. #9
    Join Date
    Dec 2005
    Location
    Eugene, OR
    Posts
    78
    Rep Power
    10

    Default

    see attached

  10. #10
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Attached where?

Similar Threads

  1. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 10:23 PM
  2. failed upgrade, failed restore, big trouble
    By feralcoder in forum Installation
    Replies: 2
    Last Post: 03-19-2007, 06:38 PM
  3. Lotus migration
    By babou in forum Migration
    Replies: 15
    Last Post: 03-05-2007, 10:33 PM
  4. Upgrade FROM 4.0.5 GA 518 to 4.5 GA 612 Failed
    By jcone in forum Installation
    Replies: 7
    Last Post: 01-18-2007, 08:51 PM
  5. Replies: 18
    Last Post: 03-20-2006, 02:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •