Results 1 to 9 of 9

Thread: Zimbra Multiserver - Some services are not running

Hybrid View

  1. #1
    Join Date
    Jan 2013
    Location
    Brasil
    Posts
    18
    Rep Power
    2

    Default Zimbra Multiserver - Some services are not running

    Hi Folks,

    I recently installed the multiserver Zimbra.
    I have 4 servers running smoothly however, the administration appears that some services are not running, but they are.
    I followed the instructions of the links

    Enabling Server Statistics Display, of Zimbra Multi-server Install, and

    Multi-Server-Installation-Notes - wiki.zimbra

    Services not working
    not_work.png


    But services are working
    status_working.png

    so, i cant see the truth.... some idea to solve ?
    zmcontrol -v
    Release 8.0.7_GA_6021.RHEL6_64_20140408123911 RHEL6_64 FOSS edition

    On CentOS 6.5 with rsyslog
    Last edited by saulfelipe; 05-22-2014 at 07:55 AM.

    Saul Figueiredo
    Support Analyst
    LPIC1
    LPIC2
    Zimbra 8.0.5/CentOS 6.3

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by saulfelipe View Post
    so, i cant see the truth.... some idea to solve ?
    The usual reason for this is that you haven't installed/configured/started/restarted syslog on each of those server. Have you done any of that, as per the documentation?

    You also haven't provided any information on the ZCS version in use, you should always post the output of the following command:

    Code:
    zmcontrol -v
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jan 2013
    Location
    Brasil
    Posts
    18
    Rep Power
    2

    Default

    Quote Originally Posted by phoenix View Post

    Code:
    zmcontrol -v
    zmcontrol -v
    Release 8.0.7_GA_6021.RHEL6_64_20140408123911 RHEL6_64 FOSS edition.

    thanks bill
    Yes i done but not work...

    Saul Figueiredo
    Support Analyst
    LPIC1
    LPIC2
    Zimbra 8.0.5/CentOS 6.3

  4. #4
    Join Date
    May 2014
    Location
    Madrid
    Posts
    202
    Rep Power
    1

    Default

    Hi,
    This is typcial error in Zimbra, I don't know why but sometimes is not working propertly, try this two solutions:
    First one:
    1. Server configuration.
    1.1 Edit the file “/etc/rsyslog.conf”.
    Uncomment this lines
    $ModLoad imudp
    $UDPServerRun 514

    1.2 Edit the file “/etc/rsyslog.d/60-zimbra.conf”
    Let your file like this:
    #local0.* @
    local0.* -/var/log/zimbra.log
    #local1.* @
    local1.* -/var/log/zimbra-stats.log
    #auth.* @
    auth.* -/var/log/zimbra.log
    #mail.* @
    mail.* -/var/log/zimbra.log

    Restart rsyslog service.
    # service rsyslog restart

    2. Client configuration
    Just check that in the file “/etc/rsyslog.d/60-zimbra.conf” is propertly cofigure to the "main" server

    Second one, I'm sorry bu is in Spanish, but very easy to follow:
    Zimbra: Solucionando error services not running (cruces rojas) » Blog de Jorge de la Cruz


    Kind regards

  5. #5
    Join Date
    Jan 2013
    Location
    Brasil
    Posts
    18
    Rep Power
    2

    Default

    Quote Originally Posted by jorgedelacruz.es View Post

    1.2 Edit the file “/etc/rsyslog.d/60-zimbra.conf”
    Restart rsyslog service.
    # service rsyslog restart

    2. Client configuration
    Just check that in the file “/etc/rsyslog.d/60-zimbra.conf” is propertly cofigure to the "main" server

    Second one, I'm sorry bu is in Spanish, but very easy to follow:
    Zimbra: Solucionando error services not running (cruces rojas) » Blog de Jorge de la Cruz


    Kind regards


    Item 1.1 is ok but the 1.2 and 2 (cliente configuration) do not exists on my servers or clients:

    Code:
     
    [root@zm2 rsyslog.d]# pwd
    /etc/rsyslog.d
    [root@zm2 rsyslog.d]# ls -la
    total 16
    drwxr-xr-x.   2 root root  4096 Nov 22 13:15 .
    drwxr-xr-x. 101 root root 12288 Mai 20 03:13 ..
    what can i do?

    Saul Figueiredo
    Support Analyst
    LPIC1
    LPIC2
    Zimbra 8.0.5/CentOS 6.3

  6. #6
    Join Date
    Jan 2013
    Location
    Brasil
    Posts
    18
    Rep Power
    2

    Default

    Quote Originally Posted by jorgedelacruz.es View Post
    Second one, I'm sorry bu is in Spanish, but very easy to follow:
    Zimbra: Solucionando error services not running (cruces rojas) » Blog de Jorge de la Cruz


    Kind regards
    oh, sorry, i am reading this link now, i will try it

    Saul Figueiredo
    Support Analyst
    LPIC1
    LPIC2
    Zimbra 8.0.5/CentOS 6.3

  7. #7
    Join Date
    Jan 2013
    Location
    Brasil
    Posts
    18
    Rep Power
    2

    Default

    on my mta, proxy and ldap:

    Code:
    /etc/rsyslog.conf
    # rsyslog v5 configuration file
    
    # For more information see /usr/share/doc/rsyslog-*/rsyslog_conf.html
    # If you experience problems, see http://www.rsyslog.com/doc/troubleshoot.html
    
    #### MODULES ####
    
    $ModLoad imuxsock # provides support for local system logging (e.g. via logger command)
    $ModLoad imklog   # provides kernel logging support (previously done by rklogd)
    #$ModLoad immark  # provides --MARK-- message capability
    
    # Provides UDP syslog reception
    #$ModLoad imudp
    #$UDPServerRun 514
    
    # Provides TCP syslog reception
    #$ModLoad imtcp
    #$InputTCPServerRun 514
    *.* @@mailbox.DOMAIN.com.br:10514
    Realy... port 514 tcp dont work, but, with 10514 works...


    starting work.png

    Saul Figueiredo
    Support Analyst
    LPIC1
    LPIC2
    Zimbra 8.0.5/CentOS 6.3

Similar Threads

  1. Replies: 0
    Last Post: 07-13-2012, 03:02 AM
  2. Replies: 1
    Last Post: 05-21-2012, 12:00 AM
  3. Running Zimbra with other services
    By dbarro in forum Administrators
    Replies: 1
    Last Post: 09-28-2007, 09:24 AM
  4. multiserver zimbra using fedora directory services
    By riggger in forum Installation
    Replies: 3
    Last Post: 10-03-2006, 10:10 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •