Results 1 to 7 of 7

Thread: Problem in Outlook 2003 with SMTPS

  1. #1
    Join Date
    Jul 2006
    Location
    Zurich, Switzerland
    Posts
    29
    Rep Power
    9

    Question Problem in Outlook 2003 with SMTPS

    Hello,

    I just upgraded Zimbra Open Source Edition 4.0.5 to 4.5.3. Everythings seems to work fine, just as before. The only problem I have is sending emails in Outlook. My server runns Debian 3.1.

    My MTA (and IMAP) is authentication enabled and need TLS authentication. For Outlook2003 purposes, I did what it is described here: http://wiki.zimbra.com/index.php?tit...r_SSL_port_465 (it worked before the upgrade). During Upgrade, these settings got lost, so I enabled it again - and did restart the server.

    In Outlook I get the following error when sending an email: "Your outgoing (SMTP) server does not support SSL-Secured connections"
    When I check in the admin console, I have this option set in "Global Settings" and in the server settings (MTA tab).

    /var/log/zimbra.log shows the following:
    Mar 2 23:01:27 mail postfix/smtpd[27523]: connect from MY_NOTEBOOK_FQDN[MY_NOTEBOOK_IP]
    Mar 2 23:01:27 mail postfix/smtpd[27523]: setting up TLS connection from MY_NOTEBOOK_FQDN[MY_NOTEBOOK_IP]
    Mar 2 23:01:27 mail postfix/smtpd[27523]: Could not allocate 'TLScontext->con' with SSL_new()
    Mar 2 23:01:27 mail postfix/smtpd[27523]: warning: TLS library problem: 27523:error:140BA0C3:SSL routines:SSL_new:null ssl ctx:ssl_lib.c:231:
    Mar 2 23:01:27 mail postfix/smtpd[27523]: lost connection after CONNECT from MY_NOTEBOOK_FQDN[MY_NOTEBOOK_IP]
    Mar 2 23:01:27 mail postfix/smtpd[27523]: disconnect from MY_NOTEBOOK_FQDN[MY_NOTEBOOK_IP]
    Mar 2 23:01:27 mail postfix/smtpd[27525]: connect from MY_NOTEBOOK_FQDN[MY_NOTEBOOK_IP]
    Mar 2 23:01:27 mail postfix/smtpd[27525]: setting up TLS connection from MY_NOTEBOOK_FQDN[MY_NOTEBOOK_IP]
    Mar 2 23:01:27 mail postfix/smtpd[27525]: Could not allocate 'TLScontext->con' with SSL_new()
    Mar 2 23:01:27 mail postfix/smtpd[27525]: warning: TLS library problem: 27525:error:140BA0C3:SSL routines:SSL_new:null ssl ctx:ssl_lib.c:231:
    Mar 2 23:01:27 mail postfix/smtpd[27525]: lost connection after CONNECT from MY_NOTEBOOK_FQDN[MY_NOTEBOOK_IP]
    Mar 2 23:01:27 mail postfix/smtpd[27525]: disconnect from MY_NOTEBOOK_FQDN[MY_NOTEBOOK_IP]
    Mar 2 23:01:27 mail postfix/smtpd[27523]: connect from MY_NOTEBOOK_FQDN[MY_NOTEBOOK_IP]
    Mar 2 23:01:27 mail postfix/smtpd[27523]: setting up TLS connection from MY_NOTEBOOK_FQDN[MY_NOTEBOOK_IP]
    Mar 2 23:01:27 mail postfix/smtpd[27523]: Could not allocate 'TLScontext->con' with SSL_new()
    Mar 2 23:01:27 mail postfix/smtpd[27523]: warning: TLS library problem: 27523:error:140BA0C3:SSL routines:SSL_new:null ssl ctx:ssl_lib.c:231:
    Mar 2 23:01:27 mail postfix/smtpd[27523]: lost connection after CONNECT from MY_NOTEBOOK_FQDN[MY_NOTEBOOK_IP]
    Mar 2 23:01:27 mail postfix/smtpd[27523]: disconnect from MY_NOTEBOOK_FQDN[MY_NOTEBOOK_IP]

    What could be the reason for this error?

    Thank for your hints!

    Regards,
    m.a.g.

  2. #2
    Join Date
    Jul 2006
    Location
    Zurich, Switzerland
    Posts
    29
    Rep Power
    9

    Default

    Some more information - what I figured out:
    - Authentication isn't working either for SMTP. It makes no difference if "Enable authentication " and "TLS authentication only" are checked or not: SMTP only works without authentication and without SSL.
    - My commercial Certificates in /opt/zimbra/conf/smtp.crt & .key got overwritten during upgrade -> I replaced them, no effect.
    - IMAP works perfectly with (and only with) authentication and SSL (with my commercial Certificate).
    - Accessing Webmail works perfectly with my commercial Certifiace.

    Thanks for your input.

    m.a.g.

  3. #3
    Join Date
    Dec 2006
    Posts
    18
    Rep Power
    9

    Default Outlook and Zimbra on the Wiki

    Perhaps the section on Outlook and Zimbra on the wiki might help
    http://wiki.zimbra.com/index.php?tit..._Configuration

    I uncommented those two lines from my master.cf and changed to port 465 and it worked for me. I have noticed that this gets overwritten after every upgrade (as happened in your case). Make sure you don't lose the whitespace in there.

    There is another modification suggested in this thread that you might not have tried
    http://www.zimbra.com/forums/showthr...?t=3541&page=2

    I have never personally tried this one.
    Last edited by klopfer; 03-04-2007 at 07:21 AM.

  4. #4
    Join Date
    Jul 2006
    Location
    Zurich, Switzerland
    Posts
    29
    Rep Power
    9

    Default

    Thanks for your hints!

    Quote Originally Posted by klopfer View Post
    Perhaps the section on Outlook and Zimbra on the wiki might help
    http://wiki.zimbra.com/index.php?tit..._Configuration
    These two lines got commented-out during update, but I've already uncommented those - with no effect for my problem.

    Quote Originally Posted by klopfer View Post
    There is another modification suggested in this thread that you might not have tried
    http://www.zimbra.com/forums/showthr...?t=3541&page=2
    I've already checked that - seems to look ok for me:
    Code:
    zimbra@mail:~/conf$ zmprov gs FQDN | grep Auth
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: FQDN
    zimbraMtaAuthURL: https://FQDN/service/soap/
    zimbraMtaTlsAuthOnly: TRUE
    zimbra@mail:~/conf$ zmprov gs FQDN | grep Mode
    zimbraMailMode: https
    The problem also occurs when using Thunderbird instead of Outlook 2003.

    What else could it be?

    Thanks,
    m.a.g.

  5. #5
    Join Date
    Dec 2006
    Posts
    18
    Rep Power
    9

    Default One other suggestion

    Also, when I changed modes from http to https I had to follow these instructions to get it to work properly.

    See the last post on this page and first on the next page
    http://www.zimbra.com/forums/showthr...?t=1316&page=2

  6. #6
    Join Date
    Jul 2006
    Location
    Zurich, Switzerland
    Posts
    29
    Rep Power
    9

    Default

    In that config-file I have the variable %%zimbraMtaAuthURL%% in it, so nothing to change there. And that variable seems to be set correctly - see previous post.

    What I just noticed: by trying to send an email, I get the error right away; I'm not getting promted for username and password.

    What else to check?

  7. #7
    Join Date
    Jul 2006
    Location
    Zurich, Switzerland
    Posts
    29
    Rep Power
    9

    Default

    The last day, I did doublecheck my configuration and was googling for an answer to my SMTPS problem. Unfortunatly, I did not find any solution. That means, the problem still persists...
    Does someone have the same problem?

    Whereelse could I seek to find the problem? Right now, this issue is a show-stopper for zimbra!

    Thank you very much for your assistance.
    m.a.g.

Similar Threads

  1. Sync problem with Outlook Connector
    By prox in forum Zimbra Connector for Outlook
    Replies: 1
    Last Post: 07-12-2007, 09:04 AM
  2. Outlook 2003 on Terminal Services not joyful...
    By techrat in forum Zimbra Connector for Outlook
    Replies: 1
    Last Post: 06-18-2007, 03:30 PM
  3. Outlook Folders transfer problem
    By paul123 in forum Zimbra Connector for Outlook
    Replies: 2
    Last Post: 05-14-2007, 07:14 PM
  4. Outlook 2003 crashes after connector is installed
    By chrisgru in forum Zimbra Connector for Outlook
    Replies: 21
    Last Post: 05-02-2006, 10:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •