Results 1 to 4 of 4

Thread: install without dns mx config?

  1. #1
    Join Date
    Oct 2010
    Posts
    27
    Rep Power
    5

    Default install without dns mx config?

    i am asking this b/c i didnt have this hurdle in the past. i dont know if its my error or something is diff w/ newest zimbra os ver.

    i have a running zimbra os ed 8.0.7 on ubuntu 10.04. my own hardware. public static IP from ISP. dns & mx all configured at registrar for domain.com & mail.domain.com. all working.

    i want to migrate to zimbra os ed 8.0.7 on ubuntu 12.04 on a hosted vm, with a new public static IP from the cloud provider. probably use zextras migration tool to do it. afterward (or right before) issue dns/mx update w/ registrar so the 48-72 hr dns propagation begins. obviously i'm trying to time it to minimize mail server downtime during the migration.

    i've done this in the past but i owned both the old & new server boxes then (not sure if that matters). today when i try to install zimbra on the cloud vm server, i get all the dns failure errors (ldap wont start etc). i have domain.com & mail.domain.com w/ the public IP in /etc/hosts, but the new zimbra install looks to dns & finds my current mail.domain.com server.

    is there no way for me to install the zimbra server on the vm 1st, then issue the dns updates? i know the actual mail wont go to the new server for 48-72 hrs. but i cant even get the new server to just install zimbra. i dont recall it checking for dns/mx validity in past versions. or maybe i just forgot.

    i dont need split dns & all that. its a public IP, not pvt. i just want min down time for the migration. i think i achieve that by installing the new server 1st w/o errors or issues, then submit dns updates, then shutdown old server & migrate data over w/ zextras tool.

    am i wrong? is there a better way?

  2. #2
    Join Date
    May 2008
    Location
    Kirkland, WA
    Posts
    4
    Rep Power
    7

    Default

    I think your problem is more basic. LDAP doesn't care about DNS. It does care about being able to resolve to itself. Whenever I've installed ZCS in a public cloud, the private IP address of my server and the public IP address assigned to that server are different. If you execute an ifconfig command to find the ip address of your internal NIC and put that address in /etc/hosts in the form 10.0.0.1 mail.domain.com I bet LDAP will fire up.

  3. #3
    Join Date
    Apr 2012
    Posts
    101
    Rep Power
    3

    Default

    I do this when I want to replicate my production system across to a test VM. I use dnsmasq on the server and tell the OS to use localhost as the resolver. That way it does not matter what the IP address is, nor the real hostname. The server always resolves itself to 127.0.0.1.

    I found using /etc/hosts was not enough. Some services resolve using the nameserver and bypass /etc/hosts. dnsmasq is an answer in this case.

  4. #4
    Join Date
    Oct 2010
    Posts
    27
    Rep Power
    5

    Default

    actually you guys are all correct. using aj cody's excellent wiki/guide, dnsmasq easily solves the problem.

    but turns out i solved it prior by just re-ordering the aliases in my /etc/hosts as follows:

    127.0.0.1 localhost.localdomain localhost
    74.x.x.x mail.domain.com mail alias.domain.com alias
    74.x.x.x some.cloudhost.bs.com couldhostalias

    before the cloud host's line preceded mine. it work immediately after the fix.

    i already propagated the DNS so its all moot now. but thanx for the informative replies; others will surely benefit.

Similar Threads

  1. Zimbra 8 FOSS - Multiserver Install DNS config help
    By sviriyala in forum Administrators
    Replies: 4
    Last Post: 11-15-2012, 10:29 AM
  2. Zimbra 8 FOSS - Multiserver Install DNS config help
    By sviriyala in forum Installation
    Replies: 3
    Last Post: 11-14-2012, 01:36 PM
  3. Replies: 17
    Last Post: 07-19-2010, 11:10 AM
  4. Replies: 13
    Last Post: 09-25-2009, 10:02 AM
  5. [SOLVED] zcs 5.0.2 install config issue
    By mhhadmin in forum Installation
    Replies: 8
    Last Post: 02-15-2008, 04:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •