Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: 3.0 to 4.5.3 Upgrade failed (mysql error)

  1. #1
    Join Date
    Sep 2005
    Posts
    36
    Rep Power
    10

    Default 3.0 to 4.5.3 Upgrade failed (mysql error)

    Hi! I encountered this error while upgrading 3.0 to 4.5.3:

    Code:
    ERROR 1005 (HY000) at line 2: Can't create table './mboxgroup67/#sql-515e_1f1.frm' (errno: 150)
    Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=SAoo20h4bjrUQusGVKJZ5cQJ8C --database=zimbra --batch --skip-column-names'. at /opt/zimbra/libexec/scripts/Migrate.pm line 220,  line 94.
    Tue Mar  6 11:40:50 2007: Script failed with code 1 - exiting
    UPGRADE FAILED - exiting
    What should I do?

    One more thing, at the start up of the upgrade where it shows my current configuration values, it seems that it cant get the value of my LDAPHOST and LDAPPORT configuration as shown below:
    Code:
    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
       HOSTNAME=stiimail.stii.dost.gov.ph
       LDAPHOST=
       LDAPPORT=
       SNMPTRAPHOST=stiimail.stii.dost.gov.ph
       SMTPSOURCE=admin@stii.dost.gov.ph
       SMTPDEST=admin@stii.dost.gov.ph
       SNMPNOTIFY=yes
       SMTPNOTIFY=yes
       LDAPROOTPW=GBHZs9we
       LDAPZIMBRAPW=GBHZs9we
    Is this ok?

    Thanks!

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Looks like the migration script failed.
    I assume you have a backup. . .right????

  3. #3
    Join Date
    Sep 2005
    Posts
    36
    Rep Power
    10

    Default

    Quote Originally Posted by jholder View Post
    Looks like the migration script failed.
    I assume you have a backup. . .right????
    Yep, I'm restoring it now. So what should I do about it? (upgrade problem). Thanks!

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Well,
    I'd make sure you have enough space, clear out your /tmp folder, and try agian.

  5. #5
    Join Date
    Sep 2005
    Posts
    36
    Rep Power
    10

    Default

    Quote Originally Posted by jholder View Post
    Well,
    I'd make sure you have enough space, clear out your /tmp folder, and try agian.
    Hi! Yep, I believe my /tmp folder has enough space:
    Code:
    df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sda2             5.7G  2.3G  3.2G  42% /
    /dev/sda1              99M   13M   81M  14% /boot
    /dev/shm              760M     0  760M   0% /dev/shm
    /dev/md0               59G   32G   24G  58% /opt
    what am i missing?

  6. #6
    Join Date
    Sep 2005
    Posts
    36
    Rep Power
    10

    Default Possible workaround: Export and Import Accounts and Mails

    I've been trying to upgrade my 3.0 installation to the 4.5 (4.5.1 and 4.5.3) for several times for the past month and never succeeded. Im thinking of a possible workaround that will involve the following steps:

    1.) Have a fresh install of the latest release (4.5.3) on a different machine, or on a virtual machine

    2.) Find a way to import user accounts (and preferences?) from the old server to the new one. Perhaps if I can make their LDAP talk to each other.

    3.) Migrate emails via imapsync.

    ** SINCE THE PRODUCTION SERVER MUST RESIDE ON THE MACHINE OF MY ZIMBRA 3.0**

    4.) Backup /opt/zimbra directory from the new server

    5.) Install 4.5.3 on the old server, overwriting all the data.

    6.) Copy the /opt/zimbra from the new server to the old server (now with a fresh install 4.5.3)

    7.) Re-run install.sh (or i can skip this one?)

    Are all these possible? Thanks!

  7. #7
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Hi Delt,
    I think it's important for you to understand that you are attempting to treat the symptoms, and not address the problem.

    I think your proposal may work, but the problem you should be concerned about is why the heck is your script failing.

    Can you post your /opt/zimbra/.install_history ?

    Thanks
    john

  8. #8
    Join Date
    Sep 2005
    Posts
    36
    Rep Power
    10

    Default

    Quote Originally Posted by jholder View Post
    Hi Delt,
    I think it's important for you to understand that you are attempting to treat the symptoms, and not address the problem.

    I think your proposal may work, but the problem you should be concerned about is why the heck is your script failing.

    Can you post your /opt/zimbra/.install_history ?

    Thanks
    john
    Hi John!
    I'm just considering my other options. It's getting to be quite frustrating not being able to successfully upgrade our server after n attempts. Anyway, I just restored my 3.0 backup, I think it has overwritten the .install_history of my failed upgrade. Are there any other files that we can look at? Anyway here's my current .install history :

    Code:
    1143111968: INSTALL SESSION START
    1143111981: INSTALLED zimbra-core-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1143111983: INSTALLED zimbra-ldap-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1143111987: INSTALLED zimbra-logger-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1143111991: INSTALLED zimbra-mta-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1143111994: INSTALLED zimbra-snmp-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1143112001: INSTALLED zimbra-store-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1143112004: INSTALLED zimbra-apache-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1143112006: INSTALLED zimbra-spell-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1143112006: INSTALL SESSION COMPLETE
    1143112070: CONFIG SESSION START
    1143112070: CONFIGURED BEGIN
    1143112084: CONFIGURED configLCValues
    1143112086: CONFIGURED configCASetup
    1143112090: CONFIGURED configCreateCert
    1143112100: CONFIGURED configSetupLdap
    1143112106: CONFIGURED configSaveCA
    1143112111: CONFIGURED configInstallCert
    1143112115: CONFIGURED configCreateServerEntry
    1143112118: CONFIGURED configSpellServer
    1143112121: CONFIGURED configSetServicePorts
    1143112152: CONFIGURED configInstallZimlets
    1143112155: CONFIGURED configSetMtaAuthHost
    1143112186: CONFIGURED configCreateDomain
    1143112199: CONFIGURED configInitSql
    1143112232: CONFIGURED configInitLogger
    1143112233: CONFIGURED configInitMta
    1143112244: CONFIGURED configInitSnmp
    1143112250: CONFIGURED configSetEnabledServices
    1143112250: CONFIGURED setupCrontab
    1143112363: CONFIGURED END
    1143112363: CONFIG SESSION COMPLETE
    1173203598: INSTALL SESSION START
    1173203614: UPGRADED zimbra-core-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1173203616: UPGRADED zimbra-ldap-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1173203622: UPGRADED zimbra-logger-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1173203630: UPGRADED zimbra-mta-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1173203633: UPGRADED zimbra-snmp-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1173203640: UPGRADED zimbra-store-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1173203645: UPGRADED zimbra-apache-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1173203647: UPGRADED zimbra-spell-3.0.1_GA_160.FC4-20060216172118.i386.rpm
    1173203647: INSTALL SESSION COMPLETE
    1173204007: CONFIG SESSION START
    1173204007: CONFIGURED BEGIN
    1173204022: CONFIGURED configLCValues
    1173204022: CONFIGURED configCASetup
    1173204022: CONFIGURED configCreateCert
    1173204027: CONFIGURED configSetupLdap
    1173204034: CONFIGURED configSaveCA
    1173204038: CONFIGURED configInstallCert
    1173204041: CONFIGURED configCreateServerEntry
    1173204045: CONFIGURED configSpellServer
    1173204048: CONFIGURED configSetServicePorts
    1173204078: CONFIGURED configInstallZimlets
    1173204081: CONFIGURED configSetMtaAuthHost
    1173204081: CONFIGURED configCreateDomain
    1173204081: CONFIGURED configInitSql
    1173204085: CONFIGURED configInitLogger
    1173204086: CONFIGURED configInitMta
    1173204097: CONFIGURED configInitSnmp
    1173204104: CONFIGURED configSetEnabledServices
    1173204104: CONFIGURED setupCrontab
    1173204213: CONFIGURED END
    1173204213: CONFIG SESSION COMPLETE

  9. #9
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    We think that perhaps you may not have enough buffer space.
    This causes an error in creation of foreign constants.

    Take a look at /opt/zimbra/conf/my.cnf and set the innodb_buffer_pool_size = 1992294400

  10. #10
    Join Date
    Sep 2005
    Posts
    36
    Rep Power
    10

    Default

    Quote Originally Posted by jholder View Post
    We think that perhaps you may not have enough buffer space.
    This causes an error in creation of foreign constants.

    Take a look at /opt/zimbra/conf/my.cnf and set the innodb_buffer_pool_size = 1992294400
    Ok. I'll try. Thanks. I'll post whatever the results here

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Replies: 18
    Last Post: 03-20-2006, 01:22 PM
  3. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM
  4. Building native libraries on MacOS X
    By ajmas in forum Developers
    Replies: 3
    Last Post: 10-14-2005, 11:00 PM
  5. Insallation failed (Debian server)
    By popui007 in forum Installation
    Replies: 5
    Last Post: 09-29-2005, 02:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •