Results 1 to 2 of 2

Thread: Error on attempt to read email

  1. #1
    Join Date
    Mar 2007
    Posts
    1
    Rep Power
    8

    Default Error on attempt to read email

    Current status: I can download my pop3 email from an exchange server and see the listing of messages but I get an error when I attempt to open an individual message (error message below).

    System Configuration:

    Base Install from provided VMware image. Used the Rpath update tool to update system. (I did have an error at the end saying invalid permissions on log file, chmoded 666 and was okay).

    I created a user account and logged in, setup pop3 mail retrieval and received all my headers. (woohoo! I thought, as on my previous install I had UID case problems that I tried to manually setup). This is where the problem kicks in, I get an error when I try to open an email :


    Code:
    msg - system failure: java.lang.NoSuchMethodError: com.zimbra.cs.mailbox.MessageCache.getMimeMessage(Lcom/zimbra/cs/mailbox/Message;Z)Ljavax/mail/internet/MimeMessage;
    com.zimbra.common.service.ServiceException: system failure: java.lang.NoSuchMethodError: com.zimbra.cs.mailbox.MessageCache.getMimeMessage(Lcom/zimbra/cs/mailbox/Message;Z)Ljavax/mail/internet/MimeMessage;
    	at com.zimbra.common.service.ServiceException.FAILURE(ServiceException.java:175)
    	at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:281)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:168)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:90)
    	at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:223)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
    	at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:162)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
    	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
    	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
    	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
    	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
    	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
    	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:541)
    	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
    	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
    	at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:667)
    	at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
    	at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
    	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
    	at java.lang.Thread.run(Thread.java:595)
    Caused by: java.lang.NoSuchMethodError: com.zimbra.cs.mailbox.MessageCache.getMimeMessage(Lcom/zimbra/cs/mailbox/Message;Z)Ljavax/mail/internet/MimeMessage;
    	at com.zimbra.cs.mailbox.Message.getMimeMessage(Message.java:306)
    	at com.zimbra.cs.mailbox.Message.getMimeMessage(Message.java:287)
    	at com.zimbra.cs.service.mail.ToXML.encodeMessageAsMP(ToXML.java:603)
    	at com.zimbra.cs.service.mail.Search.addMessageHit(Search.java:419)
    	at com.zimbra.cs.service.mail.SearchConv.putHits(SearchConv.java:192)
    	at com.zimbra.cs.service.mail.SearchConv.handle(SearchConv.java:119)
    	at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:270)
    	... 21 more
    
    code - service.FAILURE
    method - ZmCsfeCommand.prototype.invoke
    detail - soap:Receiver

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    sounds like your install is missing some jar files. Could be from the upgrade, or something else - I assume you've tried restarting/rebooting?
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  2. Relay Issues with windows mobile 5 device
    By astarr in forum Zimbra Mobile
    Replies: 15
    Last Post: 04-19-2007, 05:17 PM
  3. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 03:56 AM
  4. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •