Results 1 to 10 of 10

Thread: German umlauts

  1. #1
    Join Date
    Mar 2007
    Posts
    22
    Rep Power
    8

    Default German umlauts

    Today I noticied a new problem in my zimbra installation, german umlauts. Some mails, I think which are ISO-8859-1 encoded, are not displayed correctly. For example "Gre" is displayed as GrüŸe.

    Currently I use de_at.UTF-8 as default locale in debian, maybe that's my fault?


    How can I solve that problem?

  2. #2
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default More info, please...

    Wjat version of the software do you have installed, and can you attach a sample message (right click, "Show Original") that exhibits this behavior?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Mar 2007
    Posts
    22
    Rep Power
    8

    Default

    I attached a original copy of such a message...
    Attached Files Attached Files

  4. #4
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default Problem is in the original mail

    The message contains some umlauts encoded correctly ("Vielen Dank fr die Wiedervorlage") and some encoded incorrectly ("Sehr geehrter Herr Müller"). It appears that the MUA used by the sender of this email is corrupting the umlauts in the quoted text. Zimbra can only display what's in the message, and the quoted part of the message is incorrect.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    Join Date
    Mar 2007
    Posts
    22
    Rep Power
    8

    Default

    But my problem is that both are displayed incorrectly, I think this must be a problem with the debian locales settings...

  6. #6
    Join Date
    Mar 2007
    Posts
    7
    Rep Power
    8

    Default

    what's the version of zimbra you have installed? in 4.5.2 i think there was a problem regarding german special chars.

  7. #7
    Join Date
    Mar 2007
    Posts
    22
    Rep Power
    8

    Default

    Currently I installed following version of zimbra:

    Code:
    zimbra@zimbra:~$ dpkg --list |grep zimbra
    ii  zimbra-apache  4.5.2_GA_699.D Best email money can buy
    ii  zimbra-core    4.5.2_GA_699.D Best email money can buy
    ii  zimbra-ldap    4.5.2_GA_699.D Best email money can buy
    ii  zimbra-logger  4.5.2_GA_699.D Best email money can buy
    ii  zimbra-mta     4.5.2_GA_699.D Best email money can buy
    ii  zimbra-snmp    4.5.2_GA_699.D Best email money can buy
    ii  zimbra-spell   4.5.2_GA_699.D Best email money can buy
    ii  zimbra-store   4.5.2_GA_699.D Best email money can buy
    How can I upgrade these files? Is a new installation required?

  8. #8
    Join Date
    Mar 2007
    Posts
    7
    Rep Power
    8

    Default

    load new version of zimbra and run installation. it should ask you if you want to update your version of zimbra.
    But i think it would be better to backup your installation.

    After upgrading new messages are displayed correctly. The old ones will still be "corrupted". Only way to fix this would be to import a non corrupted backup of your mails i think.

    greetings from germany

    ps: there where threads about this few weeks ago, you should find them whe you search for umlaut in the forums.

  9. #9
    Join Date
    Mar 2007
    Posts
    22
    Rep Power
    8

    Default

    Thanks for your help! the update to 4.5.3 solved the problem and now even my mta works perfectly But after the upgrade the zimlets disappeared, is it necessary to deploy them again?

    greeting from austria!

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Yes, you'll need to deploy the zimlets after upgrading.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 30
    Last Post: 11-10-2007, 08:20 AM
  2. german umlaut
    By CatiaL in forum Administrators
    Replies: 2
    Last Post: 06-12-2007, 07:10 AM
  3. Replies: 6
    Last Post: 04-18-2007, 07:03 AM
  4. Wrong folder names with german Outlook
    By SpeedPartner in forum Zimbra Connector for Outlook
    Replies: 11
    Last Post: 09-08-2006, 02:58 PM
  5. Complete German Translation 3.0.1_GA_160
    By blue4koala in forum I18N/L10N - Translations
    Replies: 8
    Last Post: 05-13-2006, 10:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •