Results 1 to 10 of 11

Thread: Cannot start Zimbra M2

Hybrid View

  1. #1
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default Cannot start Zimbra M2

    This is the error I get when I try and start Zimbra after installing the lates Open Source release:

    [root@webmail bin]# service zimbra start
    Host webmail.avmax.ca
    Starting ldap...Done.
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException webmail.avmax.ca:389)


    This is the error I get when I try and start ldap manually as the zimbra user:

    [zimbra@webmail bin]$ ldap start
    db_recover: Finding last valid log LSN: file: 1 offset 28
    /opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: libbind.so.3: cannot open shared object file: No such file or directory

    Any ideas?

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Your system is out of date. So run yum update (or yum install bind-libs) to bring that up to date.
    Last edited by KevinH; 11-17-2005 at 03:07 PM.

  3. #3
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default

    [zimbra@webmail bin]$ ./zmcontrol start
    Host webmail.avmax.ca
    Starting ldap...Done.
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException webmail.avmax.ca:389)

    OK. I have done that. But I am still getting the message above. I have modifed my /etc/hosts and done the following:

    delete /opt/zimbra/openldap-data/* (leave the directory)
    Make sure all zimbra processes are stopped
    su - root
    touch /opt/zimbra/.newinstall (Note the '.' in the filename)
    /opt/zimbra/libexec/zmsetup.pl

    Still no luck.

    I am running Fedora Core 3.

    Any more ideas?

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Try to start slapd in debug mode. Look at this post for more info:

    http://www.zimbra.com/forums/showpos...95&postcount=9

  5. #5
    Join Date
    Nov 2005
    Posts
    1
    Rep Power
    10

    Default also getting this LDAP error on FC3

    Hello. I tried to follow all of the above steps and the ones in the other post but to no avail (I am still getting the exact same error when I do a 'zmcontrol start'). When i directly run '/opt/zimbra/bin/ldap start' after doing the recovery it gives me:

    db_recover: Finding last valid log LSN: file: 1 offset 43437
    db_recover: Recovery starting from [1][43296]
    db_recover: Recovery complete at Fri Nov 18 11:57:47 2005
    db_recover: Maximum transaction ID 80000002 Recovery checkpoint [1][43437]
    Started slapd: pid 13220

    and it starts ldap, but when i do a '/opt/zimbra/bin/zmcontrol start' it gives me the same error as mentioned earlier.

    Any ideas? We are a mid-sized public school district and are really looking forward to being able to test the new functionality and decide if Zimbra is the right solution for us. It's even wierder because the M1 release worked without any problems. Thanks for any help you can provide.

  6. #6
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Did you remove iptables? zmiptables -u If you had M1 on the machine then the iptables rules may still be there which we don't use any more.

  7. #7
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default missing key

    zmlocalconfig -e ldap_is_master=true will force ldap to start, though the upgrade script should have done that.

  8. #8
    Join Date
    Oct 2005
    Posts
    33
    Rep Power
    10

    Default It took a little more to fix the problem

    After it appeared to start, I checked the status and found that antivirus and mta had not actually started. Eventually I found a conflict between the latest libdb-4.3.so and the db.h in sleepycat that was looking for something around version 4.2.52.

    I installed compat-db-4.2.52-2.i386.rpm and everything started running.

    (thanks to previous post) I also had to force ldap to start on startup with:

    zmlocalconfig -e ldap_is_master=true

    I'm still checking to see if it is all working.

  9. #9
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default ldap_is_master

    To clarify - the upgrade script (not install.sh, but the upgradeM1M2.pl script) should be setting ldap_is_master in the local config.

    Is anyone seeing this NOT happen? If so, can you send us details? I'm going to be working the upgrade stuff into the installer, and would rather not include any more bugs than I absolutely have to

    Also - we modified the way we're dealing with ldap in the local config in M2.

    Previously, we had an ldap host and ldap port - if zimbra_server_hostname eq ldap_host, we'd start ldap.

    Now, we're setting an ldap_url (ldap://hostnameort) and ldap_master_url to tell the services where to find ldap, and an ldap_is_master boolean to indicate whether or not to start ldap.

    Here's why - on startup of the ldap master, there's no way to determine, from ldap, what services to start - so we special case the ldap start. (On ldap replicas, we ask the master what to start). With the switch to ldap_url (which can be a list of replicas), there's no real way to determine, based on zimbra_server_hostname, if ldap is supposed to run on a particular box.

Similar Threads

  1. Replies: 9
    Last Post: 03-01-2008, 08:21 PM
  2. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM
  3. Logger
    By jholder in forum Installation
    Replies: 24
    Last Post: 03-31-2006, 11:50 AM
  4. Seeming variety of problems on suse-9.1
    By Crexis in forum Installation
    Replies: 52
    Last Post: 03-04-2006, 12:19 AM
  5. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 08:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •