Results 1 to 3 of 3

Thread: failed upgrade, failed restore, big trouble

Hybrid View

  1. #1
    Join Date
    Mar 2007
    SF, pacific northwest
    Rep Power

    Default failed upgrade, failed restore, big trouble

    I tried to upgrade 3.1.4 to 4.5.3. The upgrade failed (choked on schema updates)

    Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=SAoo20h4bjrUQusGVKJZ5cQJ8C --database=zimbra --batch --skip-column-names'. at /opt/zimbra/libexec/scripts/ line 220, line 94.
    Tue Mar 6 11:40:50 2007: Script failed with code 1 - exiting
    UPGRADE FAILED - exiting

    So I tried to upgrade 3.1.4 over the half-installed 4.5.3, that failed, so I have to clean install 3.1.4. Done, moved on.

    Now my problems are much worse. Before doing all this I took a backup, of course. But now I can't restore from the backup. When I run 'zmrestoreldap -lb xxxxxxx' I get:

    bdb_db_open: database already in use
    backend_startup_one: bi_db_open failed! (-1)
    slap_startup failed

    When I run 'zmrestoreoffline -a all' I get:
    Error occurred: no such domain:

    If I reinstall and configure with the domain, then I get the same error, but I'm missing

    Everything worked fine in my staging runs

  2. #2
    Join Date
    Mar 2007
    SF, pacific northwest
    Rep Power


    I figured out that after install, even if I specify 'don't start servers', the LDAP server is running. Once I stop that I can run the restoreldap successfully.

    Once I have the LDAP restored, the no such domain messages go away, too.

    The restoreoffline still fails, I'll characterize it more later.

  3. #3
    Join Date
    Oct 2005
    Thatcher, AZ
    Rep Power


    It looks like your are a network edition customer.
    If you are, then I would advise you to contact support.

    The initial error you had is covered in the forums, but it looks like you've got more going on.

    Either call, or e-mail. Either way, you need to get support involved.

    Good luck,

Similar Threads

  1. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 09:23 PM
  2. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  3. Lotus migration
    By babou in forum Migration
    Replies: 15
    Last Post: 03-05-2007, 09:33 PM
  4. Zimbra Upgrade FAILED Badly
    By in forum Installation
    Replies: 1
    Last Post: 09-04-2006, 04:10 PM
  5. Replies: 18
    Last Post: 03-20-2006, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts