Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Port conflits(25)

  1. #1
    Join Date
    Mar 2007
    Posts
    55
    Rep Power
    8

    Default Port conflits(25)

    Durant the installation of zimbra i receive the message :
    -----------------------------------------------------------
    Checking for port conflicts
    Port conflict detected: 25 (zimbra-mta)
    Port conflicts detected! - Any key to continue
    ------------------------------------------------------------
    By scannig the liste of my open ports i find 25 ( servic SMTP)
    sould i escape this conflit and continue installation ?
    Or i must disable SMTP service ? ( if yes who ?)

  2. #2
    Join Date
    Mar 2007
    Posts
    8
    Rep Power
    8

    Default

    This is indicating that you have another mail server running.
    - Disable it if you use it for local delivery only
    - Don't install zimbra mta but be sure of what you're doing and check if zimbra can "speak" with your mta.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Zimbra will only use the postfix MTA that comes with it. As [B2F]Tom mentioned you need to disable the installed MTA (you'll need to check your install for that), you can continue the installation but Zimbra MTA won't start until the other MTA is stopped.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    Mar 2007
    Posts
    55
    Rep Power
    8

    Default

    ok , thank you
    but hwo can i proceed to stop the other MTA ?
    i don't remember that i install it before ??
    any help

  5. #5
    Join Date
    Mar 2007
    Posts
    8
    Rep Power
    8

    Default

    maybe a ps -eaf may gives some indication to you.

    qmail, exim, postfix are some of the most famous mta ... take a look if you find one of them in your process table list.

    Regarding your distribution, take a look to in your init.d directory or in your service list ...

    At last, maybe your mta is not in standalone mode but manage by inetd.

  6. #6
    Join Date
    Mar 2007
    Posts
    55
    Rep Power
    8

    Default

    thank you for your help
    for distrubution I am using ubuntu 6
    and when i scan my open ports at localhost i find
    that realy port 25 is open with service : SMTP
    do you know how can i stop this service ?

  7. #7
    Join Date
    Mar 2007
    Posts
    8
    Rep Power
    8

    Default

    25 is the port of SMTP. But you have to find the software that listen on this port.
    Debian is installed with Exim and ubuntu is based on Debian. Maybe it is the same for you. Check your process list to look after an exim process : ps -eaf | grep exim
    If you find one, then do an /etc/init.d/exim stop. You can remove it too : apt-get remove exim.
    Find your mail transfert agent software and refer to any ubuntu administration guide to know how to remove it.

  8. #8
    Join Date
    Mar 2007
    Posts
    55
    Rep Power
    8

    Default

    I find that exim4 is as you say my mail transfert agent
    i uninstall it but zimbra-mta is not running
    what other application can't use 25 port ???

  9. #9
    Join Date
    Mar 2007
    Posts
    55
    Rep Power
    8

    Default

    this is my mta status script :
    -----------------------------------------------------------------------
    zimbra@zimbra:~$ sh -x bin/zmmtactl status
    + BASE=/opt/zimbra
    + SCRIPTS='zmmtaconfigctl postfix zmsaslauthdctl'
    + case "$1" in
    + STATUS=0
    + for i in '$SCRIPTS'
    + /opt/zimbra/bin/zmmtaconfigctl status
    + R=0
    + '[' 0 -ne 0 ']'
    + for i in '$SCRIPTS'
    + /opt/zimbra/bin/postfix status
    + R=1
    + '[' 1 -ne 0 ']'
    + echo 'postfix is not running'
    postfix is not running
    + STATUS=1
    + for i in '$SCRIPTS'
    + /opt/zimbra/bin/zmsaslauthdctl status
    + R=0
    + '[' 0 -ne 0 ']'
    + exit 1
    -----------------------------------------------------------------
    i think that there is a problem in /opt/zimbra/bin/postfix R=1
    do you have an idea ? what can i do ?

    any help

  10. #10
    Join Date
    Nov 2005
    Location
    London, ON
    Posts
    255
    Rep Power
    10

    Default

    You'll need to turn it off, and then disable it from startup.

    Something like
    /etc/init.d/exim stop
    or
    /etc/init.d/exim4 stop

    Then to disable it at startup use chkconfig

Similar Threads

  1. initializing ldap...FAILED(256)ERROR
    By manjunath in forum Installation
    Replies: 39
    Last Post: 06-07-2013, 11:27 AM
  2. [Network Edition Trial] OS X Installation
    By dmg in forum Installation
    Replies: 4
    Last Post: 02-07-2007, 05:25 PM
  3. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 10:19 AM
  4. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 11:34 PM
  5. Help Please... Zimbra error message too slow...
    By nazeeronline in forum Installation
    Replies: 20
    Last Post: 09-06-2006, 06:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •