Results 1 to 2 of 2

Thread: NPTL Wierdness, degraded?

  1. #1
    Join Date
    Mar 2007
    Regina, Sask.
    Rep Power

    Default NPTL Wierdness, degraded?

    Ok I'm confused and hoping someone here can help or at least explain what would have happened.

    I had a stock CentOS 4 machine with Zimbra installed. I figured I would document my own install as I'm going to install CentOS5 on this machine when it's released. I ran the installer to remove Zimbra (which worked fine) and then proceeded to re-install it.

    I got the error mentioning that NPTL was not found I double checked on other CentOS 4 machines and got this:

    NPTL 2.3.4

    But on my machine I'm now showing:
    # /usr/bin/getconf GNU_LIBPTHREAD_VERSION

    Does anyone have any ideas how this would revert BACK? Here are some specifics:

    # uname -rvmpio
    2.6.9-42.0.10.EL #1 Tue Feb 27 09:24:42 EST 2007 i686 athlon i386 GNU/Linux

    # cat /proc/cpuinfo | grep -i model
    model : 10
    model name : AMD Athlon(tm) XP 2800+

    I'm just not seeing how this reverts. Everything I've read says it's the default threading now (since RHEL3 even) and every one of my machiens is showing it installed to some capacity. Thing is it had to be available for me to even install Zimbra the first time so I'm trying to track what happened that was different on the box.

    This is a very vanilla install with only really two applications on it (or at least it DID have two working lol):

    1. Zimbra
    2. Bacula

    Anyone out there have some suggestions, ideas, or anything else I could check? Sorry if this is off topic but I've been hunting for a while now and noticed that if it's a pre-req, maybe somenoe here could help.


  2. #2
    Join Date
    Mar 2007
    Regina, Sask.
    Rep Power

    Default got it ...

    Another application had mentioned that the tls lib directory should be moved as there was an issue. In another part of the doc it mentions the issue was with tls on older 2.4 kernels. Unfortunatley, libraries were updated while the tls lib dir was moved and things broke horribly.

    Hopefully this doesn't happen to anyone else

Similar Threads

  1. NPTL missing in Debian Sarge
    By martin78 in forum Installation
    Replies: 6
    Last Post: 02-19-2007, 10:19 PM
  2. Nptl...missing
    By nvalentine in forum Installation
    Replies: 0
    Last Post: 10-02-2006, 11:28 AM
  3. NPTL not found on SuSE 9.1
    By brentk in forum Installation
    Replies: 1
    Last Post: 03-16-2006, 10:22 PM
  4. Install Zimbra without NPTL?
    By Daniel-Daniel in forum Installation
    Replies: 7
    Last Post: 11-23-2005, 01:43 AM
  5. FC3 and Zen install failure with NPTL
    By Daniel-Daniel in forum Installation
    Replies: 4
    Last Post: 11-22-2005, 11:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts