Results 1 to 10 of 11

Thread: Zimbra not listening on port 7071

Hybrid View

  1. #1
    Join Date
    Apr 2007
    Posts
    7
    Rep Power
    8

    Default Some ZimbraAdmin trouble

    Hello all,

    I just downloaded the community edition so that I could give the whole sytem a whirl before I decide whether to go for the network edition. I setup a Xen environment for it running CentOS 4.4. I got zimbra installed and everything seems to be running, but when I go to https://mail.domain.com:7071/zimbraAdmin, nothing happens. It just isn't listening on that port. I don't really know how java / tomcat apps work in general, so I'm not sure where to look to try to dig up the problem.

    Tomcat is running. ps ax | grep tomcat:

    Code:
    13196 ?        Ss     0:00 /opt/zimbra/libexec/zmtomcatmgr start -Xms100m -Xmx100m -client -XX:NewRatio=2 -Djava.awt.headless=true
    15503 ?        Sl     0:12 /opt/zimbra/jdk1.5.0_08/bin/java -Xms100m -Xmx100m -client -XX:NewRatio=2 -Djava.awt.headless=true -Dcatalina.base=/opt/zimbra/apache-tomcat-5.5.15 -Dcatalina.home=/opt/zimbra/apache-tomcat-5.5.15 -Djava.io.tmpdir=/opt/zimbra/apache-tomcat-5.5.15/temp -Djava.library.path=/opt/zimbra/lib -Djava.endorsed.dirs=/opt/zimbra/apache-tomcat-5.5.15/common/endorsed -classpath /opt/zimbra/apache-tomcat-5.5.15/bin/bootstrap.jar:/opt/zimbra/apache-tomcat-5.5.15/bin/commons-logging-api.jar:/opt/zimbra/lib/jars/zimbra-launcher.jar com.zimbra.cs.launcher.TomcatLauncher
    I checked the tomcat logs and it seems to be listening. Here is the output:

    Code:
    Mar 31, 2007 8:43:09 PM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
    INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /opt/zimbra/lib
    Mar 31, 2007 8:43:09 PM org.apache.coyote.http11.Http11BaseProtocol init
    INFO: Initializing Coyote HTTP/1.1 on http-8080
    Mar 31, 2007 8:43:09 PM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 839 ms
    Mar 31, 2007 8:43:09 PM org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    Mar 31, 2007 8:43:09 PM org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/5.5.15
    Mar 31, 2007 8:43:09 PM org.apache.catalina.core.StandardHost start
    INFO: XML validation disabled
    Mar 31, 2007 8:43:10 PM org.apache.catalina.startup.HostConfig deployDescriptor
    WARNING: A docBase /opt/zimbra/apache-tomcat-5.5.15/webapps/zimbra inside the host appBase has been specified, and will be ignored
    log4j:WARN No appenders could be found for logger (org.apache.commons.digester.Digester).
    log4j:WARN Please initialize the log4j system properly.
    log4j:WARN No appenders could be found for logger (org.apache.catalina.session.ManagerBase).
    log4j:WARN Please initialize the log4j system properly.
    Zimbra server reserving server socket port=110 bindaddr=null ssl=false
    Zimbra server reserving server socket port=995 bindaddr=null ssl=true
    Zimbra server reserving server socket port=143 bindaddr=null ssl=false
    Zimbra server reserving server socket port=993 bindaddr=null ssl=true
    Zimbra server process is running as root, changing to user=zimbra uid=504 gid=504
    Zimbra server process, after change, is running with uid=504 euid=504 gid=504 egid=504
    Mar 31, 2007 8:43:18 PM org.apache.coyote.http11.Http11BaseProtocol start
    INFO: Starting Coyote HTTP/1.1 on http-8080
    Mar 31, 2007 8:43:18 PM org.apache.jk.common.ChannelSocket init
    INFO: JK: ajp13 listening on /0.0.0.0:8009
    Mar 31, 2007 8:43:18 PM org.apache.jk.server.JkMain start
    INFO: Jk running ID=0 time=0/29  config=null
    Mar 31, 2007 8:43:18 PM org.apache.catalina.storeconfig.StoreLoader load
    INFO: Find registry server-registry.xml at classpath resource
    Mar 31, 2007 8:43:18 PM org.apache.catalina.startup.Catalina start
    INFO: Server startup in 9265 ms
    Mar 31, 2007 8:50:18 PM org.apache.catalina.startup.HostConfig checkResources
    INFO: Reloading context [/service]
    Mar 31, 2007 8:50:22 PM org.apache.catalina.core.StandardContext processTlds
    SEVERE: Error reading tld listeners java.io.FileNotFoundException: /opt/zimbra/apache-tomcat-5.5.15/work/Catalina/localhost/service/tldCache.ser (Permission denied)
    java.io.FileNotFoundException: /opt/zimbra/apache-tomcat-5.5.15/work/Catalina/localhost/service/tldCache.ser (Permission denied)
            at java.io.FileInputStream.open(Native Method)
            at java.io.FileInputStream.(FileInputStream.java:106)
            at org.apache.catalina.startup.TldConfig.processCache(TldConfig.java:386)
            at org.apache.catalina.startup.TldConfig.execute(TldConfig.java:288)
            at org.apache.catalina.core.StandardContext.processTlds(StandardContext.java:4251)
            at org.apache.catalina.core.StandardContext.start(StandardContext.java:4107)
            at org.apache.catalina.startup.HostConfig.checkResources(HostConfig.java:1085)
            at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1178)
            at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:292)
            at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
            at org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBase.java:1304)
            at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1568)
            at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1577)
            at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1557)
            at java.lang.Thread.run(Thread.java:595)
    Zimbra server reserving server socket port=110 bindaddr=null ssl=false
    Fatal error: terminating: PrivilegedServlet init failed
    java.net.BindException: Permission denied
            at java.net.PlainSocketImpl.socketBind(Native Method)
            at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:359)
            at java.net.ServerSocket.bind(ServerSocket.java:319)
            at com.zimbra.cs.util.NetUtil.newBoundServerSocket(NetUtil.java:111)
            at com.zimbra.cs.util.NetUtil.bindServerSocket(NetUtil.java:134)
            at com.zimbra.cs.util.NetUtil.bindTcpServerSocket(NetUtil.java:63)
            at com.zimbra.cs.servlet.PrivilegedServlet.init(PrivilegedServlet.java:94)
            at javax.servlet.GenericServlet.init(GenericServlet.java:211)
            at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1105)
            at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:932)
            at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:3915)
            at org.apache.catalina.core.StandardContext.start(StandardContext.java:4176)
            at org.apache.catalina.startup.HostConfig.checkResources(HostConfig.java:1085)
            at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1178)
            at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:292)
            at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
            at org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBase.java:1304)
            at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1568)
            at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1577)
            at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1557)
            at java.lang.Thread.run(Thread.java:595)
    
    Mar 31, 2007 8:50:25 PM org.apache.coyote.http11.Http11BaseProtocol init
    INFO: Initializing Coyote HTTP/1.1 on http-80
    Mar 31, 2007 8:50:25 PM org.apache.coyote.http11.Http11BaseProtocol init
    INFO: Initializing Coyote HTTP/1.1 on http-7071
    Mar 31, 2007 8:50:25 PM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 1553 ms
    Mar 31, 2007 8:50:25 PM org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    Mar 31, 2007 8:50:25 PM org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/5.5.15
    Mar 31, 2007 8:50:25 PM org.apache.catalina.core.StandardHost start
    INFO: XML validation disabled
    log4j:WARN No appenders could be found for logger (org.apache.catalina.startup.TldConfig).
    log4j:WARN Please initialize the log4j system properly.
    Mar 31, 2007 8:50:32 PM org.apache.catalina.startup.HostConfig deployDescriptor
    WARNING: A docBase /opt/zimbra/apache-tomcat-5.5.15/webapps/zimbra inside the host appBase has been specified, and will be ignored
    log4j:WARN No appenders could be found for logger (org.apache.catalina.session.ManagerBase).
    log4j:WARN Please initialize the log4j system properly.
    log4j:WARN No appenders could be found for logger (org.apache.catalina.session.ManagerBase).
    log4j:WARN Please initialize the log4j system properly.
    Zimbra server reserving server socket port=110 bindaddr=null ssl=false
    Zimbra server reserving server socket port=995 bindaddr=null ssl=true
    Zimbra server reserving server socket port=143 bindaddr=null ssl=false
    Zimbra server reserving server socket port=993 bindaddr=null ssl=true
    Zimbra server process is running as root, changing to user=zimbra uid=504 gid=504
    Zimbra server process, after change, is running with uid=504 euid=504 gid=504 egid=504
    Mar 31, 2007 8:50:37 PM org.apache.coyote.http11.Http11BaseProtocol start
    INFO: Starting Coyote HTTP/1.1 on http-80
    Mar 31, 2007 8:50:38 PM org.apache.coyote.http11.Http11BaseProtocol start
    INFO: Starting Coyote HTTP/1.1 on http-7071
    Mar 31, 2007 8:50:38 PM org.apache.catalina.startup.Catalina start
    INFO: Server startup in 12183 ms
    I tried the following:

    Code:
    telnet localhost 7071
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    So, it seems to be working locally. I shouldn't have any firewall setup as this was a fresh install with nothing done to the system.

    I tried running curl --insecure https://localhost:7071 on the system too, but that just gave me empty output.

    Any help would be appreciated.

    Thanks,
    -carl
    Last edited by carllerche; 04-01-2007 at 09:38 PM.

  2. #2
    Join Date
    Oct 2005
    Location
    Harrisburg, Pennsylvania
    Posts
    155
    Rep Power
    10

    Default

    Quote Originally Posted by carllerche View Post
    So, it seems to be working locally. I shouldn't have any firewall setup as this was a fresh install with nothing done to the system.
    Howdy,

    You're right, it definitely appears as if it's actually running on port 7071, it largely appears to be a problem with accessing it... which does seem to point towards a firewall.

    A lot of distros do setup firewalls by default; what happens if you type the following:

    iptables -L -n

    If it shows some firewall rules in place, I believe you can safely disable that by typing:

    /etc/init.d/iptables stop

    Have a good one,
    -Eric

  3. #3
    Join Date
    Apr 2007
    Posts
    7
    Rep Power
    8

    Default

    Thanks for the reply. That was definitely it. I'm not used to CentOS (I've been exclusively using FreeBSD). I probably should have checked though :-/

    Anyway, I can view the admin login page now, but when I try to login it freezes on "loading...". I know the request is done and I get the following back:

    {"Body":{"AuthResponse":{"a":[{"_content":"false","n":"zimbraIsDomainAdminAccount"}],"lifetime":43200000

    ,"authToken":"0_67a8fa794b424d521952c42e1fb317909bc2debf_69643d3 3363a34396635396361632d393261312d343

    362372d383036312d3632373766353761303034363b6578703 d31333a313137353532373836373036383b61646d696e3d313 a313b"

    ,_jsns:"urn:zimbraAdmin"}},_jsns:"urn:zimbraSoap"}
    but I can't actually get anywhere. I'm using FF.

    If I try to login with a bad account, it tells me that the authentication failed.

    Any idea what this could be?

    PS, would it be possible to change the thread title to "some zimbraAdmin trouble" instead? Thanks.

    -carl

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Make sure you've also disabled SElinux and that your server has sufficient memory allocated - check the required specifications.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Apr 2007
    Posts
    7
    Rep Power
    8

    Default

    Quote Originally Posted by phoenix View Post
    Make sure you've also disabled SElinux and that your server has sufficient memory allocated - check the required specifications.
    Not sure what SElinux is, but I'll look into it. Also, is there a way to check in the logs if the memory is the problem?

  6. #6
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    /var/log/zimbra.log
    /opt/zimbra/log/mailbox.log
    /opt/zimbra/tomcat/logs/catalina.out

    If there's anything wrong, it'll be in atleast one of the logs above.

Similar Threads

  1. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  2. Replies: 8
    Last Post: 02-27-2007, 04:10 AM
  3. Replies: 16
    Last Post: 09-07-2006, 07:39 AM
  4. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •