Results 1 to 4 of 4

Thread: unclean shutdown ldap damage

  1. #1
    Join Date
    Apr 2007
    Posts
    4
    Rep Power
    8

    Default unclean shutdown ldap damage

    Zimbra server went down due to power failure and battery backup failure.

    I created a copy and tar of the entire opt/zimbra dir

    I am at a point now where I would like to uninstall and reinstall and try to rsync the data from the copy.

    when I ./install -u

    it goes through as normal until

    Backing up ldap

    bdb_db_open: unclean shutdown detected; attempting recovery
    bdb_db_open: Recovery skipped in read-only mode. Run manual recovery if errors are encoutered.

    Then it just sits and nothing happens.

    I have tried fixing all permissions

    db_recovery

    Kill all processes



    I have looked through all of the forums for 2 days now and found nothing exactly like my problem.

    This server was working perfectly prior to power failure.

    Any help would be great! Thank a lot



    EDIT:
    Also,

    This is what I received when

    su zimbra
    zmcontrol stop

    Code:

    COMMAND: zmcontrol stop
    Host
    mail.crestautoworld.com
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done

    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done

    Stopping mailbox...FAILED
    Killing mysqld with pid 3136 /opt/zimbra/bin/mysql.server: line 58: kill: (3136)
    - No such process
    .............................. gave up waiting!



    Stopping logger...Done
    Stopping ldap...Done

    I tried rebooting and when I
    zmcontrol status

    Cannot dtermine services - exiting

    When I zmcontrol start

    sometimes I get
    starting ldap...done

    and that's all...no other services start.


    This Forum page has similar symptoms

    http://www.zimbra.com/forums/showthr...mailbox+failed
    Last edited by pramsay; 04-02-2007 at 12:04 PM.

  2. #2
    Join Date
    Apr 2007
    Posts
    4
    Rep Power
    8

    Default Also; here is some info I got from day one of server failure

    This is what I received when

    su zimbra
    zmcontrol stop

    Code:

    COMMAND: zmcontrol stop
    Host
    mail.crestautoworld.com
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done

    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done

    Stopping mailbox...FAILED
    Killing mysqld with pid 3136 /opt/zimbra/bin/mysql.server: line 58: kill: (3136)
    - No such process
    .............................. gave up waiting!



    Stopping logger...Done
    Stopping ldap...Done

    I tried rebooting and when I
    zmcontrol status

    Cannot dtermine services - exiting

    When I zmcontrol start

    sometimes I get
    starting ldap...done

    and that's all...no other services start.


    This Forum page has similar symptoms

    http://www.zimbra.com/forums/showthr...mailbox+failed

  3. #3
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Hmm
    Try (run as root):
    kill -9 `ps -u zimbra -o "pid="`
    ps auxx | grep zimbra

    Kill any left over zimbra processes

    Then run
    cd /opt/zimbra/libexec
    ./zmfixperms
    su - zimbra
    zmcontrol start
    tail -100 /opt/zimbra/logs/mailbox.log
    (post that)
    tail -100 /opt/zimbra/tomcat/logs/catalina.out
    (post that)
    tail -100 /var/log/zimbra.log
    (post that)

    We'll figure out what's goin on.

  4. #4
    Join Date
    Apr 2007
    Posts
    4
    Rep Power
    8

    Default

    Thanks, I will post those in the morning when I get back on site. already did try the repair permissions, but maybe the logs will show something.

Similar Threads

  1. LDAP Replication Experiences
    By technikolor in forum Administrators
    Replies: 4
    Last Post: 11-12-2008, 12:52 AM
  2. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 11:12 AM
  3. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM
  4. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 03:39 PM
  5. Replies: 4
    Last Post: 11-15-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •