Results 1 to 10 of 46

Thread: configuring multiple domains on a single server

Hybrid View

  1. #1
    Join Date
    Mar 2007
    Posts
    29
    Rep Power
    8

    Default configuring multiple domains on a single server

    I am a complete newbie to both linux and zimbra. I have installed zimbra a few times now onto Ubuntu 6.10 but I am having difficulties in correctly configuring multiple domains.

    I have to set up 6 domains on the server, I had my server named mail..com and that was my default doamin for my zimbra installation. I used 'Internal' for authenication, we are only starting to build a network so I assumed that this is an internal LDAP for zimbra.

    I then created a new domain, doamin2.com and a user account for that domain. I changed my DNS to for domain2.com and when I ping mail.domain2.com I get the correct ip returned. However when I try to connect via outlook to domain2 email account I get a POP3 server error. If I try and email the account@domain2.com I get a 550 User not identified (I think this was it) and if I telnet mail.domain2.com 25 I get 220 mail.domain1.com returned.

    I have opened the 25 and 110 ports on the firewall etc.

    I am sorry but I am not an email admin but have be 'asked' to set this up.

    Does anyone have any suggestions or know of a good 'how to' doco?

    Does it have anything to do with Virtual Hosts?

    Any help greatly appreciated

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Ping is a dumb app. It won't return any useful information
    Have you tried dig?

    PS-*Seems* like a DNS issue. Check dig, hosts file, and DNS.

  3. #3
    Join Date
    Mar 2007
    Posts
    29
    Rep Power
    8

    Default

    Thanks jholder. I did dig mail.doamin2.com and it returned information for my DNS servers and the external ip address. I'll be honest I don't know a whole hell of a lot about DNS either. But here goes.

    mail.domain1.com is our current large production email server, it is on an imail server hosted for us. The CEO wants it in house. I built the Ubuntu box using zimbra and correctly or not decided that the hostname should be mail.domain1.com

    When I install zimbra - "I get a DNS Error resolving MX for mail.domain1.com, It is suggested that the domain name have an MX record configured in DNS" - duh I shouldn't have missed that.

    I can't change the DNS servers for mail.domain1.com until I have built and configured the email server.

    If I am using an new external DNS provider for the new server, do I require BIND on the mail server as well?

    Sorry guys but I am confused as hell.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    If you're behind a NAT device then you'll need a split DNS (details in the wiki) so your internal IP can be resolved, try 'dig yourdomain.com any' (then try it with MX instead of any) to see where you dns points to.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Mar 2007
    Posts
    29
    Rep Power
    8

    Default

    Thanks for the help guys, I guess I am not articulating myself well. I think I will look for another soln.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    I understand what you've said perfectly well, is there any problem trying the dig commands I posted? Apart from fixing this problem, what do you mean by 'other solution'?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Allow single account to be domain admin over multiple domains
    By peter@mxtoolbox.com in forum Administrators
    Replies: 2
    Last Post: 03-19-2008, 12:36 PM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. Replies: 3
    Last Post: 06-07-2007, 07:19 AM
  5. Multiple domains, single account
    By roastpork in forum Administrators
    Replies: 1
    Last Post: 02-08-2006, 08:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •