Results 1 to 5 of 5

Thread: Postfix can't run

  1. #1
    Join Date
    Mar 2007
    Posts
    8
    Rep Power
    8

    Default Postfix can't run

    After a system crash, my Zimbra don't work.
    When I run zmcontrol status:
    Host mail.mydomain.com
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    Timeout after 180 seconds

    The last sentence won't show untile 180 seconds later.
    I think it shows one of service in mta has no response.
    so I run:
    postfix start

    The process has no result. it seems it never finished.

    Could someone tell me how to repair Postfix, or where is the error log.
    Thanks.

  2. #2
    Join Date
    Mar 2007
    Posts
    8
    Rep Power
    8

    Default

    It seems my Postfix is out of control.
    After run
    $ postfix stop
    postfix/postfix-script: stopping the Postfix mail system

    I run this:
    $ ps -aux | grep postfix

    result:

    zimbra 21269 0.0 0.0 5364 1028 ? S 18:32 0:00 /bin/bash /opt/zimbra/bin/postfix status
    zimbra 21279 0.0 0.0 28228 2048 ? S 18:32 0:00 /opt/zimbra/postfix-2.2.9/sbin/postqueue -p
    zimbra 21615 0.0 0.0 5364 1028 ? S 18:34 0:00 /bin/bash /opt/zimbra/bin/postfix status
    zimbra 21625 0.0 0.0 28228 2048 ? S 18:34 0:00 /opt/zimbra/postfix-2.2.9/sbin/postqueue -p
    zimbra 21888 0.0 0.0 5364 1028 ? S 18:36 0:00 /bin/bash /opt/zimbra/bin/postfix status
    zimbra 21898 0.0 0.0 28228 2048 ? S 18:36 0:00 /opt/zimbra/postfix-2.2.9/sbin/postqueue -p
    zimbra 22218 0.0 0.0 5364 1028 ? S 18:38 0:00 /bin/bash /opt/zimbra/bin/postfix status
    zimbra 22230 0.0 0.0 28228 2048 ? S 18:38 0:00 /opt/zimbra/postfix-2.2.9/sbin/postqueue -p

    Many many lines like above shows...
    I'm using Zimbra 4.5.4 RHEL4_64.
    It works well before the system crash.

  3. #3
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Yep, stop all of those.
    If you can't, then kill them with a sig 9

    Run fsck to see if you have any disk errors, and run the zmfixperms script located in the libexec dir

    If that doesn't fix it, run
    ./install.sh -s

    from the original install dir.

  4. #4
    Join Date
    Mar 2007
    Posts
    8
    Rep Power
    8

    Default

    Thanks your reply
    Before I follow you, I want to know if "zmfixperms" or "./install.sh -s" may destory the users mail account and mailbox?
    Because I have a lot of user using the mailserver.

  5. #5
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Nope.

    However, it's always a good idea to backup your data.

Similar Threads

  1. Replies: 23
    Last Post: 01-24-2013, 03:44 PM
  2. Modifying the Zimbra Postfix Configuration
    By Bevan Bennett in forum Installation
    Replies: 9
    Last Post: 02-05-2009, 06:36 AM
  3. Replies: 3
    Last Post: 11-03-2007, 11:55 PM
  4. Sending Mail! Still something wrong!
    By BlueHaven in forum Installation
    Replies: 11
    Last Post: 08-02-2007, 05:19 PM
  5. unable to restart zimbra after reboot
    By droefs in forum Administrators
    Replies: 28
    Last Post: 04-16-2006, 03:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •