Results 1 to 5 of 5

Thread: Upgrade from 3.1.3 to 4.0.3

  1. #1
    Join Date
    Feb 2006
    Posts
    25
    Rep Power
    9

    Default Upgrade from 3.1.3 to 4.0.3

    Hi,

    There is someone that have been upgrade from 3.1.3 to 4.0.3?? I'm planning to make this upgrade and i want to know if someone reported problems doing this upgrade..

  2. #2
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    I've gone through an upgrade from version 3.1.x to version 4.0.x on CentOS 4, but I don't think it was the exact versions you mention. This upgrade was simple, straightforward, and painless. My question to you, though, is why are you only upgrading to version 4.0.3? The current version of Zimbra is 4.5.5. You really should consider upgrading to this latest version.

  3. #3
    Join Date
    Feb 2006
    Posts
    25
    Rep Power
    9

    Default Upgrade from 3.1.3 to 4.0.3

    I'm gonna upgrade to this version because i have to migrate Zimbra from the current servers (32 bits) to new servers running OS and Zimbra 64 bits. Wat i'm gonna do is :

    Upgrade the actual servers from 3.1.3 to 4,0,3 (32 bits), in my new servers install the same version but in 64 bits. Then, when i've tested that's works fine, i'm gonna upgrade to the actual Zimbra Version in 64 bits.

    Quote Originally Posted by soxfan View Post
    I've gone through an upgrade from version 3.1.x to version 4.0.x on CentOS 4, but I don't think it was the exact versions you mention. This upgrade was simple, straightforward, and painless. My question to you, though, is why are you only upgrading to version 4.0.3? The current version of Zimbra is 4.5.5. You really should consider upgrading to this latest version.

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    why not 4.5.4 32bit on the current server then
    4.5.5 64bit on the new server?
    (though some like to get just to v4 first then the sub-releases)

    course this might be a stupid question-but I don't know what operating system your using
    Last edited by mmorse; 05-22-2007 at 10:43 AM.

  5. #5
    Join Date
    Feb 2006
    Posts
    25
    Rep Power
    9

    Default Upgrade Failed

    Two Weeks ago, i've tried to make this upgrade , but it's fails.... That's what i made;

    In my Zimbra Store server (Zimbra version 3.1.3)

    1.- Shut Down Zimbra Services
    2.- Backup /opt/zimbra, /mailbox (here is store, db, log, logger)
    3.- Run 4.0.2 installer and got this error message:
    Code:
    Checking for installable packages
    
    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell
    
    
    The Zimbra Collaboration Suite appears already to be installed.
    It can be upgraded with no effect on existing accounts,
    or the current installation can be completely removed prior
    to installation for a clean install.
    
    Do you wish to upgrade? [Y] Y
    
    Select the packages to install
        Upgrading zimbra-core
        Upgrading zimbra-ldap
        Upgrading zimbra-logger
    
    Install zimbra-mta [Y] N
        Upgrading zimbra-snmp
        Upgrading zimbra-store
        Upgrading zimbra-apache
        Upgrading zimbra-spell
    
    Installing:
        zimbra-core
        zimbra-ldap
        zimbra-logger
        zimbra-snmp
        zimbra-store
        zimbra-apache
        zimbra-spell
    
    The system will be modified.  Continue? [N] Y
    
    Shutting down zimbra mail
    
    Backing up ldap
    
    
    Removing existing packages
    
       zimbra-ldap...done
       zimbra-logger...done
       zimbra-snmp...done
       zimbra-store...done
       zimbra-spell...done
       zimbra-apache...done
       zimbra-core...done
    
    Removing deployed webapp directories
    Installing packages
    
      zimbra-core......zimbra-core-4.0.2_GA_362.RHEL4-20060924201056.i386.rpm...done
        zimbra-ldap......zimbra-ldap-4.0.2_GA_362.RHEL4-20060924201056.i386.rpm...done
        zimbra-logger......zimbra-logger-4.0.2_GA_362.RHEL4-20060924201056.i386.rpm...done
        zimbra-snmp......zimbra-snmp-4.0.2_GA_362.RHEL4-20060924201056.i386.rpm...done
        zimbra-store......zimbra-store-4.0.2_GA_362.RHEL4-20060924201056.i386.rpm...done
        zimbra-apache......zimbra-apache-4.0.2_GA_362.RHEL4-20060924201056.i386.rpm...done
        zimbra-spell......zimbra-spell-4.0.2_GA_362.RHEL4-20060924201056.i386.rpm...done
    
    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
       HOSTNAME=canelo.midomimio.cl
       LDAPHOST=
       LDAPPORT=
       SNMPTRAPHOST=canelo.midomimio.cl
       SMTPSOURCE=admin@midomimio.cl
       SMTPDEST=admin@midomimio.cl
       SNMPNOTIFY=yes
       SMTPNOTIFY=yes
       LDAPROOTPW=ZZZZZZ
       LDAPZIMBRAPW=ZZZZZ
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    chown: no se puede acceder a «/opt/zimbra/conf/smtpd.key»: No existe el fichero o el directorio
    chown: no se puede acceder a «/opt/zimbra/conf/smtpd.crt»: No existe el fichero o el directorio
    Operations logged to /tmp/zmsetup.log.23794
    Setting defaults...Setting defaults from existing config...Done
    Upgrading from 3.1.3_GA_474 to 4.0.2_GA_362
    Sat May 12 14:25:45 2007: Stopping zimbra services
    Sat May 12 14:25:50 2007: Starting mysql
    UPGRADE FAILED - exiting
    After that i've tried to start the server but it does not start:

    Code:
    [root@canelo zcs]# su - zimbra
    [zimbra@canelo ~]$ zmcontrol status
    Cannot determine services - exiting
    [zimbra@canelo ~]$ zmcontrol start 
    Host canelo.conaf.cl
            Starting ldap...Done.
            Starting logger...Done.
            Starting mailbox...Done.
            Starting snmp...Done.
            Starting spell...Done.
    [zimbra@canelo ~]$ zmcontrol status 
    Host canelo.conaf.cl
            ldap                    Running
            logger                  Stopped
                    logmysql.server is not running
                    zmlogswatchctl is not running
            mailbox                 Stopped
                    mysql.server is not running
            snmp                    Running
            spell                   Running

    After Hours triying to fix this, i downloaded the backup and i got the same errors, so , i have rebuild the logger mysql db and add the following line in sudo config (visudo), because, when i run zmcontrol start, its promt for a password:

    root ALL=(ALL) ALL

Similar Threads

  1. Upgrade 3.1.3 to 4.0.3 -FAILED
    By rrojas in forum Installation
    Replies: 4
    Last Post: 05-28-2007, 09:05 AM
  2. Upgrade from Zimbra 3.1.3 to Latest edition (4.5.5)
    By jeemeekay in forum Administrators
    Replies: 1
    Last Post: 05-16-2007, 03:55 AM
  3. 4.0.3 -> 4.5.1 upgrade
    By Storm16 in forum Installation
    Replies: 1
    Last Post: 02-11-2007, 08:44 PM
  4. Replies: 16
    Last Post: 11-29-2006, 09:36 AM
  5. Upgrade to 4.0.3 on Suse 9.3
    By winne27 in forum Migration
    Replies: 3
    Last Post: 10-27-2006, 10:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •