Results 1 to 10 of 10

Thread: zimbra-core must be enabled

  1. #1
    lynggaard Guest

    Default zimbra-core must be enabled

    Hello

    I am trying to install the newest zimbra on ubuntu 7.4 but I am running into a problem

    All I get is this:
    "
    Installing packages

    zimbra-core......zimbra-core_4.5.5_GA_838.UBUNTU6_i386.deb...done
    zimbra-ldap......zimbra-ldap_4.5.5_GA_838.UBUNTU6_i386.deb...done
    zimbra-logger......zimbra-logger_4.5.5_GA_838.UBUNTU6_i386.deb...done
    zimbra-mta......zimbra-mta_4.5.5_GA_838.UBUNTU6_i386.deb...done
    zimbra-snmp......zimbra-snmp_4.5.5_GA_838.UBUNTU6_i386.deb...done
    zimbra-store......zimbra-store_4.5.5_GA_838.UBUNTU6_i386.deb...done
    zimbra-apache......zimbra-apache_4.5.5_GA_838.UBUNTU6_i386.deb...done
    zimbra-spell......zimbra-spell_4.5.5_GA_838.UBUNTU6_i386.deb...done
    Operations logged to /tmp/zmsetup.log.15291
    zimbra-core must be enabled.
    "

    It doesn't continue to configuration or anything. when looking in syslog is appears that something has failed because I see stuff as:

    "May 12 12:36:10 home slapcat: could not stat config file "/opt/zimbra/conf/slapd.conf": No such file or directory (2)"

    May 12 12:36:05 home postfix[14044]: warning: My hostname home is not a fully qualified name - set myhostname or mydomain in /opt/zimbra/postfix-2.2.9/conf/main.cf



    Any ideas ?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by lynggaard View Post
    Hello

    I am trying to install the newest zimbra on ubuntu 7.4 but I am running into a problem
    Any particular reason you're not using the supported Ubuntu version for installing Zimbra? You do realise that it may not work on this version, don't you?


    Quote Originally Posted by lynggaard View Post
    May 12 12:36:05 home postfix[14044]: warning: My hostname home is not a fully qualified name - set myhostname or mydomain in /opt/zimbra/postfix-2.2.9/conf/main.cf
    The usual questions about hosts file, DNS A & MX records - are they all set-up correctly? Have you looked at some of the other Ubuntu troubleshooting threads?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Feb 2007
    Posts
    11
    Rep Power
    8

    Default same problem

    I have attached my install log file. I am trying to install this on my laptop to demo for some people, and its not running ubuntu edgy but feisty fawn.
    Attached Files Attached Files

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You can see from my post above that the version of Ubuntu that you have isn't supported, it may not work. Search the forums for some details if you want to use that version but I'd suggest installing the supported version of Ubuntu.
    Last edited by phoenix; 05-23-2007 at 12:07 PM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    May 2007
    Posts
    3
    Rep Power
    8

    Default I have the same problem

    I am having exactly the same problem: "zimbra-core must be enabled" then exit right before doing the config part of the install. Seems close to working as otherwise everything in the install goes very smoothly.

    Appears that this problem happens in /opt/zimbra/libexec/zmsetup.pl. I took a look at the code but really could not follow it well enough to diagnose.

    Is it best to just run Zimbra on a dedicated server with Ubuntu 6?

    - Jon

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by jon21 View Post
    Is it best to just run Zimbra on a dedicated server with Ubuntu 6?
    Yes, the easiest thing is to use Ubuntu 6.06 LTS.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    May 2007
    Posts
    17
    Rep Power
    8

    Default

    i have the same problem as you, here a solution:

    edit
    /opt/zimbra/libexec/zmsetup.pl

    there is a problem with the sub isInstalled()

    so,change the following

    +- line 324

    # if its already defined return;
    # if (defined $enabledPackages{$package}) {
    # if ($enabledPackages{$package} eq "Enabled") {
    # detail("$package is enabled");
    # return 1;
    # } else {
    # detail("$package is not enabled");
    # return undef;
    # }

    return 1;



    it's works for me (crappy but it's work)

  8. #8
    Join Date
    Sep 2007
    Posts
    12
    Rep Power
    8

    Default

    The problem is in get_plat_tag.sh

    To install zimbra under feisty replace get_plat_tag.sh in the installation bin/ directory with this:

    #!/bin/sh
    echo UBUNTU6

    run install and check all prerequisites. Use apt(itude) to install all required packages if necessary.

    Before installing, open a second shell in/to the server.
    After the zimbra-core package has been installed, immediately go to the second shell and change to /opt/zimbra/libexec. Either copy bin/get_plat_tag.sh from the installation dir here or delete the original and edit it to resemle the above script.

    Now the internal "installed" check will return ok and installation will continue without problems and zimbra will run without problems.

    Remember: This is not a supported installation

  9. #9
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    There is a simpler solution I posted a while back. The installer is incorrectly detecting it as a debian4 OS due to /etc/debian_release present in Ubuntu gutsy, iirc. Temporarily move this file or replace the contents with something sensible and the installer runs fine.

  10. #10
    Join Date
    Sep 2007
    Posts
    12
    Rep Power
    8

    Default

    Apart from that, antivirus and clamscan don't seem to run fine under feisty, and stats reports itself as stopped as well. So for the time being I will behave like a good citizen and install 5beta3 on a fresh edgy install...

Similar Threads

  1. Replies: 7
    Last Post: 01-24-2007, 10:03 PM
  2. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 12:00 PM
  3. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM
  4. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 07:23 AM
  5. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 06:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •