Page 4 of 4 FirstFirst ... 234
Results 31 to 33 of 33

Thread: multi-domain configuration - mail loops back

  1. #31
    Join Date
    Sep 2005
    Location
    Somewhere south of the border at this point... nice and sunny
    Posts
    47
    Rep Power
    10

    Default

    bill - this iteration of the hosts file (the one you quoted):

    Code:
    ##
    # Host Database
    #
    # localhost is used to configure the loopback interface
    # when the system is booting.  Do not change this entry.
    ##
    127.0.0.1       localhost
    255.255.255.255 broadcasthost
    ::1             localhost
    
    # Local IPs
    192.168.13.13   sigil.mechanus.org
    worked fine until the second domain was added. meaning, mechanus.org (when it was the single domain hosted in zimbra) could send e-mail to external domains without a problem.

    as i added eskinaproductions.com as a domain, and went through the troubleshooting, it's now:

    Code:
    ##
    # Host Database
    #
    # localhost is used to configure the loopback interface
    # when the system is booting.  Do not change this entry.
    ##
    127.0.0.1       localhost.localdomain localhost
    255.255.255.255 broadcasthost
    ::1             localhost
    
    # Local IPs
    192.168.13.13   sigil.mechanus.org sigil
    more or less like the guide says. email, however, is still being dropped in the deferred queue when its destination is external to the two hosts on the server (mechanus.org and eskinaprouctions.com).

    dig mechanus.org mx on the LAN DNS server (which is the same box) returns:

    Code:
    ; <<>> DiG 9.3.2 <<>> mechanus.org mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17601
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;mechanus.org.                  IN      MX
    
    ;; ANSWER SECTION:
    mechanus.org.           86400   IN      MX      5 sigil.mechanus.org.
    
    ;; AUTHORITY SECTION:
    mechanus.org.           86400   IN      NS      sigil.mechanus.org.
    
    ;; ADDITIONAL SECTION:
    sigil.mechanus.org.     86400   IN      A       192.168.13.13
    
    ;; Query time: 3 msec
    ;; SERVER: 192.168.13.13#53(192.168.13.13)
    ;; WHEN: Tue May 22 11:57:38 2007
    ;; MSG SIZE  rcvd: 82
    mx2 is outside of the internal network - it's a backup mx, which is the only starking difference i see right now.
    cheers,

    rodolfo

  2. #32
    Join Date
    Sep 2005
    Location
    Somewhere south of the border at this point... nice and sunny
    Posts
    47
    Rep Power
    10

    Default

    I'm going to guess that the simplest solution would be to find someone who's willing to be a relay for this zimbra install, no?

    I'm guessing, since this problem has cropped up a bit here with no apparent solution, i'm guessing everyone is using external relays with the ISPs (which I can't use my ISPs for several reasons) or they installed their own external relays?
    cheers,

    rodolfo

  3. #33
    Join Date
    Sep 2005
    Location
    Somewhere south of the border at this point... nice and sunny
    Posts
    47
    Rep Power
    10

    Default

    hey guys, to close out this thread, and hopefully provide a solution to this problem, if anyone else encounters it. I was checking the postfix conf with a friend of mine and the external MTA should be BLANK. If you don't have an edge MTA, nothing should go there, and it should work.
    cheers,

    rodolfo

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 02:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 04:34 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •