Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: ldap error

  1. #11
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Unfortunetly, the error 99 has nothing to do with DNS. An error 99 is an access denied, which means that the address associated with your domain cannot be bound to.

    Check your hosts file. if that's correct, make sure the address that's referenced in your hosts file is correctly assigned to an ethernet adapter.

  2. #12
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Check your DNS configuration with the following commands (on the zimbra server):

    Code:
    host `hostname`  <-- type as-is and use backticks not single quotes
    dig yourcomain.com mx
    dig yourcomain.com any
    post the results.

    I'd rather you installed the most recent version of Zimbra as there were a lot of fixes since 4.5.7
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #13
    Join Date
    Nov 2007
    Posts
    48
    Rep Power
    7

    Thumbs up

    THANK YOU.

    I sadly replied about my Jr. Admin to FIX that dan /etc/hosts file and had not verified it myself. It was wrong (using the pervious mail instead of testmain).

    LDAP started successfully. I suppose the title on this thread is once again correct.

    After a week of hardware crashed, bad CERTS from NAS firmware upgrades and insane problems validating an IronKey.. It's nice to put this in the WIN column!!!!

  4. #14
    Join Date
    Nov 2007
    Posts
    4
    Rep Power
    7

    Default help: errno=99

    Sorry for the complications. I'm a newby in linux also. I hope you can guide me to solve this problem. I already read other post but seem nothing work. I already install zcs-4.5.9_GA_1454.RHEL5.tgz but the problems appear.

    this is my /etc/hosts file
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6
    218.111.110.57 mail.daquarian.com mail

    [root@mail zcs]# sudo /opt/zimbra/openldap-2.3.37.7/libexec/slapd -d7 -l LOCAL0 -4 -u zimbra -h dap://mail.daquarian.com:389 -f /opt/zimbra/conf/slapd.conf
    @(#) $OpenLDAP: slapd 2.3.37 (Oct 14 2007 11:43:14) $
    build@build10.re.zimbra.com:/home/build/p4/FRANK/ThirdParty/openldap/openldap-2.3.37.7/servers/slapd
    daemon_init: dap://mail.daquarian.com:389
    daemon_init: listen on dap://mail.daquarian.com:389
    daemon_init: 1 listeners to open...
    ldap_url_parse_ext(dap://mail.daquarian.com:389)
    daemon: listen URL "dap://mail.daquarian.com:389" parse error=3
    slapd stopped.
    connections_destroy: nothing to destroy.

  5. #15
    Join Date
    Nov 2007
    Posts
    48
    Rep Power
    7

    Default

    After fixing my /etc/hosts file and rebooting the system.. Zimbra refused to work again.

    After a lot more googling around.. I took the advice that I needed to be SURE that all processes were killed. Sadly.. the /etc/init.d/zimbra stop/start script is horriblhy inadequate. When slapd starts quit... the script did not indiated anything had gone wrong. Nor, did it tell me the one time I went right.

    If there is not a but to change the start/stop/restart script to be more UNIX like (e.g. show [OK] [FAILED] messages for EVERY step of start/stop.. here.. let me show an example of properly crafter start/stop script incase the team that wrote the zimbra one has never seen one. Observer the status message for each component of the system's shutdown and resart. Simple.. but VERY effective when managing a system.

    Code:
    -bash-3.1# /etc/init.d/sendmail restart
    Shutting down sm-client:                                   [  OK  ]
    Shutting down sendmail:                                    [  OK  ]
    Starting sendmail:                                         [  OK  ]
    Starting sm-client:                                        [  OK  ]
    -bash-3.1#
    So.. let me close my rant with this. After making sure I killed everything zimbra related ( ps -ealf | grep zimbra ) I uninstalled it for the 10th or so time.. and ran one more install.

    That time it worked. Properly. Now I have been able to turn the system over to my mail admin for final configuration. It's takem more than a week to get this up and running.

    I looked at your /etc/hosts.. looks OK to me. Check your MX and hostname digs and see if those are all pointing at the same server.

    One of the initial 'mistakes' we made was using a generic name of 'mail' for our server.. but we already had a 'mail' MX record for our domain. What we did was create an MX record for 'testmail.ourdomain.com' which pointed to the server named 'mail.ourdomain.com' (which was resolvable via DNS and also /etc/hosts). The problem this caused was the startup script sometimes used the DNS, sometimes used the MX entry and in other cases based it's automated $url paramters (in the setup scripts), making for some very frustrating installation messages.

    My advice:

    - kill all zimbra processes
    - make sure the MX, DNS and /etc/hosts ALL reference the same system and IP.
    - uninstall zimbra (install.sh -u)
    - re-instal zimbra (install.sh)
    - keep fingers crossed.
    - let us know if it worked.

  6. #16
    Join Date
    Nov 2007
    Posts
    4
    Rep Power
    7

    Default Errno:99

    Hi,

    I got this error while installing zcs-4.5.9_GA_1454.RHEL5.tgz on Centos 5.

    Attempt to complete configuration now? [yes] Failed to start slapd. Attempting debug start to determine error.
    daemon: bind(7) failed errno=99 (Cannot assign requested address)
    slap_open_listener: failed on ldap://mail.daquarian.com:389


    Save configuration data to a file? [Yes] yes
    Save config in file: [/opt/zimbra/config.10599] /opt/zimbra/config.10599
    Saving config in /opt/zimbra/config.10599...Done
    The system will be modified - continue? [No] yes
    Operations logged to /tmp/zmsetup.log.10599
    Initializing ldap...Failed to start slapd. Attempting debug start to determine error.
    daemon: bind(7) failed errno=99 (Cannot assign requested address)
    slap_open_listener: failed on ldap://mail.daquarian.com:389

    FAILED (1)


    ERROR



    Configuration failed

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.

    Errors have been logged to /tmp/zmsetup.log.10599

    --------------------------------------------------------------------------
    Then i do this command and i got this message.

    [root@mail ~]# sudo /opt/zimbra/openldap-2.3.37.7/libexec/slapd -d7 -l LOCAL0 -4 -u zimbra -h ldap://mail.daquarian.com:389 -f /opt/zimbra/conf/slapd.conf
    @(#) $OpenLDAP: slapd 2.3.37 (Oct 14 2007 11:43:14) $
    build@build10.re.zimbra.com:/home/build/p4/FRANK/ThirdParty/openldap/openldap-2.3.37.7/servers/slapd
    daemon_init: ldap://mail.daquarian.com:389
    daemon_init: listen on ldap://mail.daquarian.com:389
    daemon_init: 1 listeners to open...
    ldap_url_parse_ext(ldap://mail.daquarian.com:389)
    daemon: bind(7) failed errno=99 (Cannot assign requested address)
    slap_open_listener: failed on ldap://mail.daquarian.com:389
    slapd stopped.
    connections_destroy: nothing to destroy.

    --------------------------------------------------------------------------
    etc/hosts:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6
    218.111.110.57 mail.daquarian.com mail

    --------------------------------------------------------------------------
    network configuration:

    eth0 Link encap:Ethernet HWaddr 00:0D:87:AC:2D:35
    inet addr:192.168.4.13 Bcast:192.168.4.255 Mask:255.255.255.0
    inet6 addr: fe80::20d:87ff:feac:2d35/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:2740 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2362 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:213420 (208.4 KiB) TX bytes:236318 (230.7 KiB)
    Interrupt:177 Base address:0x2000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:33 errors:0 dropped:0 overruns:0 frame:0
    TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2276 (2.2 KiB) TX bytes:2276 (2.2 KiB)
    --------------------------------------------------------------------------
    Can someone help me to solve this error.

  7. #17
    Join Date
    Nov 2007
    Posts
    48
    Rep Power
    7

    Default

    Hi there,

    I can sympathise.

    First thing that jumps out at my is your network config and /etc/hosts not matching.

    Code:
    --------------------------------------------------------------------------
    etc/hosts:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6
    218.111.110.57 mail.daquarian.com mail
    
    --------------------------------------------------------------------------
    network configuration:
    
    eth0 Link encap:Ethernet HWaddr 00:0D:87:AC:2D:35
    inet addr:192.168.4.13 Bcast:192.168.4.255 Mask:255.255.255.0
    inet6 addr: fe80::20d:87ff:feac:2d35/64 Scope:Link
    What you have is an /etc/hosts file that is trying to tell slapd (LDAP) that the mail server's IP is 218.111.110.57

    However, your network configuration (do you have DHCP turned on. .it looks like a DHCP assigned address) is 192.168.4.13.

    Thus. slapd is totally confused about which IP it's supposed to be attempting it's bind to.

    First step is to re-configure your eth0 NIC to the 218 address... OR change your /etc/hosts file to match the actualy IP currently set to eth0.

    If you need to change the eth0 config.. it's 'typically' located here:

    /etc/sysconfig/network-scripts/ifcfg-eth0

  8. #18
    Join Date
    Nov 2007
    Posts
    4
    Rep Power
    7

    Default Idap error - errno=99

    Hi,

    Do I need to have DNS Server. My network currently doing NAT and firewall. Can you advise any idea to solve this problem.
    I ready do the changes to 218 add but still have problem and change to 192.168.4.13 also cannot get through. Have any ideas?
    Last edited by KarLMarX; 11-23-2007 at 01:15 AM.

  9. #19
    Join Date
    Nov 2007
    Posts
    48
    Rep Power
    7

    Default

    Hi Karl,

    I wish I had some workable suggestions. It could be a problem with the NAT and/or routing.

    I'm a PERL developer by profession, tossed into the realm of sys-admin out of necessity. I'm way out of my depth in this regard, so any suggestions beyond my comfort zone might be worse than none at all.

    When dealing with the NAT issues on our own (convoluted) network, the biggest problems I ran into were routing, and how the messages found their way to the systems behind a few levels of firewalls and routers.

    As far as I can tell, the DNS is likely the cause of the problem. I had some very strange errors and install failures until we re-loaded the system and set it's hostname to the final production hostname (instead of a testing name originally attempted) and made sure our MX record matched precisely.

    Networking is far from my forte, so again, I'd hate to give you bad advice on accident (or on purpose.. either for that matter! )

  10. #20
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by KarLMarX View Post
    Hi,

    Do I need to have DNS Server. My network currently doing NAT and firewall. Can you advise any idea to solve this problem.
    I ready do the changes to 218 add but still have problem and change to 192.168.4.13 also cannot get through. Have any ideas?
    If you are still having problems and your zimbra server is behind a router then you need a local DNS server so that postfix can find itself plus a correct /etc/hosts file. You can check your setting with these commands I posted earlier:

    Code:
    host `hostname`  <-- type as-is and use backticks not single quotes
    dig yourcomain.com mx
    dig yourcomain.com any
    and post the output here. You should also disable ipv6 & any firewall & SElinux on the Zimbra server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 23
    Last Post: 01-24-2013, 02:44 PM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  4. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM
  5. Building native libraries on MacOS X
    By ajmas in forum Developers
    Replies: 3
    Last Post: 10-14-2005, 11:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •