Results 1 to 2 of 2

Thread: Post upgrade issues with mysql data

  1. #1
    Join Date
    Nov 2006
    Posts
    4
    Rep Power
    8

    Exclamation Post upgrade issues with mysql data - cannot open old email

    Hi guys,

    I really hope someone can help me out here. Been going through these awsome forums and have fixed all issues up until now. Currently our users cannot access any of their mail or calendar items from the webmail interface or using a mail client, since the upgrade an hour ago to v4.5 from 4.0 (opensource version). The error message that comes up is as follows:

    A network service error has occurred.
    msg - system failure: missing blob for id: 4913, change: 6900
    code - service.FAILURE
    method - ZmCsfeCommand.prototype.invoke
    detail - soap:Receiver

    This error shows up when ever we try to open an existing email item or try to get the details for a calendar item.

    I think it might have something to do with mysql permissions on the data possibly. Only because they can 'See' the emails in their inbox and mail folders, but cant open them. The zimbra administration panel works ok, I have checked in there to see if there is something that would help but no luck.

    Any help would be Greatly appreciated. Thanks guys.

    here is an excerpt from the mailbox.log file
    Code:
    [mid=5;ua=ZimbraWebClient - FF1.5 (Linux)/4.5.5_GA_838.FC5;ip=192.168.1.182;name=XXXXXX@XXXXXXX.com;] SoapEngine - handler exception
    com.zimbra.common.service.ServiceException: system failure: missing blob for id: 3462, change: 6326
    	at com.zimbra.common.service.ServiceException.FAILURE(ServiceException.java:175)
    	at com.zimbra.cs.mailbox.MailItem.getBlob(MailItem.java:716)
    	at com.zimbra.cs.mailbox.MessageCache.fetchFromStore(MessageCache.java:226)
    	at com.zimbra.cs.mailbox.MessageCache.getMimeMessage(MessageCache.java:187)
    	at com.zimbra.cs.mailbox.Message.getMimeMessage(Message.java:306)
    	at com.zimbra.cs.mailbox.Message.getMimeMessage(Message.java:287)
    	at com.zimbra.cs.service.mail.ToXML.encodeMessageAsMP(ToXML.java:603)
    	at com.zimbra.cs.service.mail.GetMsg.handle(GetMsg.java:75)
    	at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:270)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:168)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:90)
    	at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:223)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
    	at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:162)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
    	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
    	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
    	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
    	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
    	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
    	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:541)
    	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
    	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
    	at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:667)
    	at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
    	at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
    	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
    	at java.lang.Thread.run(Thread.java:595)
    2007-05-27 13:45:30,537 INFO  [Timer-0] [] SessionCache - Removed 1 idle sessions (SoapSession: 1).  2 active sessions remain.
    2007-05-27 13:45:32,240 INFO  [LmtpServer-1] [] LmtpHandler - [192.168.1.182] connected
    2007-05-27 13:45:32,315 INFO  [LmtpServer-1] [] cache - Initializing folder and tag caches for mailbox 2
    2007-05-27 13:45:32,377 INFO  [LmtpServer-1] [] mailbox - Re-Indexing: Mailbox 2 COMPLETED.  Re-indexed 0 items in 0ms.  (avg 0ms/item= 0 items/sec) (0 failed) 
    2007-05-27 13:45:32,406 INFO  [LmtpServer-1] [] JMSession - SMTP Server: XXX.XXXX.XXXX
    2007-05-27 13:45:32,460 INFO  [LmtpServer-1] [] zimlet - Loaded class com.zimbra.cs.zimlet.handler.NANPHandler
    2007-05-27 13:45:32,462 INFO  [LmtpServer-1] [] zimlet - Loaded class com.zimbra.cs.zimlet.handler.RegexHandler


    ---------------------


    Solved it!

    Somthing went wrong durign the upgrade with the 'store' folder. Had to replace it with one from the backup. Placed into the /opt/zimbra folder and everything is good to go.

    This link was really helpful.

    http://www.zimbra.com/forums/adminis...lob-error.html
    Last edited by zimbratester; 05-28-2007 at 11:56 PM. Reason: added mailbox.log info

  2. #2
    Join Date
    Nov 2006
    Posts
    4
    Rep Power
    8

    Default Solved !!

    Solved !!


    It seems that during the upgrade there were some archiving issues. Had to dig in the archives and restore the 'store' folder to the /opt/zimbra/ folder. Found a post that was helpful, see below if you have a similar problem.


    http://www.zimbra.com/forums/adminis...lob-error.html

Similar Threads

  1. mysql data store rebuild
    By ashelley in forum Administrators
    Replies: 3
    Last Post: 03-23-2010, 03:39 PM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. Replies: 18
    Last Post: 03-20-2006, 01:22 PM
  4. Post Upgrade Issues - Logger berserk?
    By Coilcore in forum Administrators
    Replies: 1
    Last Post: 03-03-2006, 03:08 PM
  5. Upgrade wipes all data??
    By dijichi2 in forum Installation
    Replies: 8
    Last Post: 11-15-2005, 06:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •