I've been searching for a solution to this for the last few hours, and I've seen loads of threads with this error in them, some of them duplicate this problem precisely, but none of them contain advice that can solve my problem.

When I run zmcontrol start, it will only start the ldap daemon:

Host steve.ac
Starting ldap...Done.

These are the only lines that appear in zimbra.log
Jun 10 18:46:13 vps zimbramon[18278]: 18278:info: Starting services
Jun 10 18:46:14 vps slapd[18378]: @(#) $OpenLDAP: slapd 2.3.34 (Apr 4 2007 12:09:30) $ root@support4.liquidsys.com:/home/build/p4/main/ThirdParty/openldap/openldap-2.3.34/servers/slapd
Jun 10 18:46:14 vps slapd[18379]: slapd starting

It's worth noting that I have absolutely no idea what root@support4.liquidsys.com is. It is certainly not a path that exists on my system.


However, I can now stop it:

[zimbra@vps ~]$ zmcontrol stop
Host steve.ac
Stopping mta...Done
Stopping spell...Done
Stopping snmp...Done
Stopping antivirus...Done
Stopping antispam...Done
Stopping imapproxy...Done
Stopping mailbox...Done
Stopping logger...Done
Stopping ldap...Done

An interesting observation: When I installed Zimbra, I did not select spell (because it kept failing with no error information), and I did not select snmp (because I do not need it). I don't know why those two are showing up above.


The log file now has a few more interesting lines added to it:

Jun 10 19:01:13 vps zimbramon[26537]: 26537:info: Stopping services
Jun 10 19:01:13 vps zimbramon[26537]: 26537:info: Stopping mta
Jun 10 19:01:13 vps postfix[27679]: fatal: chdir(/usr/libexec/postfix): No such file or directory
Jun 10 19:01:14 vps zimbramon[26537]: 26537:info: Stopping spell
Jun 10 19:01:15 vps zimbramon[26537]: 26537:info: Stopping snmp
Jun 10 19:01:15 vps zimbramon[26537]: 26537:info: Stopping antivirus
Jun 10 19:01:15 vps zimbramon[26537]: 26537:info: Stopping antispam
Jun 10 19:01:15 vps zimbramon[26537]: 26537:info: Stopping imapproxy
Jun 10 19:01:18 vps zimbramon[26537]: 26537:info: Stopping mailbox
Jun 10 19:01:18 vps zmtomcatmgr[28141]: threaddump requested
Jun 10 19:01:18 vps zmtomcatmgr[28141]: stale pid 3578 found in /opt/zimbra/log/zmtomcatmgr.pid: No such process
Jun 10 19:01:18 vps zmtomcatmgr[28141]: assuming no other instance is running
Jun 10 19:01:18 vps zmtomcatmgr[28141]: no manager process is running
Jun 10 19:01:20 vps zmtomcatmgr[28148]: stop requested
Jun 10 19:01:20 vps zmtomcatmgr[28148]: stale pid 3578 found in /opt/zimbra/log/zmtomcatmgr.pid: No such process
Jun 10 19:01:20 vps zmtomcatmgr[28148]: assuming no other instance is running
Jun 10 19:01:20 vps zmtomcatmgr[28148]: no manager process is running
Jun 10 19:01:20 vps zimbramon[26537]: 26537:info: Stopping logger
Jun 10 19:01:20 vps zimbramon[26537]: 26537:info: Stopping ldap
Jun 10 19:01:20 vps slapd[24078]: daemon: shutdown requested and initiated.
Jun 10 19:01:20 vps slapd[24078]: slapd shutdown: waiting for 0 threads to terminate
Jun 10 19:01:20 vps slapd[24078]: slapd stopped.


This is my hosts file:
127.0.0.1 localhost localhost.localdomain


Zmhostname:
steve.ac


There is an MX line in my /var/named/steve.ac.db (this is not the entirety of the file ).
steve.ac. 14400 IN MX 0 steve.ac.


My resolv.conf file:
nameserver 208.67.222.222
nameserver 208.67.220.220
(These are the OpenDNS nameservers)


The output of zmlocalconfig | grep ldap:
(I noticed that this was asked for in another post). The reason that ldap is pointed towards localhost is because this box is firewalled, and that port is not available from an external interface.. Does ldap listen on an external interface?
ldap_cache_account_maxage = 15
ldap_cache_account_maxsize = 5000
ldap_cache_cos_maxage = 15
ldap_cache_cos_maxsize = 100
ldap_cache_domain_maxage = 15
ldap_cache_domain_maxsize = 100
ldap_cache_server_maxage = 15
ldap_cache_server_maxsize = 100
ldap_cache_timezone_maxsize = 100
ldap_cache_zimlet_maxage = 15
ldap_cache_zimlet_maxsize = 100
ldap_connect_pool_debug = false
ldap_connect_pool_initsize = 1
ldap_connect_pool_maxsize = 50
ldap_connect_pool_prefsize = 0
ldap_connect_pool_timeout = 120000
ldap_connect_timeout = 30000
ldap_host = steve.ac
ldap_is_master = true
ldap_log_level = 32768
ldap_master_url = ldap://localhost:389
ldap_port = 389
ldap_root_password = *
ldap_url = ldap://localhost:389
postfix_sender_canonical_maps = ldap:/opt/zimbra/conf/ldap-scm.cf
postfix_transport_maps = ldap:/opt/zimbra/conf/ldap-transport.cf
postfix_virtual_alias_domains = ldap:/opt/zimbra/conf/ldap-vad.cf
postfix_virtual_alias_maps = ldap:/opt/zimbra/conf/ldap-vam.cf
postfix_virtual_mailbox_domains = ldap:/opt/zimbra/conf/ldap-vmd.cf
postfix_virtual_mailbox_maps = ldap:/opt/zimbra/conf/ldap-vmm.cf
zimbra_class_provisioning = com.zimbra.cs.account.ldap.LdapProvisioning
zimbra_ldap_password = *
zimbra_ldap_user = zimbra
zimbra_ldap_userdn = uid=zimbra,cn=admins,cn=zimbra
zimbra_zmprov_default_to_ldap = false

I would also be interested to know if there is a way to get some more debug info in zimbra.log.

Your assistance in this matter would be greatly appreciated. Thanks.