Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Tomcat failed to start after install

  1. #11
    Join Date
    Jun 2007
    Posts
    10
    Rep Power
    8

    Default

    [zimbra@133-1 conf]$ /opt/zimbra/libexec/zmmyinit
    * Creating required directories
    * Generating mysql config /opt/zimbra/conf/my.cnf
    * Creating database in /opt/zimbra/db/data
    * Starting mysql server
    * Failed to connect to mysql...retrying
    * Failed to connect to mysql...retrying

    [zimbra@133-1 conf]$ cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    ::1 localhost.localdomain localhost
    #70.126.1.133 FQDN 133-1.126-70.tampabay.res.rr.com
    70.126.1.133 133-1.126-70.tampabay.res.rr.com 133-1.126-70

  2. #12
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default


    Dude, Please reread the way that I have your hosts file. You need to fix the localhost entry.

  3. #13
    Join Date
    Jun 2007
    Posts
    10
    Rep Power
    8

    Default

    [zimbra@133-1 conf]$ /opt/zimbra/libexec/zmmyinit
    * Creating required directories
    * Generating mysql config /opt/zimbra/conf/my.cnf
    * Creating database in /opt/zimbra/db/data
    * Starting mysql server
    * Failed to connect to mysql...retrying
    * Failed to connect to mysql...retrying

    [zimbra@133-1 conf]$ cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    70.126.1.133 133-1.126-70.tampabay.res.rr.com 133-1.126-70

  4. #14
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Try to start Zimbra, and run a zmcontrol status. Then take a look to see if it connects. That's located in the /opt/zimbra/log/mailbox.log

  5. #15
    Join Date
    Jun 2007
    Posts
    10
    Rep Power
    8

    Default

    That worked...I dont know what zmmyinit couldnt connecte to the mysql database but zmcontrol start started right up! thanks a bunch!

  6. #16
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    It tries to connect several times because it can take a while (depending on the system) for mysql.server to start up.

    Enjoy.

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. After reboot mailbox and tomcat don't start
    By gon in forum Administrators
    Replies: 1
    Last Post: 11-02-2007, 11:50 AM
  3. Lotus migration
    By babou in forum Migration
    Replies: 15
    Last Post: 03-05-2007, 09:33 PM
  4. tomcat - macosx install - please help
    By gmsmith in forum Installation
    Replies: 3
    Last Post: 04-19-2006, 12:30 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •