Results 1 to 4 of 4

Thread: Tomcat crash / Port already used

  1. #1
    Join Date
    Jun 2007
    Posts
    9
    Rep Power
    8

    Default Tomcat crash / Port already used

    I've activated the proxy on the administration interface. Unfortunately, this made my Zimbra crash. Tomcat doesn't start anymore.

    Catalina log :

    Code:
    Zimbra server reserving server socket port=110 bindaddr=null ssl=false
    Fatal error: terminating: PrivilegedServlet init failed
    java.net.BindException: Address already in use
            at java.net.PlainSocketImpl.socketBind(Native Method)
            at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:359)
            at java.net.ServerSocket.bind(ServerSocket.java:319)
    Nmap -v:

    Code:
    PORT     STATE SERVICE
    22/tcp   open  ssh
    25/tcp   open  smtp
    80/tcp   open  http
    110/tcp  open  pop3
    143/tcp  open  imap
    389/tcp  open  ldap
    465/tcp  open  smtps
    993/tcp  open  imaps
    995/tcp  open  pop3s
    3306/tcp open  mysql
    TIA, Regards,

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    If this is a single server then you should not have started the proxy. Search the wiki for 'perdition' it tells you how to disable it via the command line.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jun 2007
    Posts
    9
    Rep Power
    8

    Default

    Quote Originally Posted by phoenix View Post
    If this is a single server then you should not have started the proxy. Search the wiki for 'perdition' it tells you how to disable it via the command line.
    Yep, but even if I shutdown Zimbra before, It catch an I/O exception ....

    Code:
    zmprov ms mydomain.com zimbraPop3BindPort 110 zimbraImapBindPort 143 zimbraPop3SSLBindPort 995 zimbraImapSSLBindPort 993
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    I'm not quite sure what you're telling me, have you stopped the proxy (perdition) via the command line?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. initializing ldap...FAILED(256)ERROR
    By manjunath in forum Installation
    Replies: 39
    Last Post: 06-07-2013, 11:27 AM
  2. Replies: 11
    Last Post: 06-22-2007, 02:32 PM
  3. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 10:19 AM
  4. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 11:34 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •