What in the World am I doing wrong here? I've been here for countless hours tinkering with these configurations. I can get the web interface for both admin and user to come up:

as user zimbra,

zmcontrol start

Everything starts, I send an email - It bounces back from Postfix (and does not reach the desired email account)

zmcontrol status

Then says that MTA is stopped as well as postfix.

... I have 'chkconfig postfix stop', made sure that it isn't running and MTA will say that it is running when I check the status. Then I send an email, it bounces back from postfix and I have to kill -9 Zimbra's version of postfix to get it going again.


--------------------------------------------------------------------------

File: /etc/hosts

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost mydomain.com
74.53.2xx.226 mydomain.com
74.53.2xx.226 mail.mydomain.com
74.53.2xx.227 ns.mydomain.com
74.53.2xx.238 ns2.mydomain.com
74.53.2xx.239 ns3.mydomain.com

--------------------------------------------------------------------------
File: .../named/chroot/var/named/mydomain.com.zone Modified

$TTL 3D @ IN SOA mail.mydomain.com. mail.mydomain.com. (

2005110200
8H ; refresh, seconds
2H ; retry, seconds
4W ; expire, seconds
1D ) ; minimum, seconds
NS mail ; Inet Address of name server
MX 10 mail.mydomain.com ; Primary Mail Exchanger

mail A 74.53.200.226

mail IN CNAME mail

--------------------------------------------------------------------------

File: /etc/named.conf Modified

//
// named.conf for Red Hat caching-nameserver
//

options {
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};

//


//
// a caching only nameserver config
//
controls {
inet 127.0.0.1 allow { localhost; } keys { rndckey; rndc-key; };
};

zone "." IN {
type hint;
file "named.ca";
};

zone "localdomain" IN {
type master;
file "localdomain.zone";
allow-update { none; };
};

};

zone "localhost" IN {
type master;
file "localhost.zone";
allow-update { none; };
};

zone "myhost.com" IN {
type master;
file "myhost.com.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
type master;
file "named.local";
allow-update { none; };
};

allow-update { none; };
};

zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.ip6.arpa" I$
type master;
file "named.ip6.local";
allow-update { none; };
};

zone "255.in-addr.arpa" IN {
type master;
file "named.broadcast";
allow-update { none; };
};

zone "0.in-addr.arpa" IN {
type master;
file "named.zero";
allow-update { none; };

file "named.zero";
allow-update { none; };
};

include "/etc/rndc.key";
key rndc-key {
algorithm hmac-md5;
secret "xxxxxxxxxxxxxxxxxxxxxxxxxxxx";
};

--------------------------------------------------------------------------

Please respond ASAP-Hopefully there is a simple solution!

Thanks, A.