Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Zimbra on Ubuntu 6.06

  1. #1
    Join Date
    Jun 2007
    Posts
    21
    Rep Power
    8

    Default Zimbra on Ubuntu 6.06

    Tomcat is just killing me on Ubuntu, the install is clean although fails in installing documents.

    zmcontrol status
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    tomcat is not running
    mta Running
    snmp Running
    spell Running

    Ziltch in /var/log/zimbra.log

    Nothing in /opt/zimbra/log

    The below is reflected in /opt/zimbra/tomcat/logs/catalina.out

    SEVERE: Error starting static Resources
    java.lang.IllegalArgumentException: Document base /opt/zimbra/apache-tomcat-5.5.15/server/webapps/host-manager does not exist or is not a readable directory
    at org.apache.naming.resources.FileDirContext.setDocB ase(FileDirContext.java:140)
    at org.apache.catalina.core.StandardContext.resources Start(StandardContext.java:3812)
    at org.apache.catalina.core.StandardContext.start(Sta ndardContext.java:3983)
    at org.apache.catalina.core.ContainerBase.addChildInt ernal(ContainerBase.java:759)
    at org.apache.catalina.core.ContainerBase.addChild(Co ntainerBase.java:739)
    at org.apache.catalina.core.StandardHost.addChild(Sta ndardHost.java:524)
    at org.apache.catalina.startup.HostConfig.deployDescr iptor(HostConfig.java:603)
    at org.apache.catalina.startup.HostConfig.deployDescr iptors(HostConfig.java:535)
    at org.apache.catalina.startup.HostConfig.deployApps( HostConfig.java:470)
    at org.apache.catalina.startup.HostConfig.start(HostC onfig.java:1118)
    at org.apache.catalina.startup.HostConfig.lifecycleEv ent(HostConfig.java:310)
    at org.apache.catalina.util.LifecycleSupport.fireLife cycleEvent(LifecycleSupport.java:119)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1020)
    at org.apache.catalina.core.StandardHost.start(Standa rdHost.java:718)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1012)
    at org.apache.catalina.core.StandardEngine.start(Stan dardEngine.java:442)
    at org.apache.catalina.core.StandardService.start(Sta ndardService.java:450)
    at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
    at org.apache.catalina.startup.Catalina.start(Catalin a.java:551)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:275)
    at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:406)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)


    and in the same file, one also notices:

    INFO: XML validation disabled
    log4j:WARN No appenders could be found for logger (org.apache.catalina.startup.TldConfig).
    log4j:WARN Please initialize the log4j system properly.


    Have been working on this for close to 3 days now, am completely stumped. Any help would be appreciated, google and forum search hasn't helped so far.

    Best,
    A

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    I'm working on this issue, and when I have more info, I'll post.

  3. #3
    Join Date
    Jun 2007
    Posts
    21
    Rep Power
    8

    Default

    Quote Originally Posted by jholder View Post
    I'm working on this issue, and when I have more info, I'll post.
    Thanks! As I'd pointed out a clean installation on Debian also came up with the same symptoms.

    A

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    The error you're seeing in catalina.out about the host-manager directory shouldn't be causing you any problems, it's only a warning about a missing directory. The log4j messages can also be ignored. Which version of Ubuntu is this? I assume this is 4.5.5 of Zimbra? What happens if you start the mailbox and tomcat manually? Did the install go OK, are there any errors in your install log?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Jun 2007
    Posts
    21
    Rep Power
    8

    Default

    Quote Originally Posted by phoenix View Post
    The error you're seeing in catalina.out about the host-manager directory shouldn't be causing you any problems, it's only a warning about a missing directory. The log4j messages can also be ignored. Which version of Ubuntu is this? I assume this is 4.5.5 of Zimbra? What happens if you start the mailbox and tomcat manually? Did the install go OK, are there any errors in your install log?
    1. Yes this is 4.5.5.
    2. When I start mailbox and tomcat manually, a status check shows them both running, on accessing the zimbraAdmin webpage it crashes and a new status check shows tomcat not running.
    3. Incidently the user webpage is not available at the time either
    4. Install went through just fine with no errors in the install logs - All clean

    If you like, I can either post the logs or you can see the same situation live on my Debian box now.

    A

  6. #6
    Join Date
    Jun 2007
    Posts
    21
    Rep Power
    8

    Default

    Quote Originally Posted by alamba View Post
    1. Yes this is 4.5.5.
    Incidently, the same behaviour noticed with 4.5.6.

  7. #7
    Join Date
    Jun 2007
    Posts
    21
    Rep Power
    8

    Default

    The problem seem to come out of unsuccessful sql dips:

    java.sql.SQLException
    MESSAGE: Access denied for user 'zimbra'@'talustechnical.com' (using password: YES)

    Resetting the password as per the wiki doesn't help even after comparing using select statements for sql as against the localconfig.

    A

  8. #8
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Yeah, so this may be a bug. We're working to attempt to repo now.

  9. #9
    Join Date
    Jun 2007
    Posts
    21
    Rep Power
    8

    Default

    Quote Originally Posted by jholder View Post
    Yeah, so this may be a bug. We're working to attempt to repo now.
    Any update on the bug fix? Do shout out incase I can help in repo.

    A

  10. #10
    Join Date
    Jun 2007
    Location
    Philippines
    Posts
    193
    Rep Power
    8

    Default

    Quote Originally Posted by alamba View Post
    Any update on the bug fix? Do shout out incase I can help in repo.

    A
    Im just curious as to your process in installing Zimbra in Dapper Drake. I have been quite successfull in my 3 attempts run Zimbra in Ubuntu 6.06. I have my Zimbra test server rigth now running on Ubuntu 6.06.

    Or maybe there is really a bug in there, but i was lucky not to toss up on them... :-)

Similar Threads

  1. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 04:43 AM
  2. upgrade woes -made into new thread
    By JustinHarlow in forum Installation
    Replies: 18
    Last Post: 06-08-2007, 12:11 PM
  3. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 11:45 AM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM
  5. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 06:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •