Results 1 to 6 of 6

Thread: User List in LDAP Backend

  1. #1
    Join Date
    Sep 2005
    Posts
    7
    Rep Power
    10

    Default User List in LDAP Backend

    We currently have our users listed in a ldap backend. Tring to get Zimbra to talk to our openLDAP server. I can get most of it to work and have all the necessary values but I get an error when setting up the GAL with out LDAP.

    What I am tring to do is set it up to where when we add new users to the LDAP Zimbra will see it and allow access. We currently have another mta that handles all inbound mail and checks the users against the LDAP.
    Last edited by rmroadee; 09-18-2005 at 06:22 PM.

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default 2 steps

    Quote Originally Posted by rmroadee
    We currently have our users listed in a ldap backend. Tring to get Zimbra to talk to our openLDAP server. I can get most of it to work and have all the necessary values but I get an error when setting up the GAL with out LDAP.

    What I am tring to do is set it up to where when we add new users to the LDAP Zimbra will see it and allow access. We currently have another mta that handles all inbound mail and checks the users against the LDAP.
    It sounds as if you've got authentication against your ldap backend working. The missing piece is provisioning on the zimbra server - we don't currently support auto-provisioning, so you'll either have to add a piece to your current provisioning system that will create the zimbra account (which you can do with our soap API) or create the accounts on zimbra manually.

  3. #3
    Join Date
    Sep 2005
    Posts
    12
    Rep Power
    10

    Default

    One more option is to create a cronjob on the Zimbra server which regularly queries ldapseach against your current LDAP. Then take the returned attributes and call zmprov ca ...

    - Ari

  4. #4
    Join Date
    Sep 2005
    Posts
    7
    Rep Power
    10

    Default

    Quote Originally Posted by ari
    One more option is to create a cronjob on the Zimbra server which regularly queries ldapseach against your current LDAP. Then take the returned attributes and call zmprov ca ...

    - Ari
    I will have too look into doing that.

    Thank You
    Viper Communications

  5. #5
    Join Date
    Sep 2005
    Location
    Los Angeles
    Posts
    51
    Rep Power
    10

    Default

    [stever@zimbra nbin]$ cat ldap2zimbra-NY-IT.sh
    for i in `ldapsearch -x -P 2 -v -h ldap.my-ldap-server.com -b cn=NY,ou=Groups,ou=NY,ou=company-1,o=NAM member equivalentToMe 2>&1 | grep ou=* | cut -d " " -f 2 | cut -d , -f 1 | cut -d = -f 2 | grep _` ; do zmprov ca $i@my-zimbra-domain.com password ; done


    this will add all users on your ldap server that belong to the Group group within the NY container, and have an atribute of NY within their entities.


    hack away at it, it will never add duplicate accounts. i use my ldap server for passwd authentication but i have a local fallback password just in case.

  6. #6
    Join Date
    Sep 2005
    Posts
    7
    Rep Power
    10

    Default

    Quote Originally Posted by riegersteve
    [stever@zimbra nbin]$ cat ldap2zimbra-NY-IT.sh
    for i in `ldapsearch -x -P 2 -v -h ldap.my-ldap-server.com -b cn=NY,ou=Groups,ou=NY,ou=company-1,o=NAM member equivalentToMe 2>&1 | grep ou=* | cut -d " " -f 2 | cut -d , -f 1 | cut -d = -f 2 | grep _` ; do zmprov ca $i@my-zimbra-domain.com password ; done


    this will add all users on your ldap server that belong to the Group group within the NY container, and have an atribute of NY within their entities.


    hack away at it, it will never add duplicate accounts. i use my ldap server for passwd authentication but i have a local fallback password just in case.
    Thank U,
    Will work with it and ajust to our needs..

    Viper Communications

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  3. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 11:34 PM
  4. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 10:19 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •