Results 1 to 6 of 6

Thread: Installing Zimbra-src

  1. #1
    Join Date
    Sep 2005
    Posts
    1
    Rep Power
    10

    Default Installing Zimbra-src

    Any know how can I install zimbra-src? im searching any howto but...

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

  3. #3
    Join Date
    Sep 2005
    Posts
    35
    Rep Power
    10

    Default Problem installing from source

    Hi,

    I'm trying to install on a debian box. But running make throws an error. It is missing something but not saying what...

    Do you know what I am missing?

    Code:
    tommie@justin:~/zimbra/ZimbraBuild$ make
    (cd /home/tommie/zimbra/ZimbraBuild/../ZimbraServer;  \
            -Dzimbra.buildinfo.version=3.0.M1_21.UNKNOWN \
            -Dzimbra.buildinfo.release=20050924000606_ -Dzimbra.buildinfo.date=20050924000606 \
            -Dzimbra.buildinfo.host=justin dev-dist ; )
    /bin/sh: -Dzimbra.buildinfo.version=3.0.M1_21.UNKNOWN: command not found
    make: *** [/home/tommie/zimbra/ZimbraBuild/../ZimbraServer/build/dist/tomcat/webapps/service.war] Error 127

  4. #4
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default Ant?

    Quote Originally Posted by tommie
    Hi,

    I'm trying to install on a debian box. But running make throws an error. It is missing something but not saying what...

    Do you know what I am missing?

    Code:
    tommie@justin:~/zimbra/ZimbraBuild$ make
    (cd /home/tommie/zimbra/ZimbraBuild/../ZimbraServer;  \
            -Dzimbra.buildinfo.version=3.0.M1_21.UNKNOWN \
            -Dzimbra.buildinfo.release=20050924000606_ -Dzimbra.buildinfo.date=20050924000606 \
            -Dzimbra.buildinfo.host=justin dev-dist ; )
    /bin/sh: -Dzimbra.buildinfo.version=3.0.M1_21.UNKNOWN: command not found
    make: *** [/home/tommie/zimbra/ZimbraBuild/../ZimbraServer/build/dist/tomcat/webapps/service.war] Error 127
    The makefile can't find ant in your path - before that -D, you'll see the macro $(ANT) - which is being expaned to nothing.

  5. #5
    Join Date
    Sep 2005
    Posts
    35
    Rep Power
    10

    Default

    Hi,

    that worked however now I run in another error.

    /bin/sh: rpmbuild: command not found
    make: *** [core] Error 127


    Does it need to make an rpm? Can't I just build it from source without making an RPM. I am using Debian.

    regards,
    Tommie

  6. #6
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default dev targets

    Search the makefile for targets with the dev prefix. The default targets are set up to build packages, but the dev-install target should do what you want.

Similar Threads

  1. Replies: 26
    Last Post: 04-19-2011, 10:24 AM
  2. QUE Failure
    By tbullock in forum Administrators
    Replies: 31
    Last Post: 07-30-2008, 01:17 PM
  3. Replies: 9
    Last Post: 03-01-2008, 08:21 PM
  4. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •